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Creating a derived field
1. Add a gridded data source.
a. In the Data Sources tab of the Data Explorer, navigate to the Gridded Data -> Remote chooser.
b. Select Realtime data from IDD -> NCEP Model Data -> Global Forecast System (GFS) -> GFS-CONUS 80km -> latest* and click Add Source.
2. Inspect the 2D native and derived fields.
a. Expand the 2D grid tree, and all of the fields listed directly under 2D grid are native fields, or fields included with the data.
b. Expand the 2D grid -> Derived tree to see all of the derived fields.  These derived fields are generated through formulas “under the hood”.  The majority of the formulas from these derived fields can be found by right-clicking on Formulas in the Field Selector and navigating to Edit Formulas -> Derived Quantities.
3. Create a new derived quantity to inspect the difference between Pressure and MSLP.
a. In the Field Selector, right-click on Formulas and select Create Formula.
b. At the top of the Formula Editor window, enter the following:
i. Description: MSLP – pressure (from %N1% & %N2%)
1. This is how the derived field will list in the Field Selector.  The ‘N1’ and ‘N2’ will allow for the name of the derived field to include the names of the two fields that it was derived from: MSLP – pressure (from Pressure_reduced_to_MSL_msl & Pressure_surface)
ii. Name: pdiff
1. This is how the derived field can be referred to in a parameter default
iii. Formula: sub(D1, D2)
1. This is the actual formula.  D1 and D2 are used as placeholders for the two fields to be operated on.  These fields will be defined in step 3d.
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c. Expand Advanced.
d. In the Derived tab, do the following:
i. Uncheck For end user and check Create derived quantities.
1. Unchecking For end user keeps the formula from being listed out with the rest of the formulas in the Field Selector.  Checking Create derived quantities creates a derived quantity (field) from this formula.
2. In the Parameters menu, right-click in the text box, navigate through the menu tree to select the GFS MSLP fieldPressure_reduced_to_MSL_msl, , type a comma ( , ), and right-click again to choose the Pressure_surface field.  These fields are the D1 and D2 specified in the formula (step 3b iii above).
3. The Categories menu here doesn’t have to be used since specific field names are being selected.  If we were using an alias, such as PRESSURE, then this Categories menu could be used to tell McIDAS-V to only look for 2D gridded pressure fields by entering GRID-2D-*.
e. Click Add Formula.

4. Investigate the placement of the derived field in the Field Selector and move it under the 2D grid -> Derived tree.
a. In the Field Selector, right-click on the GFS CONUS 80km data source and select Reload Data.  Once this is done, the data source will be re-loaded and the new formula created earlier will generate a derived quantity.  Note that this derived quantity is listed at the bottom of the Fields panel, and not under 2D grid -> Derived like the other 2D derived formulas.
b. Move this new derived field to under 2D grid -> derived by editing the formula.  To do this, right-click on Formulas in the Field Selector and select Edit Formulas -> Derived Quantities -> MSLP – pressure.
c. In the Derived tab at the bottom of the Formula Editor window, click the Define Output Categories button.
d. This Define Output Categories window allows for specifying where this derived field should be listed.  To get this field to list under 2D grid -> Derived, select Use Data, choose All for Operand, choose All for  and Category, thenand enter Derived for Append.
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- The Operand dropdown refers to which operand in the formula (D1 and D2) will be used.  This could be useful, for example, if the operands in the formula were from different categories such as a 2D and a 3D grid.  Both of these grids are 2D so All can be used.
- The Category dropdown refers to which categories were defined when creating the formula.  In this case, no categories were defined since specific field names were used.  This could be used if an alias was used in the Parameters menu when creating the formula.  For example, if TEMP (temperature) was specified as the alias, then there could be multiple categories (2D grid and 3D grid).  This Category dropdown could then be used to say if you are putting the derived field under the 2D or 3D tree in the Field Selector.
- The Append menu allows for tellinginforms McIDAS-V which menu tree (under the category tree) to place the derived field.  In this case, the field is put under a tree called Derived which is under the 2D grid tree (the tree where the MSLP and surface pressure fields are).
e. Click OK to close the Define Output Categories window.
f. Click Change Formula save the formula and close the Formula Editor window.
g. Reload the data again using the method from 4a and now the derived field will list under 2D grid -> Derived.
5. Display the data to see the difference between MSLP and surface pressure.
a. In the Field Selector, choose the 2D grid -> Derived -> MSLP – pressure field.  Select the Plan Views -> Contour Plan View and the first 5 times.  Click Create Display.
b. Probe the display with the middle mouse button to see the pressure difference in Pascals.  Change the display to millibars by going to the Layer Controls for the layer and selecting Edit -> Change Display Unit.  In this Change Unit window, use the dropdown to select millibar.  Click OK.
6. It is possible to create a parameter default so millibars or hPa would be used as the display unit by when the display is created.  This can be done by creating a parameter default.
a. In the Main Display, select Tools -> Parameters -> Defaults.
b. From the User Defaults tab, select File -> New Row.  In the Parameter menu, enter pdiff.  This pdiff was defined in 3b ii as the name associated with the formula.  Enter a Range of -10 to 400 (or whatever range you think is suitable for the data).  For Unit, use the dropdown to select millibar or type hPa if you prefer.  Click OK.
c. In the Main Display, create a new tab and then re-display the derived MSLP – pressure field.

Ensemble grids
1. Remove all layers and data sources.
2. Add a gridded data source of ensemble members.
a. In the Data Sources tab of the Data Explorer, navigate to the Gridded Data -> Remote chooser.
b. Select Realtime data from IDD -> NCEP Model Data -> Global Ensemble Forecast System (GEFS) -> GEFS-Global 1p0deg Ensemble-members -> latest* and click Add Source. 
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3. To ensure that the ensemble’s display uses the native projection of the data, verify that Projections -> Auto-set Projection is enabled in the Main Display.
4. Display MSLP data of a few ensemble members.
a. In the Fields panel of the Field Selector, select the 2D grid -> Mass -> Pressure reduced to MSL @ Mean sea level field.
b. In the Ensemble subset tab, select (command left-click) members .0, 5.0, 10.0, 15.0, and 20.0.
c. In the Times subset tab, select “Use Selected.”  Then, select the first 10 times.
d. Click Create Display.
5. Inspect the display.  Play through the loop to see how the ensemble members slowly begin diverging from each other you get further away from the initialization of the model run.
6. Note that by default the ensemble contours are colored by their member value (per the enhancement values of the colorbar in the Legend ranging from 0 to 20).  Change the display to color the contours by pressure value instead of ensemble member.
a. In the Layer Controls for the ensemble layer, uncheck Color by Member.
b. Look at the display to notice that all of the contours are now the same color.  This is because the range from the ensemble members (0-20) is still being applied to the enhancement.  Since all of the pressure values are greater than 20 Pascals, everything the color value for the enhancement table maximum is maxed out on the enhancementused.  Change the enhancement values to better fit the range of data by right-clicking on the colorbar in the Legend and selecting Change Range.  In the Change Range window, enter a From value of 95200 and a To value of 105200.
7. Use a formula to display the minimum pressure value of a few ensemble members.
a. Remove all layers.
b. In the Field Selector tab of the Data Explorer, click on Formulas.
c. In the Fields panel, select the Grids -> Ensembles -> Ensemble grid lowest values formula, the Imagery -> Image Display display type, and click Create Display.
d. In the Field Selector window, select the 2D grid -> Mass -> Pressure reduced to MSL @ Mean sea level.  In the Times tab, select the first 10 times.  In the Ensemble tab, select members .0, 5.0, 10.0, 15.0, and 20.0.  Click OK.
- This generates a display of the first 10 timesteps of the ensemble.  The ensemble members selected when evaluating the formula are utilized used to determine the lowest pressure value at each location over each timestep.
8. The formula in step 6 7 allows provides the option for individually selecting which ensemble members to useare used in for the formulas.  As an alternative, a data source can be added that already has a derived products for mean and standard deviation for all ensemble members.
a. Remove all layers and data sources.
b. In the Data Sources tab of the Data Explorer, navigate to the Gridded Data -> Remote chooser.
c. Select Realtime data from IDD -> NCEP Model Data -> Global Ensemble Forecast System (GEFS) -> GEFS-Global 1p0deg Ensemble-derived products -> latest* and click Add Source.
d. In the Field Selector, select the 2D grid -> Mass -> Pressure reduced to MSL (Unweighted mean of all members) @ Mean sea level.  Choose the Plan Views -> Contour Plan View display type, the first 10 times, and click Create Display.
NcML Aggregation
This example utilizes GEOCAT files that don’t have a time dimension contained within the files, so McIDAS-V can’t assign a time to the data.  This means that directly from the files, you can’t create a loop in the Main Display using the Time Animation Widget.  The file names of theses GEOCAT data, however, do contain date and time information.  Creating a NcML file to pull this date/time information from the file name allows for aggregating these files into one data source that can then be looped through in the Main Display.
Note: Information about NcML aggregation, including examples, can be found on Unidata’s page:
http://www.unidata.ucar.edu/software/thredds/current/netcdf-java/ncml/Aggregation.html
More general information about the NetCDF Markup Language (NcML) can be found here:
http://www.unidata.ucar.edu/software/thredds/current/netcdf-java/ncml/#NcML22
A basic NcML tutorial from Unidata can be found here:
https://www.unidata.ucar.edu/software/thredds/v4.6/netcdf-java/ncml/Tutorial.html
1. Load and display one of the GEOCAT files to observe how no time dimension is read from the data.
a. In the Data Sources tab of the Data Explorer, navigate to the General -> Files/Directories chooser.
b. Select the Grid files (netcdf/GRIB/OPeNDAP/GEMPAK) Data Type.
c. Select the geocatL2.GOES-13.2011221.190200.hdf.ci.hdf  file and click Add Source.
d. In the Field Selector, select the 2D grid -> cloud_type field and the Plan Views -> Color-Shaded Plan View display type.  Notice how there is no Times tab.
e. Click Create Display.  Notice how there is no time defined in the Time Animation Widget at the top of the display.
2. Create a NcML file to aggregate these GEOCAT files into one data source that can be played in a loop in the Main Display.
a. Using a text editor, create a file called mywrapper.ncml with the code below (note the indentation).  Save this file in the same directory as the GEOCAT data:
<netcdf xmlns="http://www.unidata.ucar.edu/namespaces/netcdf/ncml-2.2">
  <aggregation dimName="time" type="joinNew">
    <variableAgg name="cloud_type"/>
    <scan location="" dateFormatMark="geocatL2.GOES-13.#yyyyDDD.HHmmss" suffix=".hdf" subdirs="false" />
  </aggregation>
</netcdf>
b. Look over this file.  Here is an explanation of the above code:
- Line 1: The XML namespace for the netcdf markup language (NcML) version is 2.2.
- Line 2: The type of aggregation being used is specified here as joinNew.  This type of aggregation is being used since the variable name we want to aggregate (cloud_type) has the same name in each file.  We are connecting these files along a new outer dimension, which is specified here as time.
- Line 3: This defines that the variable name that we are aggregating is “cloud_type”.
- Line 4: This line specifies several things.  First, scan location specifies the location of the data files being aggregated.  Since in this case the GEOCAT data and NcML file are in the same directory, this can be set as an empty string.  The dateFormatMark is where the date/time information is pulled from the file name.  This is simply the filename up to the point where the date/time is written.  At this point, a # symbol is entered followed by a string which defines what the numbers in the date/time reference.  In this case, it is YearDay.HourMinuteSecond.  Suffix is the extension of the filenames, which is hdf in this case.  Subdirs defines if subdirectories should be looked through for files.  This is set to false, so no subdirectories will be examined.
- Lines 5 and 6 simply mark the ending of the aggregation and then the ending of the file.
3. Load this mywarapper.ncml file and display a loop of the cloud_type field.
a. In the General -> Files/Directories chooser, right-click in the Files panel where the GEOCAT files are listed and choose Refresh.
b. Select the mywrapper.ncml file and click Add Source.
c. In the Field Selector, select the 2D grid -> cloud_type field and the Plan Views -> Color-Shaded Plan View display type.  Notice how there is now a Times tab with 4 timesteps, one for each GEOCAT file in the directory with the NcML wrapper file.
d. Click Create Display.  Note that the Time Animation Widget at the top of the display now has the ability to play through a loop of the data.
4. Look back in the Field Selector to examine some of the other fields.
a. Select the 2D grid -> box_average_11um_ctc file and note that there is no Times tab in the Field Selector.  The reason for this is that the only field that was aggregated in the NcML file was cloud_type, as set in the variableAgg name.  If we wanted to aggregate multiple fields together, additional variableAgg name lines can be added to the mywrapper.ncml file.
NcML Editing
The above example worked with example files that were already CF-Compliant, meaning these files could be loaded without error into McIDAS-V.  In the real world, users may come across files that aren’t CF-Compliant.  This section goes over a simple example of how NcML editing can be used to load a non-complaint HDF file into McIDAS-V.
1. Attempt loading the patmosx_noaa-14_asc_2000_005.level2b.hdf file into McIDAS-V.
a. In the Data Sources tab of the Data Explorer, navigate to the General -> Files/Directories chooser.
b. Select the Grid files (netcdf/GRIB/OPeNDAP/GEMPAK) Data Type.
c. Select the patmosx_noaa-14_asc_2000_005.level2b.hdf file and click Add Source.  Note that this pops up the Non-Compliant NetCDF Tool window.
2. Determine the issue(s) with the file.
a. In the Non-Compliant NetCDF Tool window, click the NcML Editor.
b. This file is fairly lengthy, but scroll to the bottom of the text and note how the longitude and latitude variables are defined:
<variable name="longitude" shape="fakeDim0" type="float">
<variable name="latitude" shape="fakeDim1" type="float">
- These variables should have shapes of “longitude” and “latitude” respectively.
3. Create a NcML file that correctly defines the shapes of these variables.
a. Using a text editor, create a file called patmosx_noaa_14_asc_2000_005.level2b.hdf.ncml with the code below (note the indentation).  Save this file in the same directory as the patmosx HDF file.
<?xml version="1.0" encoding="UTF-8"?>
<netcdf xmlns="http://www.unidata.ucar.edu/namespaces/netcdf/ncml-2.2"
    location="patmosx_noaa-14_asc_2000_005.level2b.hdf">

  <variable name="latitude" shape="latitude">
  </variable>

  <variable name="longitude" shape="longitude">
  </variable>

</netcdf>

b. Look this file over.  Here is an explanation of the above code:
- Line 1: Defines the encoding of the file as UTF-8.
- Lines 2 and 3: The XML namespace for the netcdf markup language (NcML) is version 2.2.  This also sets the location of the original HDF file.  The extra block of spacing before “location” allows for breaking up one long line into multiple lines.
- Lines 4-7 (not including spaces):  This re-defines the shapes of the latitude and longitude variables as “latitude” and “longitude” respectively.
- Line 8: Denotes the end of the file.
Note that this file only includes two of the variables included in the HDF file, longitude and latitude.  This is because these are the only two variables that aren’t defined in a CF-Compliant manner.
4. Load this patmosx_noaa_14_asc_2000_005.level2b.hdf.ncml file and display a loop of the top of atmosphere reflectance at the nominal wavelength of 0.65 microns - NOAA CDR field.
a. In the General -> Files/Directories chooser, right-click in the Files panel where the patmosx HDF file is listed and choose Refresh.
b. Select the patmosx_noaa_14_asc_2000_005.level2b.hdf.ncml file
c. In the Field Selector, select the 2D grid -> top of atmosphere reflectance at the nominal wavelength of 0.65 microns – NOAA CDR field and the Plan Views -> Color-Shaded Plan View display type.
d. Click Create Display to display the data in the Main Display window.
Extra: As an alternative to using a text editor to generate the NcML files in the previous examples, Netcdf Tools User Interface (ToolsUI) can be used (http://www.unidata.ucar.edu/downloads/netcdf/ netcdf-java-4/index.jsp).  In the last example, where the shapes of longitude and latitude were re-defined, ToolsUI could be used as follows:
1. Open ToolsUI and navigate to the NcML tab.
2. Select the open Local dataset button ([image: ]), navigate to the HDF file and click Open.  This loads the text of the HDF file into ToolsUI.
3. Scroll down to where the NcML variables are defined.  The first variable listed is longitude with a shape of “fakeDim0”.  Change the shape to “longitude”.  The second variable listed is latitude with a shape of “fakeDim1”.  Change the shape to “latitude”.
4. Select the Save NcML button ([image: ]), select your desired filename and location, and click Save.  This file can now be loaded into McIDAS-V.  Note that this NcML file does contain every variable included with the data, even though only longitude and latitude were changed.

NUCAPS Data
NUCAPS Suomi NPP data can be ordered from NOAA CLASS in the NetCDF format.  There is currently limited capability of working with this data in McIDAS-V.  Here are some ways the data can be viewed.
1. Load the NUCAPS NetCDF file into McIDAS-V and create a Point Data Plot display.
a. In the General -> Files/Directories chooser, navigate to the directory with the NUCAPS data.
b. Choose the netcdf/GEMPAK Point Data files Data Type.
c. Select the NUCAPS*.nc file and click Add Source.
d. In the Field Selector, select the Point Data field and the Point Data -> Point Data Plot display type.
e. Click Create Display.
2. Note that the display defaults to a loop of data since every point has a different timestep.  This limits the display to showing only one point at a time.  Adjust the display so that multiple times can be seen at once.
a. In the Times tab of the Layer Controls, change Show to Multiple.  This shows every timestep at once, regardless of where you currently are in the loop.
b. Note that not every point is plotted.   This is because decluttering is enabled.  To disable declutter, go to the Layout tab of the Layer Controls and disable Declutter.  For this example, we want to have decluttering enabled, so make sure to enable decluttering before proceeding.
3. McIDAS-V defaults to plotting the location at each timestep, which is why there are plus signs (+) at each location and no real data values.  Create a layout model to show satellite height.
a. In the Layer Controls, click the double-down blue arrows next to Layout Model and select Edit to open the Layout Model Editor.
b. In the Layout Model Editor, select File -> New.
c. In the New Layout Model window, enter a name of Satellite Height and click OK.
d. On the left side of the Layout Model Editor, choose 123 Value and add this shape to the layout model.
e. In the Properties window for the shape, for Parameter, right-click and navigate to Current Fields -> Point Data -> Satellite_Height.  Click OK.
f. In the Layout Model Editor, select File -> Save and close the Layout Model Editor.
g. In the Layer Controls tab of the Data Explorer, click the double down blue arrow next to Layout Model and select Satellite Height.  Now, the numerical value of the satellite height will be plotted at each location.
4. Explore how editing the featureType attribute of the file can expand display options.
a. The original NetCDF file does not have any featureType attribute assigned to it.  The following line was added to the NUCAPS NcML file:
<ncml:attribute name="featureType" value="trajectory" />
Load this file through the General -> Files/Directories chooser with the Trajectory Sounding files Data Type.
b. In the Field Selector, select the Track -> CrIS Radiances for each FOR.  Select the top GridTrajectory -> Trajectory Colored By Parameter display type and click Create Display.
c. This defaults to showing the full length of the track.  You can adjust this by going to the Times tab in the Layer Controls.  Set Times to Use to Track Times to use the times from the file and set Show Every to 0.05 and press Enter.
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The low value of 0.05 seconds is needed because the points in the track are very close to each other in time.  The original value of 1 minute was high enough to show the full length of the track.

GPS Radio Occultation Data
1. Load in the GPS radio occultation NetCDF file.
a. In the General -> Files/Directories chooser, navigate to the directory with the GPS data.
b. Choose the Trajectory Sounding files Data Type.
c. Select the atmPrf*.nc file and click Add Source.
2. Create a Skew-T display of the data.
a. In the Field Selector, select the Skew-T data field, the Soundings -> Trajectory Skew-T display type, and click Create Display.
b. In the Layer Controls, inspect the sounding in the Sounding Chart tab.
c. In the Layer Controls, inspect the Table tab to see the temperature value at different pressure and altitude values.
3. Create a grid trajectory display of the data.
a. In the Field Selector, select the Track -> Basic -> Dry temperature field, the top GridTrajectory -> Trajectory Colored By Parameter display type, and click Create Display.
b. Step through the loop to see how the temperature values change along the trajectory.  Note that the temperature colors are mapped to the enhancement in the Legend.
c. Similar to the NUCAPS example, the number of timesteps in the trajectory can be adjusted in the Times tab of the Layer Controls.  Set Times to Use to Track Times to use the times from the file and set Show Every to 0.05 and press Enter.
d. Play through the loop again to see how the display has changed.
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