		Page 24 of 25 
McIDAS-V Tutorial 
Using GOES-16 and JPSS Data
Created May 2018 (software version 1.7u1)

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in SSEC's 40-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and manipulate data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's IDV libraries. The functionality of SSEC's HYDRA software package is also being integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data.
More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/.
If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share information with other users.
This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the document entitled McIDAS-V Tutorial – Installation and Introduction.
Terminology
There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer).
The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field Selector, displayed in the Main Display, and output is formatted in the Layer Controls.
Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources).

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).
ABI Introduction
McIDAS-V currently supports ABI netCDF data through remote servers as well as through the local file chooser on all platforms.  Local servers for ABI data are currently available on OS X and Linux platforms.  This tutorial will cover how to access this data through remote servers and different ways that the data can be displayed and interrogated in McIDAS-V.


Accessing GOES-16 ABI Data from a Remote Server – 1 Timestep

1. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser.  Select lead.unidata.ucar.edu as the Server and RTGOESR as the Dataset.  Click Connect.

2. Select FD – GOES-16 FD all bands as the Image Type.

3. In the Times panel, select the Relative tab.  For Number of times, enter 1 and click Add Source to create a data source of the most recent time.
 
4. Display band 13 temperature data.

a. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the data.  Select the 10.3 um IR Surface & cloud -> Temperature field.

b. From the Displays panel, select the Imagery -> Image Display display type.

c. Select the Region tab to see a low-resolution preview image of the data.  Note that there is a green box drawn around the preview image.  Any data inside this bounding box will be displayed.

d. Select the Advanced tab to see information about the band and calibration selected.  These values match the domain of the data selected in the Region tab, so it covers the entire domain of the data.  Notice that the Image Size is only 904 x 904 when the raw size of the data is 5424 x 5424.  The magnification of the data is set to -6, -6.  This reduction in resolution is the default to allow for an efficient display of the data.  Modify the Advanced tab to display full resolution data over Florida.

i. Coordinate Type: Latitude/Longitude
ii. Location: Center
iii. Lat: 28; Lon: -83.5
iv. Image Size: 400 x 400
v. Magnification: 1 x 1

e. Click Create Display.

5. Investigate the display.

a. In the Main Display window, practice navigating around in the display.  To do this, use Control+Right-Click+Drag to translate the display.  This shifts the data left/right and up/down without rotating the display.  Zoom in on the display by scrolling down on the mouse wheel.  As an alternative, select a region in the Main Display by using Shift+Left-Click+Drag to zoom in on a specific domain.

b. Probe individual pixel values by holding down the middle mouse button over the display.  This will print out probe values at the bottom of the display.  Notice that latitude, longitude, and temperature values are included in the probe output.

c. Navigate to the Histogram tab of the Layer Controls to see a histogram of band 13 temperature values.

6. Add a data transect to the display.

a. From the Field Selector tab of the Data Explorer, select the Data Transect display type and click Create Display.

b. In the Main Display window, there is a red line that is referred to as the data transect.  The values along this transect line are output in the Layer Controls tab of the Data Explorer.  The two end points of the transect can be moved around by Left-Clicking+Dragging them, or by entering new Lat/Lon values at the bottom of the Display tab in the Layer Controls.  The transect line as a whole can be moved by Left-Clicking+Dragging the triangle in the middle of the transect line. 

7. Create a display of the 10.3 micron temperatures so only values of 273K and less are plotted.

a. Add a new two-paneled map display by selecting File -> New Display Tab -> Map Display -> Two Panels menu item.

b. Left-Click in the left panel to make this panel active.  The active panel has a blue frame around it, and this is the panel any displays will be added to.

c. In the Field Selector tab of the Data Explorer, select the 10.3 um IR Surface & cloud -> Temperature field.  Choose the Imagery -> Image Display display type and click Create Display. 

d. Create the cloud mask display.

i. Left-Click in the right panel to make this panel active.  The active panel has a blue frame around it, and this is the panel any displays will be added to.

ii. In the Field Selector tab of the Data Explorer, select Formulas.

iii. Select the Imagery -> Mask Value formula, the Imagery -> Image Display display type, and click Create Display.

iv. In the Select input window, enter the following and then click OK:

1. comparison: <
2. cutoff: 273
3. useNaN: 1
Notes: The comparison is set to < or ‘less then’ since the goal is to display values less than 273, which was set as the cutoff value.  Setting useNaN to 1 makes it so that if the pixels were probed outside of the masked range (where values are greater than 273) they wouldn’t show a value.  useNaN can be set to 0 as well, and in this case pixel values greater than 273 would probe as 0.  Note that if these pixel values are set to 0, then these 0 values will be included in any calculations with the data that may be done later.

v. In the new Field Selector window, for inputFieldForMask, select 10.3 um IR Surface & cloud -> Temperature.  This is the field that is being masked.

vi. For displayFieldToBeMasked, select 10.3 um IR Surface & cloud -> Temperature.  This is the field that will be displayed where the inputFieldForMask is less than 273 degrees.  In this case, we are displaying the same field that is being masked.

vii. Click OK.

e. Investigate the display.  Note that as one of the panels is navigated, the other will be navigated in the same way.  This is because by default panels in the same tab are set to share views.  This setting can be disabled in a panel by unchecking Projections -> Share Views in the display panels.

8. Create a display of a subtraction of two bands.

a. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel menu item, or by clicking the Add new tab ([image: ]) button in the Main Toolbar.

b. In the Field Selector tab of the Data Explorer, select Formulas.

c. Select the Miscellaneous -> Simple difference a-b formula, the Imagery -> Image Display display type, and click Create Display.

d. In the new Field Selector window, for a, select the 8.44 um IR Total WV cloud phase, dust -> Temperature field.  For field b, select the 7.34 um IR Lower-level WV, winds & SO2-> Temperature field.

e. Click OK in the Field Selector window to display the band subtracted data.

f. Right-Click on the colorbar of the ABI layer in the Legend and select the System -> Inverse Gray Scale enhancement.



g. Add latitude and longitude labels to the display.

i. Left-Click on the blue text for the Default Background Maps layer in the Legend to get to the Layer Controls tab of the Data Explorer for the layer.

ii. From the Lat/Lon tab of the Layer Controls, set the following:

1. Check the visibility checkboxes for Lines and Labels to plot them in the display.
2. Lines: Interval: 5.0
3. Labels: Interval: 5.0; At Longitudes: -85.0, At Latitudes: 30.0, Color: light blue
4. Font: Arial; Bold; 20

[image: ] 

h. Investigate the display to see the latitude and longitude lines and labels.  Probe the data to see the temperature difference between the two bands.

9. Capture an image of the display.

a. From the Main Display, select the View -> Capture -> Image menu item.

b. In the Save As text field, enter the name to give your image, for example: band_subtraction.gif.

c. Use the dropdown below Save As to select the directory to save your image to.

d. Under Capture What, select Current View.  This will capture an image of the display without including any other components of the Main Display such as menu items and the Legend.

e. Click Save.

f. View your saved image to verify the image was captured correctly.


Accessing GOES-16 ABI Data from a Remote Server – 5 Timesteps

10. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and Data Sources menu item from the Main Display.

11. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel menu item.  Close any previously-existing tabs.

12. In the Data Sources tab of the Data Explorer, navigate to the Satellite -> Imagery chooser.  In the Relative tab of the Times panel, for Number of times, enter 5 and click Add Source.

13. Display a loop of 10.4um Temperature data over Wisconsin and Illinois.

a. Navigate to the Field Selector tab of the Data Explorer to see a listing of each band included with the data.  Select the 10.3 um IR Surface & cloud -> Temperature field.

b. From the Displays panel, select the Imagery -> Image Display display type.

c. Navigate to the Advanced tab, and enter the following information:
i. Coordinate Type: Latitude/Longitude
ii. Location: Center
iii. Lat: 42; Lon: -89.6
iv. Image Size: 450 x 450
v. Magnification: 1 x 1

d. Click Create Display.

14. Investigate the display.

a. The Main Display now has a loop of the 5 most recent times of data in the FD dataset.  As done in step 5 earlier, navigate around and zoom in/out of the display.  Probe the display by holding down the middle mouse button over the data.

b. Use the Time Animation Widget at the top of the display panel to play through a loop of the data.

[image: ]

c. Click the Properties button ([image: ]) in the Time Animation Widget to modify settings of the animation including the dwell rate (the time spent on each frame in the animation).  As an example, set the Forward, First, and Last dwell rates to 0.2 and click OK.  This reduced dwell rate allows the display to loop faster.

15. Change the enhancement used in the display.

a. Stop the animation by clicking the Stop Animation button in the Time Animation Widget ([image: ]).

b. Right-Click on the colorbar of the ABI layer in the Legend and select the Satellite -> GOES-R -> ABI IR Temperature enhancement. 

16. Add a color scale to the display.

a. Right-Click on the ABI layer in the Legend and select Edit -> Properties.

b. [image: ]In the Properties window, navigate to the Color Scale tab and set the following:
i. Visible: Check this option to add the color scale to the display.
ii. Position: Top.  This will position the color scale at the top of the display.
iii. Labels -> Visible: Check this option to add numerical labels to the color scale.
iv. Labels -> Show Unit: Check this to add the display unit to the color scale labels.
v. Labels -> Font: Set the size to 32.

c. Click OK.

17. Create a Data Probe/Time Series display of band 13 temperature data.  This display type allows for plotting how temperature values at a specific location change through time throughout the loop.

a. In the Field Selector tab of the Data Explorer, select the Data Probe/Time Series display type and click Create Display.

b. The Layer Controls tab of the Data Explorer now shows a time series display of temperature values at the location of the probe in the Main Display.  Change the range of the y-axis (temperature values) to match the range of the data.

i. At the bottom of the Layer Controls tab, Double-Click on the 186-Band13_TEMP parameter to open the Properties window.

ii. In the Properties window, change the Range text boxes to a Min of 180 and a Max of 320 to match the range of the enhancement in the Main Display.

iii. Click OK to apply the new range in the Layer Controls and close the Properties window.

c. Move the data probe in the Main Display around with Left-Click+Drag.  The time series display in the Layer Controls automatically updates itself as the probe’s location changes.

d. The data probe in the Main Display can also be set to a specific latitude/longitude value by using the Lat and Lon text boxes at the bottom of the Layer Controls.  For example, enter values of 38.6 for Lat and -88.1 for Lon.  Note that you must press Enter in each text field for latitude/longitude to update the location of the data probe.


Accessing ABI Data from a Remote Server through Scripting

Both of the previous sections of this tutorial can be replicated through scripting.  This section covers creating a loop of ABI data and applying an enhancement to the display.

18. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and Data Sources menu item from the Main Display.

19. From the Main Display, select Tools -> Formulas -> Jython Shell to open the Jython Shell.

20. The Jython Shell defaults to single-line input mode, where only one line of code can be executed at a time.  This script is more than one line long, so it requires multi-line input.  To switch to multi-line input, click the double-down blue arrow button ([image: ]) to the right of the text entry box.

21. In a text editor, open the Data/GOES16/abiLoop.py file.  Copy this text and paste it into the Jython Shell.

22. To evaluate this code, click the Evaluate button, or use Shift+Enter.  In-line documentation of what the script is doing can be found in the script (lines that begin with ‘#’ are comments).  More information about McIDAS-V scripting can be found in the User’s Guide as well as the Scripting and User Functions tutorials.

23. After you are done analyzing the display created with the script, close the new display window.



Using GOES-16 GLM and Satellite Derived Winds

24. [image: ]This section of the tutorial uses a new Data Type through the General -> Files/Directories chooser as well as a new layout model which is must be added via a plugin.  Add this plugin. 

a. From the Main Display window, navigate to the Tools -> Plugins -> Manage menu item to open the Plugin Manager.

b. The top of the Plugin Manager lists plugins currently installed, and the bottom panel lists the various plugins available for installation.  Expand the Data Sources tree and click the green Install Plugin button next to GLM NetCDF Files.

c. This pops up a message notifying the user that McIDAS-V must be restarted to complete the installation of the plugin.  Click OK through this message and restart McIDAS-V.

25. Display GOES-16 band 14 data.

a. From the General -> Files/Directories chooser, navigate to the <local data>/Data/GOES16/ABI directory.

b. Select the GOES16_CONUS* file.

c. From the Data Type dropdown, select Grid files (netCDF/GRIB/OPeNDAP/GEMPAK).

d. Click Add Source.

e. In the Fields panel of the Field Selector, verify that brightness_temperature is selected.

f. In the Displays panel of the Field Selector, select Imagery -> Image Display.

g. Click Create Display.

26. Modify the display of the GOES-16 band 14 data.

a. To make the cold clouds white and the relatively warmer land darker, change the enhancement used by the displayed layer by Right-Clicking on the colorbar in the Legend and selecting System -> Inverse Gray Scale.

b. Disable the wireframe box around the display by selecting View -> Show -> Wireframe Box in the display panel.

c. Other layers will be added to the display in the next several steps.  To maintain the current projection, from the display panel, disable Projections -> Auto-Set Projection.

27. Add a data source of six consecutive (2 minutes total) GLM files as group data.

a. From the General -> Files/Directories chooser, navigate to the <local data>/Data/GOES16/GLM directory.

b. Use Shift+Left-Click to select all six OR_GLM-L2-LFCA* files.

c. From the Data Type dropdown, select GLM Groups Data files.  This data type was added from the plugin that was installed in step 24 above.

d. Click Add Source.

28. By default, each data point in each GLM file has its own timestep, which would create a loop of potentially thousands of frames.  Bin all of the times together so each data point plots at the same timestep.

a. From the Field Selector, Right-Click on the 6 Files Data Source and choose Properties.

b. At the bottom of the Properties tab of this window, find the Time Binning section.  Set the following using the dropdown menus: 

Bin Size: 5 minutes
Round To: 1 hour

A bin size of 5 minutes is large enough to contain all of the data.  The round to value of 1 hour sets this timestep to be right on the hour, 13Z, thus matching the time of the band 14 data displayed earlier.

c. Click OK at the bottom of the Properties window.

29. Display the GLM data.

a. In the Fields panel of the Field Selector, select Point Data.

b. In the Displays panel of the Field Selector, choose the Point Data -> Point Data Plot display type.

c. In the Layout Model subset tab, click the double-down blue arrows next to None and choose GLM -> Group.  This layout model was added from the plugin that was installed in step 24 above.

d. Click Create Display.

30. Investigate and modify the display of GLM data.  Note that the points of GLM data are parallax-corrected (from the data itself), so they may not perfectly match up with the location of the band 14 imagery, which is not parallax-corrected.

a. The pink plus signs in the display represent the GLM group data points.  As you zoom in and out of the display, you’ll see the number of points change.  This is because of decluttering that McIDAS-V does to the display.  To modify the decluttering, Left-Click on the 6 files data source in the Legend to get to the Layer Controls of the layer.  Disable the Declutter checkbox to show every point.  Another option would be leaving Declutter enabled (checked) and adjusting the Density slider.  As the slider moves to the right, more points will be shown.

b. If you wish to change the size of the plus signs in the display, adjust the Scale value in the Layer Controls.  Decreasing the value from 1 (for example, 0.5) will make the points smaller.  Increasing the value from 1 (for example, 2) will make the points larger.

31. Add a data source of satellite derived winds.

a. From the General -> Files/Directories chooser, navigate to the <local data>/Data/GOES16/Derived Winds directory.

b. Select the OR_ABI-L2-DMWC* file.

c. From the Data Type dropdown, select netCDF/GEMPAK Point Data files.

d. Click Add Source.

32. Display the satellite derived winds.

a. In the Fields panel of the Field Selector, choose the Point Data field.

b. In the Displays panel of the Field Selector, choose the Point Data -> Point Data Plot display type.

c. A new layout model will be imported to plot the satellite derived winds colored by speed.  To do this, go to the Layout Model subset tab of the Field Selector and choose Edit.

d. From the Layout Model Editor window, select File -> Import.

e. From the Layout Model import window, select the <local data>/Data/GOES16/G16_Winds.ism file and click Open.

f. From the Layout Model Editor window, select File -> Save and close the Layout Model Editor.  

g. From the Layout Model subset tab of the Field Selector, click the double-down blue arrows next to None and choose G16_Winds <local>.

h. Click Create Display.

33. Investigate and modify the display of GOES-16 satellite derived winds using the same methods used in step 30 above with GLM data.


JPSS Introduction

McIDAS-V has the ability of displaying JPSS (Suomi NPP and NOAA-20) data through the Under Development -> Imagery – JPSS chooser.  Among the JPSS products that McIDAS-V can display are data from the VIIRS (all bands of SVM and SVI, EDRs, Day/Night band), CrIS, and ATMS instruments.  In order for the data to be recognized by McIDAS-V, the geolocation files must be contained within the same directory as the data.  Some sources of data, including NOAA’s CLASS, package the data and geolocation files together by default.  Other sources of JPSS data may store the geolocation in a separate file from the data.  Note that this chooser is still under development and improvements in functionality as well as the ability to utilize different JPSS products will be added in the future.

Installing the VIIRS Formulas Plugin

34. [image: ]This section of the tutorial uses two formulas specifically designed to work with VIIRS data.  These formulas are not packaged as part of the core group of formulas in McIDAS-V, and must be added via a plugin.  Add this plugin.

a. From the Main Display window, navigate to the Tools -> Plugins -> Manage menu item to open the Plugin Manager.

b. The top of the Plugin Manager lists plugins currently installed, and the bottom panel lists the various plugins available for installation.  Expand the Miscellaneous tree and click the green Install Plugin button next to VIIRS Formulas.

c. This pops up a message notifying the user that McIDAS-V must be restarted to complete the installation of the plugin.  Click OK through this message and restart McIDAS-V. 


Display a Single Granule of NOAA-20 Data

35. Load a single granule of NOAA-20 SVM03 VIIRS data.

a. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS.

b. Under Files, select the following file:

<local path>/Data/ NOAA20/VIIRS/SVM03_j01_d20180513_t1814201*

Note that the <local path>/Data/NOAA20/VIIRS directory contains nine SVM data granules (three timesteps of three different bands).  There are also three GMTCO* geolocation files (one for each timestep) that are in this directory, but are either not visible or grayed out through this Imagery – JPSS chooser.

c. Click Add Source.

Note that the first time a JPSS granule is added through this chooser, a Plugin Compatibility Notice window may appear letting users of the older version of the VIIRS Formulas plugin know that a new one is available.  In step 34 above the most recent version of this plugin was installed.  Click the Do not show this message again checkbox and click OK.

36. Display Radiance data at low resolution.

a. In the Field Selector tab of the Data Explorer, select the VIIRS-M3-SDR_All/Radiance field, and the Imagery -> Image Display display type.

b. Note that the Region tab in the Field Selector shows a preview image of the selected field.

c. Click Create Display.

d. Investigate the display and note that the resolution of the display is course, not the native 750 meter resolution of the data.  This is because no subsetting of the data was done in the Region tab of the Field Selector.

37. Display Radiance data at the full resolution of the data.

a. From the Region tab of the Field Selector, use Shift+Left-Click+Drag to draw a green box in the data.  Any data contained within this box will be displayed at full resolution.  Note that the entire box must be contained within the granule’s data.

b. Click Create Display.

c. Investigate the display and note that the resolution of the data has improved.  However, note that the bowtie deletion lines still exist on the east and west edges of the granule.

38. Use the swathToGrid formula to display the Radiance data at full resolution with the bowtie deletion lines removed.

a. In the Field Selector tab of the Data Explorer select Formulas.

b. Choose the swathToGrid formula, the Imagery -> Imagery Display display type, and click Create Display.  Note that this formula was added as part of the plugin installed in step 34 above.

c. In the Select input window, enter a value of 750 for resolution in meters and click OK.

d. In the Field Selector window, select the VIIRS* -> Image -> VIIRS-M3-SDR_All/Radiance field.

e. Wait for the Region tab to appear at the bottom of the Field Selector window showing a preview image of the granule and click OK.

f. Investigate the display and notice that the data is now displayed at full resolution with the bowtie deletion lines removed.

g. When you are done investigating the display, remove all layers and data sources.

Create a RGB Display with Aggregated Granules

McIDAS-V has the ability to aggregate several small granules into one large one by selecting multiple time-consecutive granules in the Data Sources tab of the Data Explorer before clicking Add Source.  Multiple bands can also be included in the same data source if the times match up between the bands.

39. Create a data source of three time-consecutive granules of three visible SVM bands.

a. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS.

b. Use Shift+Left-Click to select all of the SVM* data files.

c. Click Add Source.

d. From the Field Selector tab of the Data Explorer, notice that all three bands (SVM03, SVM04, and SVM05) are included in the list in the Fields panel.

40. Use the VIIRS_M_RGB(M5, M4, M3) formula to create a RGB display from the data source.

a. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel menu item.  Close any previously-existing tabs.

b. In the Field Selector tab of the Data Explorer, select Formulas.

c. Choose the VIIRS_M_RGB(M5, M4, M3) formula, the RGB Composite display type, and click Create Display.

d. In the Field Selector window, select the following:

i. Field M5: VIIRS 2018-05-13 18:11:28 GMT -> Image -> VIIRS-M5-SDR_All/Radiance.

Once the Region tab appears, use Shift+Left-Click+Drag to draw a bounding box within the bounds of the data.  This subsetting step only has to be done for this field (the Red component of the formula) since this domain will be carried over to the Green and Blue fields.  Make sure that the subsetted area includes land, water, and data near the east and/or west edges of the granule to include the bowtie deletion regions.

ii. Field M4: VIIRS 2018-05-13 18:11:28 GMT -> Image -> VIIRS-M4_SDR_All/Radiance.

iii. Field M3: VIIRS 2018-05-13 18:11:28 GMT -> Image -> VIIRS-M3_SDR_All/Radiance.

e. Once all three Region subset tabs are visible, click OK at the bottom of the Field Selector window.

41. Investigate and brighten the display to make it easier to interpret.

a. From the Main Display window, notice that the display looks mainly black and white, though the bowtie deletion lines have been removed and the data is at full (750 meter) resolution.

b. Click on the blue RGB Composite text in the Legend of the Main Display to get to the Layer Controls tab of the Data Explorer.

c. The intensities of the red, green, and blue colors are controlled by their Gamma values.  Adjust all three colors to have a Gamma value of 0.4 by typing 0.4 into the Common Gamma field of the Layer Controls and click Apply to All Gamma Fields.

d. Go back to the Main Display and notice how the red, green, and blue colors are now more intense and you can see green and brown over the land and blue over areas of water.

e. By default, a wireframe box is drawn in the Main Display.  This is the white box going around and partially through the data.  Disable the wireframe box by unselecting View -> Show -> Wireframe Box from the panel in the Main Display window.

f. When you are done investigating the display, remove all layers and data sources.

Note that this formula suggests the user selects SVM05 for Red, SVM04 for Green, and SVM03 for Blue to create a true color RGB display.  However, any bands can be used to create different types of RGB displays.


Using CrIS Data in McIDAS-V

This section utilizes CrIS data from NOAA-20.  The <local path>/Data/NOAA20/CrIS directory contains SCRIS data files and GCRSO geolocation files.  Only the SCRIS data files will be listed in the Imagery – JPSS chooser.

42. Create a data source of nine time-consecutive granules of SCRIS data.

a. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS.

b. In the Files panel, navigate to the <local path>/Data/NOAA20/CrIS directory.

c. Use Shift+Left-Click to select all of the SCRIS* data files.

d. Click Add Source.

43. Display the data and investigate the display.

a. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel menu item.  Close any previously-existing tabs.

b. In the Fields panel of the Field Selector, verify that the CrIS-SDR_All/ES_RealLW field is selected.

c. In the Displays panel of the Field Selector, select the Imagery -> MultiSpectral Display display type.

d. Click Create Display.

e. This display type creates a grayscale display in the Main Display window along with two data probes (originally stacked on top of each other), as well as a spectra in the Layer Controls.  Move the probes around in the Main Display window by using Left-Click+Drag to place one probe over a cloud and one over cloud-free land.  Compare the spectras in the Layer Controls.

f. From the Layer Controls tab of the Data Explorer, use Left-Click+Drag to move the green selector line to a new wavenumber value.  Notice that the grayscale display in the Main Display window updates itself to reflect the new wavenumber.

g. When you are done investigating the display, remove all layers and data sources.


Using ATMS Data in McIDAS-V

This section utilizes ATMS data from NOAA-20.  The <local path>/Data/NOAA20/ATMS directory contains SATMS data files and GATMO geolocation files.  Only the SATMS data files will be listed in the Imagery – JPSS chooser.

44. Create a data source of eight time-consecutive granules of SATMS data.

a. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS.

b. In the Files panel, navigate to the <local path>/Data/NOAA20/ATMS directory.

c. Use Shift+Left-Click to select all of the SATMS* data files.

d. Click Add Source.

45. Display the data and investigate the display.

a. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel menu item.  Close any previously-existing tabs.

b. In the Fields panel of the Field Selector, select MultiSpectral -> ATMS-SDR_All/BrightnessTemperature.

c. In the Displays panel of the Field Selector, select the Imagery -> MultiSpectral Display display type.

d. Click Create Display.

e. Investigate the display as done in steps 43e and 43f above.  One difference is this ATMS data uses channel numbers instead of wavenumbers.  Notice how the longer wavelengths make areas with more precipitation stand out over Iowa and the Atlantic Ocean.


Using Day/Night Band Data in McIDAS-V

This section utilizes VIIRS Day/Night band data from Suomi NPP.  This data, ordered from NOAA CLASS, packages the data (SVDNB) and geolocation (GDNBO) into the same file.  Each file includes several small granules aggregated together to cover a relatively large geographical area.
46. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and Data Sources menu item from the Main Display.

47. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel menu item.  Close any previously-existing tabs.

48. Create a data source of the two time-consecutive files of GDNBO-SVDNB* files.

a. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS.

b. In the Files panel, navigate to the <local path>/Data/SuomiNPP directory.

c. Use Shift+Left-Click to select both of the GDNBO-SVDNB* files.

d. Click Add Source.

49. Display the data and investigate the display.

a. In the Fields panel of the Field Selector, select IMAGE -> VIIRS-DNB-SDR_All/Radiance.

b. In the Displays panel of the Field Selector, select the Imagery -> Image Display display type.

c. [image: ]In the Region tab of the Field Selector, use Shift+Left-Click+Drag to draw a green bounding contained entirely within the data over the eastern United States extending into the Atlantic (similar to this image).  Any data in this bounding box will be displayed at the full resolution of the data.

d. Click Create Display.

50. Investigate the display.

a. In the Main Display window, you will likely notice that no data is visible.  This is due to the enhancement range values being set based on the minimum and maximum values contained in the data.  Adjust the enhancement by Right-Clicking on the enhancement in the Legend and choosing Change Range….

b. In the Change Range window, enter From and To values that better match up with the radiance values contained in the display.  For example, you can use values of:

From: 8.8E-10
To: 1.9E-8

c. This is near full-moon scene, which allows for a display similar to a daytime visible image to be viewed.  Other features, such as city lights and ships can be viewed in this scene.  The range set in step 50b can be expanded or contracted on either end to make different features easier to see. 


Problem Sets

The previous examples were intended to give you a general knowledge of how to load and display JPSS data.  The problem sets below are intended to introduce you to new topics related to the data, as well as challenge your knowledge of McIDAS-V.  We recommend that you attempt to complete each problem set before looking at the solutions, which are provided below the problem set.

Note that this example utilizes Suomi NPP data from NOAA CLASS.  The files contain both the data and geolocation in the same file.  Also, several small granules are aggregated together into one file, so a relatively large geographic domain is covered by a single file.

1. Using the <local path>/Data/SuomiNPP/GMODO-SVM03-SVM04-SVM05* file, create an RGB image using the Reflectance field of all three bands.  Create the display by using the VIIRS_M_RGB(M5,M4,M3) formula.  Display the data at full-resolution and make sure to include a large portion of the granule in your subsetted region.  Adjust the Common Gamma field in the Layer Controls to make the individual colors stand out more in the display.

1. Looking at the display over the Great Lakes, it is difficult to discern between clouds and snow over the land. Using the file loaded from question 1, display SVM14 brightness temperature data with the swathToGrid formula over the Great Lakes region.  Adjust the enhancement to make the clouds display as white instead of black.  Overlay this display on the RGB image created in problem 1. This longwave infrared band is useful to distinguish between clouds and snow. 

1. Looking at the RGB display over Louisiana, smoke can be observed.  Using the file loaded from question 1, display SVM13 brightness temperature data with the swathToGrid formula over Louisiana.  Overlay this display on the RGB image created in problem 1.  This medium-wave infrared band is useful to detect fire activity.

1. Determine the smoke concentration from the Louisiana fire using the <local path>/Data/SuomiNPP /GMTCO-VSUMO* VIIRS suspended matter EDR data.  Overlay this display on the RGB image created in problem 1.


Problem Set #1 – Solution

Using the <local path>/Data/SuomiNPP/GMODO-SVM03-SVM04-SVM05* file, create an RGB image using the Reflectance field of all three bands.  Create the display by using the VIIRS_M_RGB(M5,M4,M3) formula.  Display the data at full-resolution and make sure to include a large portion of the granule in your subsetted region.  Adjust the Common Gamma field in the Layer Controls to make the individual colors stand out more in the display.

1. Remove all layers and data sources from the previous displays.

1. Select File -> New Display Tab -> Map Display -> One Panel to create a new one-panel map display tab.

1. Load in a granule containing three bands of VIIRS SVM visible data (SVM03, SVM04 and SVM05).

2. In the Data Sources tab of the Data Explorer, select Under Development > Imagery – Suomi NPP

2. Select <local path>/Data/SuomiNPP/GMODO-SVM03-SVM04-SVM05_npp*	
(Note: this file packages the geolocation (GMODO) and the data (SVM*) together into the same file.)

2. Click the Add Source button.

1. Use the VIIRS formula to create a true-color RGB image with the bowtie effect removed.

3. In the Field Selector tab, under Data Sources select Formulas.

3. Under Fields, select the VIIRS_M_RGB(M5,M4,M3) formula.  Click Create Display.

3.  In the new Field Selector window, select: 

· [image: ]For Field: M5, select VIIRS -> IMAGE -> VIIRS-M5-SDR_All/Reflectance 
· For Field: M4, select VIIRS -> IMAGE -> VIIRS-M4-SDR_All/Reflectance
· For Field: M3, select VIIRS -> IMAGE -> VIIRS-M3-SDR_All/Reflectance

3. In the Region tab of Field: M5, use Shift+Left-Click+Drag to select a region to display at full-resolution.  Select a region that contains most of the granule, as shown in the image above.  It is not necessary to subset a region in for M4 and M3, as the region selected for M5 will be used for all fields.

3. Click OK to display the results of the VIIRS_M_RGB(M5,M4,M3) formula.

1. Adjust the display to enhance the Red, Green, and Blue components of the display.

4. Navigate to the Layer Controls tab of the Data Explorer.  By default, all Gamma values for all colors are set to 1.0.  Change this value to 0.4 by entering in 0.4 in the Common Gamma field and clicking the Apply to All Gamma Fields button.

4. Return to the Main Display window to observe the RGB display and also notice that the bowtie effect has been removed by the formula.

Problem Set #2 – Solution

[image: ]Looking at the display over the Great Lakes, it is difficult to discern between clouds and snow over the land. Using the file loaded from question 1, display SVM14 brightness temperature data with the swathToGrid formula over the Great Lakes region.  Adjust the enhancement to make the clouds display as white instead of black.  Overlay this display on the RGB image created in problem 1. This longwave infrared band is useful to distinguish between clouds and snow.
1. Use the swathToGrid formula to create a full-resolution display of the data without the bowtie effect.

0. In the Field Selector tab, under Data Sources select Formulas.

0. Under Fields, select the swathToGrid formula.  Under Displays, select Imagery > Image Display.  Click Create Display. 

0. In the new Select input window, enter 750 for res and 1.0 for mode.  Click OK.

0. In the Field Selector, select VIIRS* -> IMAGE -> VIIRS-M14-SDR_All/BrightnessTemperature.

0. In the Region tab, use Shift+Left-Click+Drag to select a region over the Great Lakes (as seen in the image on the right) to display at full-resolution.

0. Click OK to display the result of the swathToGrid formula.

1. Adjust the display to make the clouds over the Great Lakes appear as white instead of black and investigate the display.

1. Change the colorbar to Inverse Gray Scale.  To do this, Right-Click on the colorbar in the Legend and select System -> Inverse Gray Scale.  This is done to make the lower data values (colder temperatures, such as clouds) display as white, while warmer temperatures are darker.

1. Use the visibility checkbox in the Legend to toggle the SVM14 layer on and off to compare with the RGB display underneath.  The temperature difference between clouds and snow in this infrared band allows the clouds to stand out more than they do in the visible bands used in the RGB display.
Problem Set #3 – Solution

[image: ]Looking at the RGB display over Louisiana, smoke can be observed.  Using the file loaded from question 1, display SVM13 brightness temperature data with the swathToGrid formula over Louisiana.  Overlay this display on the RGB image created in problem 1.  This medium-wave infrared band is useful to detect fire activity.

1. Use the swathToGrid formula to create a full-resolution display of the data without the bowtie deletion.

0. In the Field Selector tab, select Formulas under Data Sources. 

0. Under Fields, select the swathToGrid formula.  Under Displays, select Imagery -> Image Display.  Click Create Display.

0. In the new Select input window, enter 750 for res and 1.0 for mode.  Click OK.

0. In the Field Selector window, select VIIRS* -> IMAGE -> VIIRS-M13-SDR_All/BrightnessTemperature.

In the Region tab, use Shift+Left-Click+Drag to select a region over Louisiana to display at full-resolution.  Click OK to display the result of the swathToGrid formula.

1. Use the visibility checkbox in the Legend to toggle the SVM13 layer on and off to compare with the RGB display underneath.

Problem Set #4 – Solution

Determine the smoke concentration from the Louisiana fire using the <local path>/Data/SuomiNPP /GMTCO-VSUMO* VIIRS suspended matter EDR data.  Overlay this display on the RGB image created in problem 1.

1. In the Data Sources tab of the Data Explorer, navigate to the Under Development -> Imagery -> Suomi NPP chooser.

0. [bookmark: _GoBack]Under Files, select the following file:
<local path>/Data/SuomiNPP/GMTCO-VSUMO*

0. Click the Add Source button.

1. Display the smoke concentration from the EDR data.

1. In the Fields panel of the Field Selector, select:
Image -> VIIRS-SusMat-EDR_/All/SmokeConcentration field.

1. Select Imagery -> Image Display in the Displays panel of the Field Selector.

1. In the Region tab of the Field Selector, use Shift+Left-Click+Drag to subset a region over Louisiana.  Anything within this subsetted region will display at the full resolution of the data.

1. Click Create Display.

1. Investigate the smoke concentration from the Louisiana fire.

2. In the Legend of the Main Display, toggle off the visibilities of the SVM13 and SVM14 data so only the RGB and the VIIRS EDR data is displayed.

2. Navigate over the fire in Louisiana and toggle the VIIRS EDR layer on and off with the visibility checkbox in the Legend.


Zooming, Panning, and Rotating Controls

	Zooming
	Panning
	Rotating

	
	Mouse
	

	Shift-Left Drag: Select a region by pressing the Shift key and dragging the left mouse button.
Shift-Right Drag: Hold Shift key and drag the right mouse button. Moving up zooms in, moving down zooms out.
	Control-Right Mouse Drag: Hold Control key and drag right mouse to pan.
	Right Mouse Drag: Drag right mouse to rotate.

	
	Scroll Wheel
	

	Scroll Wheel-Up: Zoom Out.
Scroll Wheel-Down: Zoom In.
	
	Control-Scroll Wheel-Up/Down: Rotate clockwise/counter clockwise.
Shift-Scroll Wheel-Up/Down: Rotate forward/backward clockwise.

	
	Arrow Keys
	

	Shift-Up: Zoom In.
Shift-Down: Zoom Out.
	Control-Up arrow: Pan Down.
Control-Down arrow: Pan Up.
Control-Right arrow: Pan Left.
Control-Left arrow: Pan Right.
	Left/Right arrow: Rotate around vertical axis.
Up/Down arrow: Rotate around horizontal axis.
Shift-Left/Right arrow: Rotate Clockwise/Counterclockwise.



		May 2018 - Using GOES-16 and JPSS Data – McIDAS-V 1.7u1
image1.png




image2.png
=)

_ -/ o

Inferval  Relative to Width
5o oo 10 -
5o oo 10 -

enal_ Rotreto coor nignment
Bo o | Atongiudes:[oso | IO |-
o Jbo ] atases: oo | [ |-
Font: [Arial ~ [Bota ~ |20 +] Format: [pp ~| Closeo
fo%

Top





image3.png
o800 vz [ | MDD





image4.png




image5.png




image6.png
T Properties — D - GOES-16 FD all bands (All Bands) - Image .. (B

Settings | Color Scale | Times

Visible:

Position: [Top |~

Color: Change





image7.png




image8.png
%) Plugin Manager

File Help

Tnstalled Plugins

# % Miscellaneous>VIIRS Formulas
# % Data Sources>GLM NetCDF Files

B Data Sources
© PAM NetCDF Enhancement

© NACP Plugin

© SSEC Lightning Data
© NAPLN Text Lightning Data

© Mesowest Chooser
© MMOUT NetCDF Files
© Wind Profiler Chooser

© NLAS Lidar Data

%% GLM NetCDF Files

Key: © Install Plugin # Uninstall Plugin

"NCML needed to read Portable Automated
Mesonet (PAM) netCDF files

Provides data sources for North American
Carbon Project data

NeML needed to read 2 lightning point data format

Datasource and some layout models for NAPLN
Lightning data

Provides access to mesowest point data
MMOUT NetCDF Files

Provides access to NOAA National Profier
Network data

Provides data sources for reading LIDAR data
(s, vis, csv)

Provides data types and layout models to display
Group, Event, and Flash data from local GLM
netCDF fies

[E5 send to Plugin Creator 8 View Contents.

Closel

PP PD P P

ic]

8
(in]

ID





image9.png
%) Plugin Manager

'NPP VIIRS data for McIDAS-V
versions 1.5 and newer

Closel

File Help
Installed Plugins
# % Miscellaneous>VIIRS Formulas L=
8 Miscellaneous |
© Test Menu Adds the Test menu for debugging B
© Jython Dev. Control  Contains the Jython Display Control B [
for developers
© UCAR Africa Initative A plugin for the UCAR Africa Inititive =]
© Greenland Layout Models Greenland Layout Models =]
© RGB-Eumetsat RGB formulas designed to work with B
SEVIRI MSG data
© VIIRS Formulas pre 1.5 Formulas to work with certain Suomi B
NP VIIRS data for McIDAS-V
versions 1.4 and earlier L
# % VIIRS Formulas Formulas to work with certain Suomi L=

Key: © Install Pugin s Uninstall Plugin [ES Send to Plugin Creator & View Contents





image10.png




image11.png
B Fieid Selector =)





image12.png
Field Selector =)

Fiold:foly LY
 mace B
VIRSH14-SOR_AlBrightned
VIRS 414-SDR_AIIQF1_VIR
RS 114-SDR_AlIRadiancq
VIRS-MOD-GEO_AllHeight
VIRS HOD-GEO_AWLatiude
VIRS 1OD-GEO_AlLongitud
NIRS MOD-GEO_AIQF2_ VI
VIRS-HOD-GEO_ASateite]
VIRS 1OD-GEO_AWSatelte]
NIRS 1OD-GEO_ASatelte]
VIRS-MOD-GEO_AlSolaria,
4\IBS1414.508 AUOE3 sl =

ok | [ cancel





image13.png
T Feld Selector =)

Fe: ol a
¥ VIRS 20150107 2L ATGNT  [4]
# AGE

VIRS-I13.SOR_AUBrighined
NRS-4113-SOR_AIIGF1_WIR
VIRS13-SDR _AlRdancq
/IRSMOD-GEC_AUHeignt
IRSMOD-G
IRSMOD-Gi
IRSMOD-Gi
VIRS HOD-GE
IRS MOD-Gi
IRS-MOD-Gi

o_AuLongtud
o_AuF2_VIR
0_AuSatalitef
o_Ausateitef
o_Ausateit

ok | [ cancer





