McIDAS-V Tutorial

Displaying Polar Satellite Imagery
updated September 2015 (software version 1.5)

MCcIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in
SSEC's 40-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite
(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and
manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and
Unidata's IDV libraries. The functionality of SSEC's HY DRA software package is also being integrated into
MCcIDAS-V for viewing and analyzing hyperspectral satellite data.

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the
MCcIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at
the startup of McIDAS-V when new versions are available on the McIDAS-V webpage -
http://www.ssec.wisc.edu/mcidas/software/v/.

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support
Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share
information with other users.

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start
MCcIDAS-V. If you cannot start McIDAS-V on your machine, you should follow the instructions in the
document entitled McIDAS-V Tutorial — Installation and Introduction.

Terminology

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter
Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer).

The Data Explorer contains three tabs that appear in bold italics throughout this document: Data Sources,
Field Selector, and Layer Controls. Data is selected in the Data Sources tab, loaded into the Field
Selector, displayed in the Main Display, and output is formatted in the Layer Controls.

Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources).

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).


http://www.ssec.wisc.edu/mcidas/software/v/
http://www.ssec.wisc.edu/mcidas/forums/
http://www.ssec.wisc.edu/mcidas/forums/
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Loading Polar Satellite Images and Loops

1. Create a local dataset to access the imagery files on your local machine.

a.

b.

C.

d.

In the Main Display window of McIDAS-V, select Tools -> Manage ADDE Datasets.

In the ADDE Data Manager, select File -> New Local Dataset. Enter in the following parameters to
set up a dataset with the MODIS Level 1b HDF files provided with this tutorial:

Dataset — MODIS

Image Type — HDF MODO02 1km files

Format — MODIS MOD 02 — Level-1B Calibrated Geolocated Radiances
Directory — select the <local path>/Data/Polar/modis_files directory

¥ " Add Local Dataset Iﬁ

Dataset (e.g. MYDATA): |ru1£]DIS |
Image Type (e.q. JAN 07 GOES): |HDF MOD0Z 1km files |

Format: |MODIS MOD 02 - Level-1B Calibrated Geolocated Radiances |

Directory: |C:1Userslmyuser’nDatatPnlar‘nmndis_ﬂles Browse...

Add Dataset Cancel

L

Click Add Dataset.

Close the ADDE Data Manager by clicking Ok or File -> Close.

2. To load the data in this local dataset, follow these steps.

a.

Blv| HDF MODO2 1km fi. 5 ]
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Select <LOCAL-DATA> for the Server, select
MODIS for the Dataset, and click Connect.
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Choose the HDF MODO02 1km files Image
Type and select an Absolute time of 21:20
UTC.

U ==110s

Click Add Source to show the Field Selector.

Memory: 163/322/13037 MB Latitude: 41.1 Longitude: -110 Altitude: 6247.1 m

Select 0.6465 um Land/Cloud Boundaries -> Brightness.
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g. Click Create Display. The 21:20 UTC 0.6465 um image is displayed in the Main Display window.

3. Use the zooming and panning controls in the left toolbar to inspect the image. Specifically, notice the fire in
eastern Oregon.

a. Reproject the image with a pre-defined domain. Select Projections -> Predefined -> US -> CONUS.
Use the scroll wheel to zoom into the image or Shift+Left Click+Drag a box around the image.

b. Turn off the Auto-set Projection option under the Projections menu. When this option is checked, the
projection will automatically change to the native projection of the new layer. When this option is
unchecked, all new layers will be reprojected into the current projection.

4. Return to the Field Selector to load an atmospheric temperature image.

a. Select 4.5454 um Atmospheric Temperature -> Temperature.

b. Click Create Display. The 4.5454 um temperature image is overlaid on top of the visible image. To
see the visible image, turn off the top HDF MODO02 1km file (All Bands...) checkbox in the Legend.

5. Use the cursor readout option to see the temperature values for the fire pixels.
a. Turn the HDF MODO02 1km file (All Bands...) checkbox in the Legend back on.

b. Click and drag the middle mouse button to activate the Cursor/Data Readout option and list the
latitude, longitude, and data value under the cursor. Since there are two layers in the main display, there
are two different readouts with the appropriate values and units. Notice the high 4.5454 um temperature
values are located at the location of the fire. The data probe from the cursor/data readout option shows
that values in the fire are approximately 50 degrees K warmer than outside of the fire.

6. Edit the maps in the display by using the options in the Layer Controls.

a. Click on Default Background Maps in the Legend to go to the Layer Controls. The map controls will
have two tabs. The first Maps tab lists the available maps, and the second Lat/Lon tab allows the user to
control latitude and longitude lines and labels. At the bottom of both tabs, there is a Position slider that
allows you to control the vertical positioning of the maps in the Main Display.

b. Inthe Maps tab you can remove a map, change its visibility, line width, style and color. Use these
options to create your own map display.

c. If you choose, also add latitude and longitude lines and labels in the Lat/Lon tab.
d. To save a map configuration as the default, in the Layer Controls select File -> Default Maps -> Save
as the Default Map Set. The next time you open a new tab, window, or start McIDAS-V, the defaults

will reflect what you selected.

7. Notice that both layers are labeled the same in the Legend. Change the text of the labels in the Main
Display.
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a. Right Click on the top HDF MODO02 1km files (All Bands...) label in the Legend.

b. Choose Edit -> Properties.... Enter the following for the Legend Label and Layer Label:
e Legend Label —4.5454 um - TERRA
e Layer Label — %datasourcename% - 4.5454 um - %timestamp%

U4 Properties -- HDF MOD02 1km files (All Bands) - Image Display @

l/ Settings |/{30Icrr Scale |/Times |

Display Category: |Imagerg.r | e
Legend Label: |4.5454 um - TERRA | Add Macro
Extra Legend Labels; eresolution®e - Add Macro
Layer Label: |%datasnurcename%—4.545¢ um - ¥timestamp% | Add Macro
Id: | | (for scripting)

[ ] Lock Visibility Toggle Show in Layer List
[ ] Use Fast Rendering Use Times In Animation
Remove on Remove All Include in cursor readout

[ | Show Note Text

Apply OK Cancel

8. Return to the Data Sources tab of the Data Explorer to load another time.

a. Inthe Data Sources tab of the Data Explorer, select the Satellite -> Imagery chooser with <LOCAL-
DATA>/MODIS, the Image Type HDF MODO2 1km files, and an Absolute time of 21:15 UTC.

b. Click Add Source to show the Field Selector.

c. A new data source is created in the Field Selector. To distinguish it from the first data source, the label
is editable. Right Click on the highlighted HDF MODO02 1km files (All Bands...) and choose Properties.
In the Name field enter, HDF 21:15 UTC MODO02 1km. Click OK.

d. Select 0.6465 um Land/Cloud Boundaries -> Brightness.

e. Click Create Display. The 21:15 UTC 0.6465 um image is displayed in the Main Display window
with the other displays also visible (because the Auto-set Projection setting is unchecked).
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f. Inthe Legend, click on the trash can next to 4.5454 um TERRA to remove the atmospheric temperature
display (the middle one listed with the color table range of 180 to 320).

9. Create a local dataset to access the HRPT (High Resolution Picture Transmission) and GAC (Global Area
Coverage) NOAA-18 Area polar orbiter imagery files on your local machine.

a. Inthe Main Menu Bar of the Main Display window, select Tools -> Manage ADDE Datasets. This
will open the ADDE Data Manager.

b. Select File -> New Local Dataset. Enter the following parameters to set up the dataset:

Dataset — HRPT

Image Type — HRPT N18 area files

Format — McIDAS AREA

Directory — select the <local path>/Data/Polar/HRPT _areas directory.

# © Add Local Dataset -

Dataset (e.g. MYDATA): |HRF'T |

Image Type (e.g. JAN 07 GOES): |HRF'T M18 areafiles |

Format: [McIDAS AREA -
Directory: |C:\Usersﬁ.myuser‘l.Data*.F'nIar".HRF'T_areas Browse...
Add Dataset Cancel

L

c. Click Add Dataset.

d. Inthe ADDE Data Manager, select File -> New Local Dataset. Enter the following parameters to set
up the dataset:

Dataset — GAC

Image Type — GAC N18 area files

Format — McIDAS AREA

Directory — select the <local path>/Data/Polar/GAC_areas directory.

#  Add Local Dataset 25|

Dataset (e.g. MYDATA): |GAC |
Image Type (e.g. JAN OF GOES): |GAC M18 areafiles |

Format: [McIDAS AREA hd
Directory: |C:1.L.I sers\myusenData\PolanGAC_areas Browse...
Add Dataset Cancel

e
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Click Add Dataset.

Close the ADDE Data Manager by clicking Ok or select File -> Close.

10. Remove all layers and data sources and display HRPT 10.8 um Temperature data.

a.

b.

In the Main Display window, select Edit -> Remove -> All Layers and Data Sources.
In the Main Display select File -> New Display Tab -> Map Display -> One Panel.

In the Satellite -> Imagery chooser of the Data Sources tab of the Data Explorer, select <LOCAL-
DATA> for the Server, select HRPT for the Dataset, and click Connect.

Choose the HRPT N18 area files Image Type and select an Absolute time of 04:45:04 UTC.

Select Lat/Lon for the Navigation.

Click Add Source to show the Field Selector.

Select 10.8 um Surface/Cloud-top Temp -> Temperature.

Under Displays click on the Advanced tab. Click on the green arrow icon next to Image Size to load
the full image. Change the Magnification to 1 X 1 with the sliders, and click Create Display. (The
Magnification of 1 X 1 downloads the full resolution of the data. Negative magnification values will

reduce the amount of data downloaded. For example, -5 X -5 will sample the data, and every fifth line
and every fifth element is sent from the server.)

11. Load an FY2E satellite image over the HRPT image. This dataset was previously created in the Displaying
Satellite Imagery tutorial.

a.

In the Data Sources tab of the Data Explorer, using the Satellite -> Imagery chooser, select <LOCAL-
DATA> for the Server, select ZQ _IR for the Dataset, and click Connect.

Choose the FY2E IR satellite data Image Type and select an Absolute time of 05:01 UTC.
Click Add Source to show the Field Selector.
Select 10.8 um Surface/Cloud-top Temp -> Temperature.

Under Displays click on the Advanced tab. Click on the green arrow icon next to Image Size to load
the full image. Change the Magnification to 1 X 1 with the sliders, and click Create Display.

12. Center the Main Display over the HRPT image and place the HRPT image over the FY2E image. Compare
the two displays.

a. Turn off the FY2E full disk image by unchecking the FY2E IR Satellite Data box in the Legend.
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Use Shift+Left Click+Drag to create a box over the HRPT image to zoom into it.
Turn on the FY2E full disk image by rechecking the FY2E IR Satellite Data box in the Legend.
In the Legend, Right Click on the HRPT N18 area files and select View -> Bring to Front.

Use the middle mouse button to click and probe the data for a temperature comparison. Note that the
resolution of the HRPT data is better than the FY2E data.

If the map lines in the display are missing or dashed instead of solid lines, click on Default Background
Maps in the Legend to go to the Layer Controls. In the Maps tab, change the setting for Fast
rendering for each of the displayed maps.

Creating RGB images using formulas

13. Add MODIS data using the local MODIS server created earlier in this tutorial.

a.

b.

C.

d.

Remove all layers and data sources.

In the Data Sources tab of the Data Explorer, using the Satellite -> Imagery chooser, select <LOCAL-
DATA> for the Server, select MODIS for the Dataset, and click Connect.

Choose the HDF MODO02 1km files Image Type and select the Absolute time of 21:20 UTC.

Click Add Source to show the Field Selector.

14. Define the Red, Green, and Blue channels of your image display.

a.

b.

Click on Formulas under the Data Sources listed in the Field Selector.
Select Imagery -> Three Color (RGB) Image, and click Create Display.

In the Field Selector, select HDF MODO02 1km files -> 0.6465 um -> Brightness as red, MODIS... ->
0.5537 um -> Brightness as green, and MODIS... -> 0.4656 um -> Brightness as blue and click OK.

Change the projection to over the United States via Projections -> Predefined -> US -> CONUS in the
Main Display. Use Shift+Left Click+Drag to zoom in on the data.
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Problem Sets

The previous examples were intended to give you a general knowledge of how to load and display polar satellite
data. The problem sets below are intended to introduce you to new topics related to the data, as well as
challenge your knowledge of McIDAS-V. We recommend that you attempt to complete each problem set
before looking at the solutions, which is provided below the problem set.

1.

Load a loop of GAC (Global Area Coverage) NOAA-18 images on a Globe Display. Load visible and
low-level water vapor images. Animate the loop on a rotating globe with a solid blue background
image. Use the GAC N18 dataset created earlier in this tutorial.

Load a HRPT NOAA-18 image. Display the polar orbit track for the image using a two-line element
text file with the Polar Orbit Track chooser. Add the swath width and antenna circles for the Wallops
ground station.

Problem Set #1 — Solution

Load a loop of GAC (Global Area Coverage) NOAA-18 images on a Globe Display. Load visible and low-level
water vapor images. Animate the loop on a rotating globe with a solid blue background image. Use the GAC
N18 dataset created earlier in this tutorial.

1. Remove all layers and data sources, create a globe display, and load the data.

a.

b.

Remove all layers and data sources.
In the Main Display select File -> New Display Tab -> Globe Display -> One Panel.

In the Data Sources tab of the Data Explorer, using the Satellite -> Imagery chooser, select <LOCAL-
DATA> for the Server, select GAC for the Dataset, and click Connect.

Choose the GAC N18 area files Image Type and select the Relative times of 8 most recent.
Select Lat/Lon for the Navigation.

Click Add Source to show the Field Selector.

2. Select the 0.63 pm and 12.0 um bands and display them.

a.

b.

Select 0.63 um VIS Cloud and Surface Features -> Brightness.

Under Displays click on the Advanced tab. For Coordinate Type: choose Image Coordinates. Change

the Magnification to 1 X 1 with the sliders. Click on the green arrow icon = ¥ next to Image Size to
load the full-size image. For Location: choose Upper Left, and click Create Display.

Repeat this process with the 12.0 um IR SFC/Cloud Temp, Low-level WV -> Brightness.

McIDAS-V Tutorial — Displaying Polar Satellite Imagery September 2015 — McIDAS-V version 1.5



Page 9 of 11

3. Animate the globe and add the background image. Then analyze and animate the globe display.

a. From the Main Display, select Display -> Add Background Image. In the Layer Controls for the
background image, choose Solid Blue.

b. Start the loop by using the Time Animation buttons at the top of the Main Display.

c. Turnon the Auto-Rotate view option (View -> Viewpoint from the Main Display window, or the Auto-

Rotate button ¥ in the Viewpoint Toolbar to the left of the image).

d. Change the orientation of the globe in the Main Display with the mouse controls. Restart the Auto
rotate view.

Problem Set #2 — Solution

Load a HRPT NOAA-18 image. Display the polar orbit tracks for the image using a two-line element text file
with the Polar Orbit Track chooser. Add an antenna circle for the Wallops ground station.

1. Remove all layers and data sources, and display the 19:46:04 UTC NOAA-18 image in a new tab.

a. Remove all layers and data sources.

b. Click the button in the Main Display to create a new tab.

c. Inthe Data Sources tab of the Data Explorer, using the Satellite -> Imagery chooser, select <LOCAL-
DATA> for the Server, select HRPT for the Dataset, and click Connect.

d. Choose the HRPT N18 area files Image Type

e. Select an Absolute time of 19:46:04 UTC.

f. Select Lat/Lon for the Navigation.

g. Click Add Source to show the Field Selector.
2. Display the 19:46:00 UTC NOAA-18 image

a. Select 0.63 um VIS Cloud and Surface Features -> Brightness.
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Under Displays select the Advanced tab.

r Times r Region r Adwvanced

e For Coordinate Type: choose Image
Coordinates.

Coordinate Type: |Image Coordinates | - |

Location: [Upper Lert [~
Line: |1 Element: |1

Image Size: 32906 | X([z04z | I 23 Raw size: 3296 X 2048

A
e Click on the green arrow icon = to
load the full-size image.

Magnification:

) Line Mag=1 C {) Res=1.
e For Location: choose Upper Left.
Ele Mag=1 C [ ) pes—1.
Click Create Display. _
Center Line: 1646 Element: 1023
Upper Left Line: 3 Element: 1
Reproject the display to the continental United | #PProxArea: Boper Migne fomes = oioment: 2090
States domain. In the Main Display, select Lower Right Line: 3289 Element: 2045

Projections -> Predefined -> US -> CONUS.
Zoom into the image to fill the display.

Display the polar orbit tracks from a two-line element file.

a.

In the Data Sources tab of the Data Explorer, select the Under Development -> Imagery — Satellite
Orbit Track chooser.

In the Local panel, under Look In, navigate to the <local path>/Data/Polar/ directory and select the
noaal8.txt file.

Click Add Source to show the Field Selector.

Under Displays, select Satellite Orbit Track.
Select what data to display in the Time Range tab of the Field Selector.

e Use the calendar button to select Apr 26, 2012 in both Date fields.
e Enter 19:40:00 for Begin Time, and enter 20:00:00 for End Time. Click Create Display.

Navigate to the Layer Controls of the TLE data to modify the display.

¢ Inthe Ground Station Controls panel, expand the dropdown menu for Ground Stations
Available, select Wallops Island 14 (near the bottom of the list) and click Add Selected.
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Zooming, Panning, and Rotating Controls

Zooming Panning Rotating
Mouse
Shift-Left Drag: Select a region | Control-Right Mouse Drag: Right Mouse Drag: Drag right
by pressing the Shift key and Hold Control key and drag right | mouse to rotate.
dragging the left mouse button. mouse to pan.

Shift-Right Drag: Hold Shift key
and drag the right mouse button.
Moving up zooms in, moving
down zooms out.

Scroll Wheel
Scroll Wheel-Up: Zoom Out. Control-Scroll Wheel-
Scroll Wheel-Down: Zoom In. Up/Down: Rotate
clockwise/counterclockwise.
Shift-Scroll Wheel-Up/Down:
Rotate forward/backward
clockwise.
Arrow Keys
Shift-Up: Zoom In. Control-Up arrow: Pan Down. | Left/Right arrow: Rotate
Shift-Down: Zoom Out. Control-Down arrow: Pan Up. | around vertical axis.

Control-Right arrow: Pan Left. | Up/Down arrow: Rotate
Control-Left arrow: Pan Right. | around horizontal axis.
Shift-Left/Right arrow: Rotate
Clockwise/Counterclockwise.
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