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McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in SSEC's 40-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data.
More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/.
If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share information with other users.
This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the document entitled McIDAS-V Tutorial – Installation and Introduction.
In this McIDAS-V Tutorial, most exercises will use real-time access to default remote servers.  You must have internet access to complete this lesson.  If you have access to your own real-time servers, you may also use those, but be aware that different server configurations may make the explanations in this document not quite applicable to all data that you may load.
Terminology
There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer).
The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field Selector, displayed in the Main Display, and output is formatted in the Layer Controls.
Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources).

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).








Plotting and Contouring Surface Point Observations around the world

1. Remove all layers and data sources from the previous displays.  If you have created more than one tab, close the extra tabs by clicking on the “X” in the right corner of the tabs.

2. From the Data Sources tab of the Data Explorer, select the Point Observations -> Plot/Contour chooser.

a. Connect to adde.ucarssec.wisc.edu Server with the Dataset RRTPTSRC Dataset.

b. Choose the SFCHOURLY - Real-Time SFC Hourly Point Type.

c. Select the most recent time and click Add Source.

d. In the Field Selector, select Point Data in the Fields panel.

e. Select the Point Data -> Point Data Plot display type.

f. In the lower-right panel, click the Layout Model tab and click the double down blue arrows next to METAR to select Observations -> Temperature to plot all available temperatures.

g. Click Create Display.  The default display is a world projection with temperatures plotted from around the world.  As you zoom in you will see more stations appear in the plot.

3. Reset the display projection using the Reset Display Projection button  on the left side of the Main Display or through the Projections -> From Displays menu item.

4. Return to the Data Sources tab of the Data Explorer and select the Satellite -> Imagery chooser.

a. Connect to the adde.ucarssec.wisc.edu Server with the RTIMAGES Dataset.

b. Select an Image Type of GE-VIS - GOES-East 0.65 63 um Visible.

c. Select the most recent image and add the source.

d. In the Field Selector tab, expand the 0.65 63 um field, and select Brightness.

e. For the Display, selectSelect the Imagery -> Image Display display typey.  

f. Click Create Display.

5. To contour the temperatures plotted on the screen, return to the Field Selector.

a. Click on the “SFCHOURLY” data sourceSelect SFCHOURLY in the Data Sources panel.

b. In the Fields panel, click the  icon next to, select  Gridded Fields, and select T -> T from the list of available Fields.

c. Select Plan Views -> Contour Plan View in the list of displays, and click Create Display.  The contour properties can be changed in the Layer Controls tab of the Data Explorer.

· Note that these contours are drawn from surface observations, which are recorded over land, not water. Therefore, contours will look better if you zoom in over a land area in the Main Display.

Creating Time Series of Point Observations

6. Remove All all Layers layers and Data data Sourcessources.

7. Return to Point Observations -> Plot/Contour chooser in the Data Sources tab.  Use the adde.ucarssec.wisc.edu Server, the RTPTSRC Dataset, and the SFCHOURLY Point Type.

a. Select a group of times from the Absolute time tab (to select more than one time, use Control+Click or Shift+Click), and click Add Source.

b. Select Point Data in the Fields panel and click Create Display to plot the default station models.

8. In the Layer Controls, follow these steps:

a. Click on the Plot tab to create a time series.

b. Zoom in over a station in the Main Display and Left Click on the center of it.  The station information should fill into the table below the plot in the Layer Controls.

c. Add the temperature to the plot by Right Clicking on the T field in the table and selecting Add To Chart.


Displaying RAOB Sounding Data

9. Remove all layers and data sources.

10. For local data, select the Point Observations -> Soundings -> Local chooser in the Data Sources tab. 

a. Under File, click Select File. Change Files of Type to ‘All Files’, and select the <local path>/Data/Point_ADDE/20090903_1200-raob.nc file. Click Open.

b. Skip to step 12, or continue to step 11 to use remote data.

11. For remote data, select the Point Observations -> Soundings -> Remote chooser in the Data Sources tab. 

a. Connect to the adde.ssec.wisc.edu Server with the RTPTSRC Dataset.

b. Select UPPERMAND for the Mandatory Levels and UPPERSIG for the Optional Significant Levels.

12. Select a station for your sounding display.

a. Use the zooming and panning buttons to find your station(s).  

b. Select an available time and click on your station to see if a sounding is available.  Available soundings will show up in the Selected box on the bottom right of the chooser.  

c. If more than one is available for your station, select the most recent time and add the source.  

d. Under the Displays panel of the Field Selector, you have the option to choose which type of thermodynamic diagram to display (Skew-T, Stuve, Emagram).  

e. Select one of the thermodynamic diagrams and click Create Display.

13. The sounding will show up in a 2D display in the Layer Controls tab along with a list of thermodynamic parameters.  As you move the mouse over the sounding, the thermodynamic parameters will update. 
 
 

14. The temperature and dewpoint traces can be modified via the cursor. 

a. Left Click on the first data-point to be modified and drag it horizontally along an isobar to the desired position, then move the pointer diagonally along an isotherm to keep the data-point at the desired position and to pick-up the next data-point.

b. Repeat until done and then release the mouse button.  

c. To reset the sounding, use the Edit -> Reset Sounding menu item of the Layer Controls tab.

d. Use the checkboxes below the sounding to configure the sounding chart. When the Stations box is checked, you will see a square box in the Main Display indicating the location of each sounding selected in the Data Sources tab.  Select a new station by Left Clicking another square box in the Main Display, or by choosing a station in the Station dropdown menu in the Layer Controls.

e. In the Layer Controls, in addition to the Sounding Chart, there are also tabs for a Hodograph, and a Table of all of the data in the sounding.





Problem Sets

The previous examples were intended to give you a general knowledge of how to load and display surface point data.  The problem sets below are intended to introduce you to new topics related to the data, as well as challenge your knowledge of McIDAS-V.  We recommend that you attempt to complete each problem set before looking at the solutions, which are provided below the problem set.

1. Create a time series of surface Temperature, Dewpoint Temperature and Wind Barbs for the last 24 hours over Chicago (KORD).  Change the Temperature and Dewpoint Temperature axes in the plot so they have the same range.  Look at the current zone forecast for Chicago to check the accuracy of the forecast for today. (Hint:  Weather text products can be found under Tools -> Text Data)

2. Modify the chart from problem #1 so you have three separate charts:  Place Wind Barbs and Gusts in the top left chart, Pressure in the top right chart, and Temperature and Dewpoint Temperature in the bottom chart  (Hint: Change the chart names to separate out parameters!)

3. Create your own station model layout that displays the Dewpoint Depression in green over the center of the station with the station ID below the Dewpoint Depression, the Temperature to the upper left, and Dewpoint Temperature to the upper right.  Display the most recent observations using the new layout.


Problem Set #1 – Solution

Create a time series of surface Temperature, Dewpoint Temperature and Wind Barbs for the last 24 hours over Chicago (KORD).  Change the Temperature and Dewpoint Temperature axes in the plot so they have the same range.  Look at the current zone forecast for Chicago to check the accuracy of the forecast for today. (Hint:  Weather text products can be found under Tools -> Text Data).

1. Remove all layers and data sources from the previous display.

2. Return to the Point Observations -> Plot/Contour chooser in the Data Sources tab. Connect to the adde.ucarssec.wisc.edu Server with the RTPTSRC Dataset. Select the SFCHOURLY – Real-Time SFC Hourly Point Type and the 24 most recent times with the interval set to Hourly. Click Add Source.

3. Select the Point Data field, and the Point Data -> Point Data Plot display type.  Click Create Display.

4. In the Main Display, use the Zooming and Panning controls to zoom in over Chicago, and Left Click on the Chicago O’Hare International station (KORD).

5. In the Layer Controls, click on the Plot tab, and at the bottom, scroll down through the list of fields until you find temperature (T).  

6. Right Click on T and select Add to Chart, and repeat for dewpoint temperature (TD).  

7. To add wind barbs, add speed (SPD) and direction (DIR) to the chart.  When both of these parameters are added, they are converted into windbarbswind barbs.

8. Right Click on the table of fields and select T -> Chart Properties.

a. In For the Range: property, enter in a Min and Max value appropriate for both Temperature temperature and Dewpoint dewpoint Temperaturetemperature.  Click OK.

9. Right Click on the table of fields and select TD -> Chart Properties.

a. To the right of the Range property, there is a ... button.  Click on this button and select “Fixed Range from: T...” (with the range values set in step 8a), and click OK.

10. Open up the Weather Text Product Display by selecting the Tools -> Text Data -> Weather Text Products (from server) menu item in the Main Display.

a. In the Products tab, open the Public Products -> Zone Forecasts.

b. In the Main Display window, zoom in over Illinois and click on KLOT.  The zone forecast for KLOT, including Chicago will now be shown in the weather text product window.

c. At the bottom of the Weather Text Product Display window, open the Time Covered menu item and select 24 Hours. This will add in zone forecasts created over the last 24 hours, which can be controlled through the Time Animation Controls. Check to see if forecasted temperatures were verified by the data plotted in the chart in the Layer Controls.


Problem Set #2 – Solution

Modify the chart from problem #1 so you have three separate charts:  Place Wind Barbs and Gusts in the top left chart, Pressure in the top right chart, and Temperature and Dewpoint Temperature in the bottom chart  (Hint: Change the chart names to separate out parameters!).

1. Return to the Temperature temperature chart properties by Right-Clicking on the table of fields and selecting T -> Chart Properties.

a. Enter in “Temperature” in the Chart Name field.

b. Click OK.  The Temperature temperature plot should appear in a new chart below the current plot titled “Plot”.

2. Repeat this step for Dewpoint dewpoint Temperature temperature and place it in the “Temperature” plot.

3. Add Wind wind Gusts gusts (GUS) and Pressure pressure (PSL) to the charts and place Pressure pressure in a separate chart titled “Pressure”.

4. Add speed (SPD) and direction (DIR) to the “Plot” plot. 

5. Select View -> Chart -> Layout -> Change Grid Layout menu item in the Layer Controls.

a. Expand the Edit Chart Layout window by clicking and dragging on the corner of the window.

b. Use the Columns and Rows buttons to add/remove columns and rows.

c. Left-Click+Drag on a chart to move it to a different location.

d. Use the black squares around the individual charts to control their width and length.


Problem Set #3 – Solution

Create your own station model layout that displays the Dewpoint Depression in green over the center of the station with the station ID below the Dewpoint Depression, the Temperature to the upper left, and Dewpoint Temperature to the upper right.  Display the most recent observations using the new layout.

1. Remove All all Layerslayers.  

2. In the Main Display, select the Tools -> Station Model Template menu item.

3. In the editor, select File -> New and enter in “Dewpoint Depression” for the name of the layout. 

4. Click on “123 Value” and click in the middle of the layout.  The Properties Dialog box will pop up.  

5. In the Parameter field, enter in:  =T-TD

6. Change the Foreground Color to green, and click OK.  

7. Add a Temperature and Dewpoint Temperature values in the appropriate locations.  Do this by clicking the “123 Value” and clicking on the appropriate location on the layout. Enter T as the Parameter. Do the same for dewpoint temperature, with TD as the Parameter.

8. Click on “Text” and click below the dewpoint depression. In the Parameter field, enter: ID

9. In the editor select File -> Save and then close the window.  

10. Load the most recent surface hourly data into the Field Selector.  

a. In the Data SourcesField Selector tab of the Data Explorer, select the SFCHOURLY Data Source.use the adde.ucar.edu Server, the RTPTSRC Dataset, the SFCHOURLY –REAL-Time SFC Hourly Point Type and the most recent time. Click Add Source.

b. In the Fields panel, select Point Data, with the Point Data -> Point Data Plot display type.

c. In the Times tab, use the dropdown menu to select Use Selected and choose the most recent time.

d. In the Layout Model tab in the lower right corner, change the model to “Dewpoint Depression.”,  <local>”which will have a <local> tag next to it.  Click Create Display..
e. 
f. Click Create Display.


Displaying RAOB Sounding Data

15. Remove All Layers and Data Sources.

16. For local data, select the Point Observations -> Soundings -> Local chooser from the Data Sources tab. 

a. Under File, click Select File. Change Files of Type to ‘All Files’, and select the <local path>/Data/Point_ADDE/20090903_1200-raob.nc file. Click Open.

b. Skip to step 3, or continue to step 2 to use remote data.

17. For remote data, select the Point Observations -> Soundings -> Remote chooser from the Data Sources tab. 

a. Connect to the adde.ucar.edu Server with the RTPTSRC Dataset.

b. Select UPPERMAND for the Mandatory Levels and UPPERSIG for the Optional Significant Levels.

18. Select a station for your sounding display.

a. Use the zooming and panning buttons to find your station(s).  

b. Select an available time and click on your station to see if a sounding is available.  Available soundings will show up in the Selected box on the bottom right of the chooser.  

c. If more than one is available for your station, select the most recent time and add the source.  

d. Under the Displays panel of the Field Selector, you have the option to choose which type of thermodynamic diagram to display (Skew-T, Stuve, Emagram).  

e. Select one of the thermodynamic diagrams and click Create Display.
19. 
The sounding will show up in a 2D display in the Layer Controls tab along with a list of thermodynamic parameters.  As you move the mouse over the sounding, the thermodynamic parameters will update. 
 
 

20. The temperature and dewpoint traces can be modified via the cursor. 

a. Left Click on the first data-point to be modified and drag it horizontally along an isobar to the desired position, then move the pointer diagonally along an isotherm to keep the data-point at the desired position and to pick-up the next data-point.

b. Repeat until done and then release the mouse button.  

c. To reset the sounding, go to Edit -> Reset Sounding menu item of the Layer Controls tab.
d. 
You can also choose to display the parcel path, vertical temperature, adiabats, and mixing ratio on the sounding using the checkboxes below the sounding.  When the Stations box is checked, you will see a square box in the Main Display indicating the location of the sounding.



Displaying Wind Profiler Observations

Remove All Layers and Data Sources and turn on the Auto-set Projection option in the Projections menu of the Main Display.

Select the Point Observations -> Wind Profiler chooser from the Data Sources tab.

Connect to the adde.ucar.edu Server with the RTPTSRC Dataset (alternatives: stratus.al.noaa.gov or weather2.admin.niu.edu).

Select a Profiler Type of Real-Time 6 Minute Profiler Data.

Select two stations and the 24 most recent times.

Use a 30 minute interval and load the data source.

Opening up the tree of the Fields tab in the Field Selector by clicking the  icon will allow you to choose to display each station individually, or as a group if you leave Profiler winds selected.

Display all stations as a Time/Height Display, and the data will be displayed in the 2D display in the Layer Controls tab.

The 24 most recent times will be displayed, with the latest data on the right.  This can be switched by turning on the Latest Data on the Left checkbox.

Change the display to different stations using the Stations pull down tab.

Modify the windbarb size and vertical interval to see how the display changes.

Return to the Field Selector and create a 3D view display.

Zoom out of the display to see all of the stations, as the default zooms in on one of the stations.

Rotate the view so you are looking at the profiler displays from the south.

Use the Time Animation Controls to loop through the selected times and observe how the profiler displays change.

The windbarb size and vertical interval can be modified in the Layer Controls tab.












Zooming, Panning, and Rotating Controls

	Zooming
	Panning
	Rotating

	
	Mouse
	

	Shift-Left Drag: Select a region by pressing the Shift key and dragging the left mouse button.
Shift-Right Drag: Hold Shift key and drag the right mouse button. Moving up zooms in, moving down zooms out.
	Control-Right Mouse Drag: Hold Control key and drag right mouse to pan.
	Right Mouse Drag: Drag right mouse to rotate.

	
	Scroll Wheel
	

	Scroll Wheel-Up: Zoom Out.
Scroll Wheel-Down: Zoom In.
	
	Control-Scroll Wheel-Up/Down: Rotate clockwise/counter clockwise.
Shift-Scroll Wheel-Up/Down: Rotate forward/backward clockwise.

	
	Arrow Keys
	

	Shift-Up: Zoom In.
Shift-Down: Zoom Out.
	Control-Up arrow: Pan Down.
Control-Down arrow: Pan Up.
Control-Right arrow: Pan Left.
Control-Left arrow: Pan Right.
	Left/Right arrow: Rotate around vertical axis.
Up/Down arrow: Rotate around horizontal axis.
Shift-Left/Right arrow: Rotate Clockwise/Counterclockwise.
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