
McIDAS-V Tutorial 
Displaying Suomi NPP Data 

updated January 2016 (software version 1.5) 

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in 

SSEC's 40-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 

(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 

manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and 

Unidata's IDV libraries. The functionality of SSEC's HYDRA software package is also being integrated into 

McIDAS-V for viewing and analyzing hyperspectral satellite data. 

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the 

McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at 

the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - 

http://www.ssec.wisc.edu/mcidas/software/v/ .   

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support 

Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share 

information with other users. 

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 

McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the 

document entitled McIDAS-V Tutorial – Installation and Introduction.   

Terminology 

There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter 

Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer). 

The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, 

Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field 

Selector, displayed in the Main Display, and output is formatted in the Layer Controls. 

Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources). 

 

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).   

 

 

 

 

 

 

 

http://www.ssec.wisc.edu/mcidas/software/v/
http://www.ssec.wisc.edu/mcidas/forums/
http://www.ssec.wisc.edu/mcidas/forums/
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Introduction 

McIDAS-V has the ability of displaying Suomi NPP data through the Under Development -> Imagery -> 

Suomi NPP chooser.  Among the Suomi NPP products that McIDAS-V can display are different bands of SVM 

and SVI data, various cloud filter products, and the day/night band.  In order for this data to be recognized by 

McIDAS-V, the data and geolocation files must be contained within the same directory.  Some sources of data, 

including NOAA’s CLASS, package the data and geolocation files together, while other sources, including 

SSEC’s PEATE server, do not package the files together.  Note that this chooser is still under development and 

improvements in functionality as well as the ability to utilize different NPP products will be added in the future. 

This tutorial utilizes PEATE data with separate data and geolocation files, single-banded data from NOAA 

CLASS, as well as multi-banded visible data from NOAA CLASS. 

 

Installing the VIIRS Formulas Plugin 

1. This tutorial uses two formulas specifically designed to work with Suomi NPP VIIRS data.  These formulas 

are not packaged as part of the core group of formulas in McIDAS-V, and must be added via a plugin.  Add 

this plugin. 

 

a. In the Main Display window, navigate to the Tools 

-> Plugins -> Manage menu item to open the 

Plugin Manager.  

 

b. The top of the Plugin Manager lists plugins 

currently installed, and the bottom panel lists out 

various plugins available for installation.  Expand 

the Miscellaneous tree and click the green Install 

Plugin button next to VIIRS Formulas.  

 

c. This pops up a message informing that McIDAS-V 

must be restarted to complete the installation of the 

plugin.  Click OK through this message and restart 

McIDAS-V. 

 

A Nighttime Scene of Hurricane Blanca with VIIRS Longwave IR and Day-Night Band 

 

2. Create a new two-panel map display tab with the File -> New Display Tab -> Map Display -> Two Panels 

menu item. 

 

3. Left-Click in the left panel in the Main Display to make this panel active.  Any displays will appear in the 

active panel. 
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4. Load in the three time-consecutive granules of SVM15 data. 

 

a. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery - Suomi NPP 

 

b. Under Files, use Shift+Click to select the following three files: 

 

<local path>/Data/NPP/HurricaneBlanca/SVM15_npp_d20150606_t0932221* 

<local path>/Data/NPP/HurricaneBlanca/SVM15_npp_d20150606_t0933475* 

<local path>/Data/NPP/HurricaneBlanca/SVM15_npp_d20150606_t0935129* 

 

Note that the <local path>/ Data/NPP/HurricaneBlanca directory includes three GMTCO* 

files (one for each SVM15* file).  These GMTCO* files contain the geolocation data necessary 

for McIDAS-V to plot the SVM15 data.  These GMTCO* files cannot be selected in the Data 

Sources tab of the Data Explorer, only the SVM15 files can be chosen. 

 

c. Click Add Source.  Adding these three files at once will aggregate the data together, combining the 

three individual granules into a single image. 

 

5. Use the swathToGrid formula to display SVM15 Brightness Temperature data in the left panel. 

 

a. In the Field Selector tab, under Data Sources select 

Formulas. 

 

b. Under Fields, select the swathToGrid formula.  Click 

Create Display. 

 

c. In the Select input window, enter values of 750 for res 

and 1.0 for mode and click OK.  

 

d. At the top of the Field Selector window, choose the 

VIIRS* -> IMAGE -> VIIRS-M15-

SDR_All/BrightnessTemperature field. 

 

c. The Region panel gives a preview image of the display.  

The region of interest is contained within the bowtie 

deletion lines.  Use Shift+Left-Click+Drag to subset an 

area around the hurricane.  Anything contained with the 

green bounding box will be displayed at full-resolution 

with the bowtie removed by the formula.  Note that the 

entire region must be contained within the granule’s data.  

 

d. Click OK. 
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6. The default enhancement applied to the display is gray scale.  Change this to inverse gray scale by going to 

the Layer Controls tab of the Data Explorer and clicking on the Gray scale button.  Use the dropdown 

menu to select System -> Inverse Gray Scale.  

 

7. Left-Click in the right panel in the Main Display to make this panel active.  Any displays will appear in the 

active panel. 

 

8. Load in the Suomi NPP Day/Night band granule. 

 

a. In the Data Sources tab of the Data Explorer, navigate to the Under Development -> Imagery - Suomi 

NPP chooser. 

 

b. Load in the three time-consecutive granules of SVDNB day-night band data using the same method 

from step 4b earlier. 

 

<local path>/Data/NPP/HurricaneBlanca/SVDNB_npp_d20150606_t0932221* 

<local path>/Data/NPP/HurricaneBlanca/SVDNB_npp_d20150606_t0933475* 

<local path>/Data/NPP/HurricaneBlanca/SVDNB_npp_d20150606_t0935129* 

 

Note that the <local path>/ Data/NPP/HurricaneBlanca directory includes three GDNBO* files (one 

for each SVDNB* file).  These GDNBO* files contain the geolocation data necessary for McIDAS-V to 

plot the SVDNB data.  These GDNBO* files cannot be selected in the Data Sources tab of the Data 

Explorer, only the SVDNB files can be chosen. 

 

c. Click the Add Source button. 

 

9. Select the field to display, the display type, and display the data at full-resolution. 

 

a. In the Fields panel of the Field Selector, expand the IMAGE dropdown to view the fields included with 

the data.  Select the VIIRS-DNB-SDR_ALL/Radiance field. 

 

b. In the Displays panel, select Imagery -> Image Display. 

 

c. The Region panel gives a preview image of the display.  By default, McIDAS-V will display the data at 

a reduced resolution to save on memory usage.  To display the data at full resolution, use Shift+Left 

Click+Drag to subset a region around the hurricane.  Anything contained with the green bounding box 

will be displayed at full-resolution.  Note that the entire region must be contained within the granule’s 

data.  

 

d. Click Create Display. 
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10. Adjust the display to make the hurricane more visible. 

 

a. Zoom in on the region of interest in the Main Display by using Shift+Left-Click+Drag.  The display 

region can be further customized by zooming in/out with the scroll wheel on the mouse and the display 

can be translated using Control+Right-Click+Drag. 

 

b. Adjust the colorbar range to make the data visible by going to the Layer Controls tab of the Data 

Explorer and clicking on the Gray scale button.  Use the dropdown menu to select Change Range.  In 

the Change Range window, set From to 1.5E-10 and set To to 1.5E-8.  Click OK. 

 

11. Investigate the display to determine different features that can be seen in the day-night band and longwave 

infrared band. 

 

Precipitation in Hurricane Blanca with ATMS Microwave Data 

12. Left-Click on the left panel in the Main Display window to make this panel active. 

 

13. Load in the ATMS data. 

 

a. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery - Suomi NPP 

 

b. Under Files, select the following file: 

 

<local path>/Data/NPP/HurricaneBlanca/SATMS_npp* 

 

Note that the <local path>/ Data/NPP/HurricaneBlanca directory includes a GATMO* file.  

The GATMO * file contain the geolocation data necessary for McIDAS-V to plot the SATMS 

data.  The GATMO * file cannot be selected in the Data Sources tab of the Data Explorer, only 

the SATMS file can be chosen. 

 

c. Click Add Source. 

 

14. Create a multi-spectral display of the ATMS data. 

 

a. In the Fields panel of the Field Selector, select the MultiSpectral -> ATMS-

SDR_All/BrightnessTemperature field. 

 

b. In the Displays panel, select the Imagery -> MultiSpectral Display display type. 

 

c. In the Region tab, use Shift+Left-Click+Drag to subset an area around the hurricane. 

 

d. Click Create Display. 
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15. The display of the ATMS data now overlaps the SVM15 data displayed earlier.  Open the Legend for this 

tab and toggle between layer visibilities. 

 

a. The Main Display shows a display of the data and includes two data probes that are overlaid on top of 

each other.  Use Left-Click+Drag to position the probes in two different locations.  For example, place 

one over the hurricane, and one over open water. 

 

b. In the left panel of the Main Display, select the View -> Displays -> Float Legend menu item.  This 

opens a Legend window similar to that used in a one panel display. 

 

c. The top layer listed under the Imagery tree, MultiSpectral, is the ATMS layer.  Turn the visibility of 

this layer on and off by toggling the checkbox next to the layer.  This allows for easily comparison of 

the VIIRS SVM15 and ATMS brightness temperature data. 

 

16. In the Layer Controls tab of the Data Explorer, change the frequency using either Left-Click+Drag on the 

green selector line, or by using the Band dropdown at the bottom of the tab.  Notice how the display 

changes with different frequencies.  Investigate how the display appears at different frequencies. 

 

a. Higher frequency values are useful for detecting ice because of the scattering. 

 

b. Lower frequency values are useful for detecting liquid water because of the emission.  One good band 

for detecting precipitation within Hurricane Blanca is band 4.  Within the hurricane, the lighter colored 

areas (colder) are representative of areas of precipitation. 
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Problem Sets 

The previous examples were intended to give you a general knowledge of how to load and display Suomi NPP 

data.  The problem sets below are intended to introduce you to new topics related to the data, as well as 

challenge your knowledge of McIDAS-V.  We recommend that you attempt to complete each problem set 

before looking at the solutions, which are provided below the problem set. 

1. Using the <local path>/Data/NPP/LakeEffectRGB/GMODO-SVM03-SVM04-SVM05* file, create an 

RGB image using the Reflectance field of all three bands.  Create the display by using the 

VIIRS_M_RGB(M5,M4,M3) formula.  Display the data at full-resolution and make sure to include a large 

portion of the granule in your subsetted region.  Adjust the Common Gamma field in the Layer Controls to 

make the individual colors stand out more in the display. 

 

2. Looking at the display over the Great Lakes, it is difficult to discern between clouds and snow over the land. 

Using the <local path>/Data/NPP/LakeEffectRGB/GMODO-SVM14* data, display brightness 

temperature data with the swathToGrid formula over the Great Lakes region.  Adjust the enhancement to 

make the clouds display as white instead of black.  Overlay this display on the RGB image created in 

problem 1. This longwave infrared band is useful to distinguish between clouds and snow.  

 

3. Looking at the RGB display over Louisiana, smoke can be observed.  Using the <local 

path>/Data/NPP/LakeEffectRGB/GMODO-SVM13* data, display brightness temperature data with the 

swathToGrid formula over Louisiana.  Overlay this display on the RGB image created in problem 1.  This 

medium-wave infrared band is useful to detect fire activity. 

 

4. Determine the smoke concentration from the Louisiana fire using the <local 

path>/Data/NPP/LakeEffectRGB/GMTCO-VSUMO* VIIRS suspended matter EDR data.  Overlay this 

display on the RGB image created in problem 1.  
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Problem Set #1 – Solution 

Using the <local path>/Data/NPP/LakeEffectRGB/GMODO-SVM03-SVM04-SVM05* file, create an RGB 

image using the Reflectance field of all three bands.  Create the display by using the 

VIIRS_M_RGB(M5,M4,M3) formula.  Display the data at full-resolution and make sure to include a large 

portion of the granule in your subsetted region.  Adjust the Common Gamma field in the Layer Controls to 

make the individual colors stand out more in the display. 

1. Remove all layers and data sources from the previous displays. 

 

2. Select File -> New Display Tab -> Map Display -> One Panel to create a new one-panel map display tab. 

 

3. Load in a granule containing three bands of VIIRS SVM visible data (SVM03, SVM04 and SVM05). 

 

a. In the Data Sources tab of the Data Explorer, select Under Development > Imagery – Suomi NPP 

 

b. Select <local path>/Data/NPP/LakeEffectRGB/GMODO-SVM03-SVM04-SVM05_npp*  

(Note: this file packages the geolocation (GMODO) and the data (SVM*) together into the same file.) 

 

c. Click the Add Source button. 

 

4. Use the VIIRS formula to create a true-color RGB image with the bowtie effect removed. 

 

a. In the Field Selector tab, under Data Sources select Formulas. 

 

b. Under Fields, select the VIIRS_M_RGB(M5,M4,M3) formula.  Click Create Display. 

 

c.  In the new Field Selector window, select:  

 

 For Field: M5, select VIIRS -> IMAGE -> VIIRS-M5-SDR_All/Reflectance  

 For Field: M4, select VIIRS -> IMAGE -> VIIRS-M4-SDR_All/Reflectance 

 For Field: M3, select VIIRS -> IMAGE -> VIIRS-M3-SDR_All/Reflectance 

 

d. In the Region tab of Field: M5, use 

Shift+Left-Click+Drag to select a region to 

display at full-resolution.  Select a region 

that contains most of the granule, as shown 

in the image below.  It is not necessary to 

subset a region in for M4 and M3, as the 

region selected for M5 will be used for all 

fields. 

 

e. Click OK to display the results of the 

VIIRS_M_RGB(M5,M4,M3) formula. 



Page 9 of 13 

McIDAS-V Tutorial – Displaying Suomi NPP Data        January 2016 – McIDAS-V version 1.5 

 

5. Adjust the display to enhance the Red, Green, and Blue components of the display. 

 

a. Navigate to the Layer Controls tab of the Data Explorer.  By default, all Gamma values for all colors 

are set to 1.0.  Change this value to 0.4 by entering in 0.4 in the Common Gamma field and clicking the 

Apply to All Gamma Fields button. 

 

b. Return to the Main Display window to observe the RGB display and also notice that the bowtie effect 

has been removed by the formula. 

 

Problem Set #2 – Solution 

Looking at the display over the Great Lakes, it is difficult to discern between clouds and snow over the land. 

Using the <local path>/Data/NPP/LakeEffectRGB/GMODO-SVM14* data, display brightness temperature 

data with the swathToGrid formula.  Adjust the enhancement to make the clouds display as white instead of 

black.  Overlay this display on the RGB image created in problem 1. This longwave infrared band is useful to 

distinguish between clouds and snow. Remove all layers and data sources from the previous displays. 

1. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery -> Suomi NPP  

 

a. Under Files, select the following file:<local path>/ Data/NPP/LakeEffectRGB/GMODO-SVM14* 

 

b. Click the Add Source button. 

 

2. Use the swathToGrid formula to create a full-resolution display of 

the data without the bowtie effect. 

 

a. In the Field Selector tab, under Data Sources select Formulas. 

 

b. Under Fields, select the swathToGrid formula.  Under Displays, 

select Imagery > Image Display.  Click Create Display.  

 

c. In the new Select input window, enter 750 for res and 1.0 for 

mode.  Click OK. 

 

d. In the Field Selector, select VIIRS* -> IMAGE -> VIIRS-M14-

SDR_All/BrightnessTemperature. 

 

e. In the Region tab, use Shift+Left-Click+Drag to select a region 

over the Great Lakes (as seen in the image on the right) to display 

at full-resolution. 

 

f. Click OK to display the result of the swathToGrid formula. 
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3. Adjust the display to make the clouds over the Great Lakes appear as white instead of black and investigate 

the display. 

 

a. Change the colorbar to Inverse Gray Scale.  To do this, Right-Click on the colorbar in the Legend and 

select System -> Inverse Gray Scale.  This is done to make the lower data values (colder temperatures, 

such as clouds) display as white, while warmer temperatures are black. 

 

b. Use the visibility checkbox in the Legend to toggle the SVM14 layer on and off to compare with the 

RGB display underneath.  The temperature difference between clouds and snow in this infrared band 

allows the clouds to stand out more than they do in the visible bands used in the RGB display. 

Problem Set #3 – Solution 

Looking at the RGB display over Louisiana, smoke can be observed.  Using the <local path>/Data/NPP/ 

LakeEffectRGB/GMODO-SVM13* data, display brightness temperature data with the swathToGrid formula 

over Louisiana.  Overlay this display on the RGB image created in problem 1.  This medium-wave infrared 

band is useful to detect fire activity. 

1. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery -> Suomi NPP 

 

a. Under Files, select the following file:  <local path>/Data/NPP/LakeEffectRGB/GMODO-SVM13* 

 

b. Click the Add Source button. 

 

2. Use the swathToGrid formula to create a full-resolution display of the 

data without the bowtie deletion. 

 

a. In the Field Selector tab, select Formulas under Data Sources.  

 

b. Under Fields, select the swathToGrid formula.  Under Displays, 

select Imagery -> Image Display.  Click Create Display. 

 

c. In the new Select input window, enter 750 for res and 1.0 for mode.  

Click OK. 

 

d. In the Field Selector window, select VIIRS* -> IMAGE -> VIIRS-

M13-SDR_All/BrightnessTemperature. 

 

In the Region tab, use Shift+Left-Click+Drag to select a region over 

Louisiana to display at full-resolution.  Click OK to display the result 

of the swathToGrid formula. 

 

3. Use the visibility checkbox in the Legend to toggle the SVM13 layer on 

and off to compare with the RGB display underneath. 
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Problem Set #4 – Solution 

Determine the smoke concentration from the Louisiana fire using the <local path>/Data/NPP/ 

LakeEffectRGB/GMTCO-VSUMO* VIIRS suspended matter EDR data.  Overlay this display on the RGB 

image created in problem 1. 

1. In the Data Sources tab of the Data Explorer, navigate to the Under Development -> Imagery -> Suomi 

NPP chooser. 

 

a. Under Files, select the following file: 

<local path>/Data/NPP/LakeEffectRGB/GMTCO-VSUMO* 

 

b. Click the Add Source button. 

 

2. Display the smoke concentration from the EDR data. 

 

a. In the Fields panel of the Field Selector, select: 

Image -> VIIRS-SusMat-EDR_/All/SmokeConcentration field. 

 

b. Select Imagery -> Image Display in the Displays panel of the Field Selector. 

 

c. In the Region tab of the Field Selector, use Shift+Left Click+Drag to subset a region over Louisiana.  

Anything within this subsetted region will display at the full resolution of the data. 

 

d. Click Create Display. 

 

3. Investigate the smoke concentration from the Louisiana fire. 

 

a. In the Legend of the Main Display, toggle off the visibilities of the SVM13 and SVM14 data so only the 

RGB and the VIIRS EDR data is displayed. 

 

b. Navigate over the fire in Louisiana and toggle the VIIRS EDR layer on and off with the visibility 

checkbox in the Legend. 

 

c. With the EDR data displayed, hold down the middle mouse button over the smoke region to see probe 

output of smoke concentration at the bottom of the display. 
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The following table lists out band, wavelength and resolution information for VIIRS SVM, DNB (Day/Night 

Band) and SVI data.  Source: http://rammb.cira.colostate.edu/projects/npp/ 
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Zooming, Panning, and Rotating Controls 

 

Zooming Panning Rotating 

 Mouse  

Shift-Left Drag: Select a region 

by pressing the Shift key and 

dragging the left mouse button. 

Shift-Right Drag: Hold Shift key 

and drag the right mouse button. 

Moving up zooms in, moving 

down zooms out. 

Control-Right Mouse Drag: 

Hold Control key and drag right 

mouse to pan. 

Right Mouse Drag: Drag right 

mouse to rotate. 

 Scroll Wheel  

Scroll Wheel-Up: Zoom Out. 

Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-

Up/Down: Rotate 

clockwise/counter clockwise. 

Shift-Scroll Wheel-Up/Down: 

Rotate forward/backward 

clockwise. 

 Arrow Keys  

Shift-Up: Zoom In. 

Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 

Control-Down arrow: Pan Up. 

Control-Right arrow: Pan Left. 

Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate 

around vertical axis. 

Up/Down arrow: Rotate 

around horizontal axis. 

Shift-Left/Right arrow: Rotate 

Clockwise/Counterclockwise. 

 


