
McIDAS-V Tutorial 
Displaying Point Observations 

updated August 2009 (software version 1.0beta4) 
 

 

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation 
in SSEC's 35-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 
(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 
manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and 
Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands 
and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being 
integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data. 
 
McIDAS-V is currently a beta version of the software, which means that the software may contain bugs and not 
always work as expected.  If you encounter any errors, please send them to the McIDAS Help Desk at 
mug@ssec.wisc.edu .  You will be notified at the startup of McIDAS-V when new versions are available on the 
McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/ .    More training materials are available 
on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-V User’s Guide, which is 
available from the Help menu within McIDAS-V.   
 
This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 
McIDAS-V.  If you can not start McIDAS-V on your machine, you should follow the instructions in the 
document entitled McIDAS-V Tutorial – Installation and Introduction.   

In this McIDAS-V Tutorial, each exercise will use real-time access to default remote servers.  You must have 
internet access to complete this lesson.  If you have access to your own real-time ADDE servers, you may also 
use those, but be aware that different server configurations may make the explanations in this document not 
quite applicable to all data that you may load.   

Note:  Users of data from the SSEC Data Center can use the "Import from URL" feature of the ADDE Server 
Manager and automatically include all of the SSEC Data Center servers in the McIDAS-V server lists.  From 
the main menu, select Edit -> Preferences -> ADDE Servers -> Import From URL and enter the URL 
(http://www.ssec.wisc.edu/mcidas/software/v/addeservers.xml), your User ID, and Project #.   
 
Plotting and Contouring Surface Point Observations around the world 
 
1. Remove all layers and data sources from the previous displays.   
 
2. If you have created more than one tab, close the extra tabs by clicking on the “X” in the right corner of the 

tabs.   
 
3. Select the Point Observations -> Plot/Contour chooser.  
 

a. Connect to adde.ucar.edu with the Dataset RTPTSRC.   
 
b. Choose the SFCHOURLY - Real-Time SFC Hourly Point Type.   
 
c. Select the most recent time and click Add Source.   
 
d. In the Field Selector, select Point Data in the Fields panel.   
 

mailto:mug@ssec.wisc.edu
http://www.ssec.wisc.edu/mcidas/software/v/addeservers.xml
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e. In the lower-right panel, click the Layout Model tab and click METAR to select 
Observations>Temperature to plot all available temperatures. 

 
f. Click Create Display.  The default display is a world projection with temperatures plotted from around 

the world.  As you zoom in you will see more stations appear in the plot.   
 
4. Reset the display projection.   
 
5. Return to the Data Sources tab and select the Satellite -> Imagery chooser.   
 

a. Connect to the adde.ucar.edu server with the dataset RTIMAGES  
 
b. Select an Image Type of GOES-East 0.65 um Visible, select the most recent image and create the 

display. 
 
6. To contour the temperatures plotted on the screen, return to the Field Selector 

 
a. Click on the “SFCHOURLY” data source. 
 
b. In the Fields tab, click on the  icon next to Gridded Fields, and select T from the list of available 

Fields.   
 
c. Select Contour Plan View in the List of Displays, and Create Display.  The contour properties can be 

changed in the Layer Controls tab of the Contour Plan View. 
 
 
Creating Time Series of Point Observations 
 
1. Remove all layers and data sources.   
 
2. Return to Point Observations -> Plot/Contour source in the Data Sources tab 
 

a. Select a group of times from the Absolute time tab (to select more than one time, use Control-Click 
or Shift-Click), and click Add Source.   

 
b. Select Point Data in the Fields panel and click Create Display to plot the default station models. 

 
3. In the Layer Controls, follow these steps: 

 
a. Click on the Plot tab to create a time series.  

 
b. Zoom in over a station in the main display and click on the center of it.  The station information 

should fill into the table below the plot in the Layer Controls.   
 

c. Add the temperature to the plot by right clicking on the T field in the table and selecting Add To 
Chart.   
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Problem Sets 
 
The previous examples were intended to give you a general knowledge of how to load and display surface and 
upper air point data.  The problem sets below are intended to introduce you to new topics related to the data, as 
well as challenge your knowledge of McIDAS-V.  We recommend that you attempt to complete each problem 
set before looking at the solutions, which are provided below the problem set. 
 
1. Create a time series of surface Temperature, Dewpoint Temperature and Wind Barbs for the last 24 hours 

over Chicago (KORD).  Change the Temperature and Dewpoint Temperature axes in the plot so they have 
the same range.  Look at the current zone forecast for Chicago to check the accuracy of the forecast for 
today. (Hint:  Weather text products can be found under Tools->Text Data) 

 
2. Modify the chart from problem #1 so you have three separate charts:  Place Wind Barbs and Gusts in the top 

left chart, Pressure in the top right chart, and Temperature and Dewpoint Temperature in the bottom chart  
(Hint: Change the chart names to separate out parameters!) 

 
3. Create your own station model layout that display the Dewpoint Depression in green over the center of the 

station with the station ID below the Dewpoint Depression, the Temperature to the upper left, and Dewpoint 
Temperature to the upper right.  Display the most recent observations using the new layout. 

 
Problem Set #1 – Solution 
 
Create a time series of surface Temperature, Dewpoint Temperature and Wind Barbs for the last 24 hours over 
Chicago (KORD).  Change the Temperature and Dewpoint Temperature axes in the plot so they have the same 
range.  Look at the current zone forecast for Chicago to check the accuracy of the forecast for today. (Hint:  
Weather text products can be found under Tools->Text Data) 
 
1. Remove all layers and data sources from the previous display.   
 
2. Return to the Data Sources tab, select the Surface Hourly Point Type and the 24 most recent times with the 

interval set to Hourly, and create the Point Data Plot display.   
 
3. Use the Zooming and Panning controls to zoom in over Chicago, and left-click on the Chicago Ohare 

International station (KORD).   
 
4. In the Layer Controls, click on the Plot tab, and at the bottom, scroll down through the list of fields until 

you find temperature (T).   
 
5. Right-click on T and select Add to Chart, and repeat for dewpoint temperature (TD).   
 
6. To add wind barbs, add speed (SPD) and direction (DIR) to the chart.  When both of these parameters are 

added, they are converted into windbarbs. 
 
7. Right-click on the table of fields and select T -> Chart Properties. 
 

a. In the Range: property, enter in a Min and Max value appropriate for both Temperature and Dewpoint 
Temperature.  Click OK. 
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8. Right-click on the table of fields and select TD -> Chart Properties. 
 

a. To the right of the Range: property, there is a ... button.  Click on this button and select “Fixed Range 
from T...”, and click OK. 

 
9. Open up the Weather Text Product Display by selecting Tools->Text Data->Weather Text Products (from 

server). 
 

a. Open up the Public Products->Zone Forecasts. 
 
b. In the main display window, zoom in over Illinois and click on KLOT.  The zone forecast for KLOT, 

including Chicago will now be shown in the weather text product window. 
 
Problem Set #2 – Solution 
 
Modify the chart from problem #1 so you have three separate charts:  Place Wind Barbs and Gusts in the top 
left chart, Pressure in the top right chart, and Temperature and Dewpoint Temperature in the bottom chart  
(Hint: Change the chart names to separate out parameters!) 
 
1. Return to the Temperature chart properties by right-clicking on the table of fields and selecting T -> Chart 

Properties. 
 

a. Enter in “Temperature” in the Chart Name. 
 
b. Click OK.  The Temperature plot should appear in a new chart below the current plot titled “Plot”. 

 
2. Repeat this step for Dewpoint Temperature and place it in the “Temperature” plot. 
 
3. Add Wind Gusts and pressure to the charts and place pressure in a separate chart titled “Pressure”. 
 
4. Select View -> Chart -> Layout -> Change Grid Layout from the Layer Control menu. 
 

a. Use the Columns and Rows buttons to add/remove new columns and rows.   
 
b. Left-click and drag on a chart to move it to a different location. 

 
c. Use the black squares around the individual charts to control their width and length. 

 
Problem Set #3 – Solution 
 
Create your own station model layout that displays the Dewpoint Depression in green over the center of the 
station with the station ID below the Dewpoint Depression, the Temperature to the upper left, and Dewpoint 
Temperature to the upper right.  Display the most recent observations using the new layout. 
 
1. Remove all layers.   
 
2. In the main menu select Tools -> Station Model Template.   
 
3. In the editor, select File -> New and enter in “Dewpoint Depression” for the name of the layout.  
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4. Click on “123 Value” and click in the middle of the layout.  The Properties Dialog box will pop up.   
 
5. In the Parameter:, enter in:  =T-TD 
 
6. Change the Foreground Color to green, and click OK.   
 
7. Add a Temperature and Dewpoint Temperature value in the appropriate locations.   
 
8. In the editor select File -> Save and then close the window.   
 
9. Load the most recent surface hourly data into the Field Selector.   
 

a. In the Fields tab, select Point Data. 
 
b. In the Layout Model tab in the lower right corner, change the model to “Dewpoint Depression.”. 

 
Plotting Upper Air Observations 
 
1. Upper Air point data can be loaded the same way as Surface Data. 
 

a. Remove all layers and data sources. 
 

b. Return to the Data Sources tab. 
 

c. Choose the UPPERMAND - Real-Time Upper Air (Mandatory) Point Type. 
 

d. Select the 5 most recent times. 
 

e. Select an Interval: 12 Hourly. 
 

f. Click Add Source. 
 

g. In the Field Selector, select Point Data in the Fields panel. 
 

h. In the Levels tab, select the pressure level to plot. 
 

i. Click Create Display. 
 
Displaying RAOB Sounding Data 
 
1. Select the Point Observations -> Soundings  -> Remote source from the Data Sources tab.   
 
2. Connect to the server adde.ucar.edu with the group RTPTSRC.   

 
3. Select UPPERMAND for the Mandatory Levels, and UPPERSIG for the Optional Significant Levels. 
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4. Pick the station for your sounding display.   
 

a. Use the zooming and panning buttons to find your station(s).   
 
b. Select an available time and click on your station to see if a sounding is available.  Available soundings 

will show up in the Selected box on the bottom right of the chooser.   
 

c. If more than one is available for your station, select the most recent time and add the source.   
 

d. Under the Displays tab of the Field Selector, you have the option to choose which type of 
thermodynamic diagram to display (Skew-T, Stuve, Emagram).   

 
e. Select one of the thermodynamic diagrams and create the display. 

 
5. The sounding will show up in a 2D display in the Layer Controls tab along with a list of thermodynamic 

parameters.  As you move the mouse over the sounding, the thermodynamic parameters will update.   
 

 
 
6. The temperature and dew-point traces can be modified via the cursor.  
 

a. Press the left button on the first data-point to be modified and drag it horizontally along an isobar to the 
desired position, then move the pointer diagonally along an isotherm to keep the data-point at the 
desired position and to pick-up the next data-point.  

 
b. Repeat until done and then release the mouse button.   

 
c. To reset the sounding, go to Edit ->Reset Sounding in the main menu of the Layer Controls tab.   
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d. You can also choose to display the parcel path or vertical temperature on the sounding using the 
checkboxes below the sounding.  When the Stations box is checked, you will see a square box in the 
main display indicating the location of the sounding.  

 
Displaying Wind Profiler Observations 
 
1. Remove all layers and data sources and turn on the Auto-set Projection option.   
 
2. Select the Point Observations -> Wind Profiler source from the Data Sources tab.   
 

a. Connect to adde.ucar.edu with the dataset RTPTSRC (alternatives: adde.cise-nsf.gov, 
stratus.al.noaa.gov, or weather2.admin.niu.edu).   

 
b. Select a Profiler Type of Real-Time 6 Minute Profiler Data.  
 
c. Select two stations and the 24 most recent times.   

 
d. Use a 30 minute interval and load the data source.   

 
e. Opening up the tree of the Fields tab in the Field Selector by clicking on the  icon will allow you to 

choose to display each station individually, or as a group if you leave Profiler winds selected.   
 

f. Display all stations as a Time/Height Display, and the data will be displayed in the 2D display in the 
Layer Controls tab.   

 
g. The 24 most recent times will be displayed, with the latest data on the left.  This can be switched by 

turning off the Latest Data on the Left checkbox.   
 

h. Change the display to different stations using the Stations pull down tab.   
 

i. Modify the windbarb size and vertical interval to see how the display changes. 
 
3. Return to the Field Selector and create a 3D view display.   
 
4. Zoom out of the display to see all of the stations, as the default zooms in on one of the stations.   
 
5. Rotate the view so you are looking at the profiler displays from the south.   
 
6. Use the Time Animation Controls to loop through the selected times and observe how the profiler displays 

change.   
 
7. The windbarb size and vertical interval can be modified in the Layer Controls tab. 
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Zooming, Panning, and Rotating Controls 
 

Zooming Panning Rotating 
 Mouse  
Shift-Left Drag: Select a region 
by pressing the Shift key and 
dragging the left mouse button. 
Shift-Right Drag: Hold Shift key 
and drag the right mouse button. 
Moving up zooms in, moving 
down zooms out. 

Control-Right Mouse Drag: 
Hold Control key and drag right 
mouse to pan. 

Right Mouse Drag: Drag right 
mouse to rotate. 

 Scroll Wheel  
Scroll Wheel-Up: Zoom Out. 
Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-
Up/Down: Rotate 
clockwise/counter clockwise. 
Shift-Scroll Wheel-Up/Down: 
Rotate forward/backward 
clockwise. 

 Arrow Keys  
Shift-Up: Zoom In. 
Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 
Control-Down arrow: Pan Up. 
Control-Right arrow: Pan Left. 
Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate 
around vertical axis. 
Up/Down arrow: Rotate 
around horizontal axis. 
Shift-Left/Right arrow: Rotate 
Clockwise/Counterclockwise. 

 


