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McIDAS-V Tutorial
Displaying Polar Satellite Imagery
updated SeptemberSeptember 2013 2018 (software version 1.48)


McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in SSEC's 40-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data.

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/ .
If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share information with other users.

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the document entitled McIDAS-V Tutorial – Installation and Introduction.


Terminology
There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer).
The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field Selector, displayed in the Main Display, and output is formatted in the Layer Controls.
Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources).
Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).



Loading Polar Satellite Images and Loops

1. Create a local dataset to access the imagery files on your local machine.

a. In the Main Display window of McIDAS-V, select Tools -> Manage ADDE Datasets.

b. In the ADDE Data Manager, select File -> New Local Dataset.  Enter in the following parameters to set up a dataset with the MODIS Level 1b HDF files provided with this tutorial:

· Dataset – MODIS
· Image Type – HDF MOD02 1km  filess
· Format – MODIS MOD 02 – Level-1B Calibrated Geolocated Radiances
· Directory – select the <local path>/Data/Polar/modis_filess directory



c. Click Add Dataset.

d. Close the ADDE Data Manager by clicking Ok or File -> Close.

2. To load the data in this local dataset, follow these steps.
a. Click on the  button in the Main Toolbar to go to the Data Explorer.

b. Select the Satellite -> Imagery chooser from the Data Sources tab.

c. Select <LOCAL-DATA> for the Server, select MODIS for the Dataset, and click Connect.

d. Choose the 1km HDF MOD02 1KM 1km files Image Type and select an Absolute time of 0221:50 00 UTC.

e. Click Add Source to show the Field Selector.

f. Select 0.6465 um Land/Cloud Boundaries -> Brightness.

g. Click Create Display.  The 0221:50 00 UTC 0.6465 μm image is displayed in the Main Display window.


3. Use the zooming and panning controls in the left toolbar to inspect the image.  Specifically, notice the fires in Northern California and Southern Oregon.
Use the zooming and panning controls in the left toolbar to inspect the image.

Reset the display projection by clicking on the  icon below the zooming buttons on the left toolbar.

a. Reproject the image with a pre-defined domain.  Select Projections -> Predefined -> AsiaUS -> CONUS.  Use the scroll wheel to zoom into the image or Shift+Left Click+Drag a box around the image.

b. Turn off the Auto-set Projection option under the Projections menu.  When this option is checked, the projection will automatically change to the native projection of the new layer.  When this option is unchecked, all new layers will be reprojected into the current projection.

4. Return to the Field Selector to load an atmospheric temperature image.

a. Select 4.5454 um Atmospheric Temperature -> Temperature.

b. Click Create Display.  The 4.5454 µm temperature image is overlaid on top of the visible image.  To see the visible image, turn off the top HDF MOD02 1km file (All Bands...) checkbox in the Legend.

5. Use the cursor readout option to see the temperature values for the fire pixels.

a. Turn the HDF MOD02 1km file (All Bands...) checkbox in the Legend back on.

b. Click and drag the middle mouse button to activate the Cursor/Data Readout option and list the latitude, longitude, and data value under the cursor.  Since there are two layers in the main display, there are two different readouts with the appropriate values and units.  Notice the high 4.5454 μm temperature values are located at the location of the fire.  The data probe from the cursor/data readout option shows that values in the fire are approximately 50 degrees K warmer than outside of the fire.

6. Edit the maps in the display by using the options in the Layer Controls.

a. Click on Default Background Maps in the Legend to go to the Layer Controls.  The map controls will have two tabs.  The first Maps tab lists the available maps, and the second Lat/Lon tab allows the user to control latitude and longitude lines and labels. At the bottom of both tabs, there is a Position slider that allows you to control the vertical positioning of the maps in the Main Display.

b. In the Maps tab you can remove a map, change its visibility, line width, style and color.  Use these options to create your own map display.

c. If you choose, also add latitude and longitude lines and labels in the Lat/Lon tab.

d. To save a map configuration as the default, in the Layer Controls select File -> Default Maps -> Save as the Default Map Set.  The next time you open a new tab, window, or start McIDAS-V, the defaults will reflect what you selected. 
e. 
f. Return to the Field Selector to load an infrared image.
g. 
h. Select 11.0186 um Surface/Cloud Temperature -> Temperature.

i. Click Create Display.
j. 
k. The 11.0186 µm temperature image is overlaid on top of the visible image.  To see the visible image, turn off the top 1km HDF MOD021KM (All Bands...) checkbox in the Legend.  Turn the image back on and click and drag the middle mouse button to activate the Cursor/Data Readout option.  This option brings up a latitude, longitude, and data value readout in the upper left part of the display on a mouse drag.  Since there are two layers in the main display, there are two different readouts with the appropriate values and units.

7. Notice that both layers are labeled the same in the Legend. Change the font and colortext of the labelss on in the Main Display.
 

8. In the Main Display window, choose Edit -> Preferences.  Click on Display Window.

9. In the right column under Layer List Properties, change Font to Arial/Plain/14.  Change the Color to yellow.  Click OK.

10. Return to the Main Display to see the changes. Notice the labels are the same in the Legend and on the main display window label.  This can be customized.
11. 
a. Right Click on the top HDF MOD02 1km files (All Bands...) label in the Legend. label HDF MOD021KM (All Bands...).

b. Choose Edit -> Properties…. Enter the following for the Legend Label Label and Layer Label:
· Legend Label –  11.01864.5454 um - AQUATERRA
· Layer Label – %datasourcename% - 11.0186 um -  %timestamp%




12. Return to the Data Sources tab of the Data Explorer to load another time.

a. In Go to the Data Sources tab of the Data Explorer, selectand using the Satellite -> Imagery chooser with <LOCAL-DATA>/MODIS, select the Image Type HDF MOD02 1KM 1km files Image Type, and an Absolute time of 0220:55 55 UTC.

b. Click Add Source to show the Field Selector.

c. A new data source is created in the Field Selector.  To distinguish it from the first data source, the label is editable.  Right Click on the highlighted 1km HDF MOD02 1KM 1km files (All Bands...) and choose Properties.  In the Name field enter, 1km HDF 21:55 15 UTC MOD02 1KM1km.  Click OK.

d. Select 0.6465 um Land/Cloud Boundaries -> Brightness.

e. Click Create Display.  The 0221:55 15 UTC 0.6465 μm image is displayed in the Main Display window with the other displays also visible (because the Auto-set Projection setting is unchecked).

f. In the Legend, click on the trash can next to 11.08164.5454 µm TERRA AQUA to remove the infrared atmospheric temperature display (the middle one listed with the color table range of 180 to 295.7320).

13. Create a local dataset to access the HRPT (High Resolution Picture Transmission) and GAC (Global Area Coverage) NOAA-18 Area polar orbiter imagery files on your local machine.

a. In the Main Menu Bar of the Main Display window , select Tools -> Manage ADDE Datasets. This will open the ADDE Data Manager.

b. Select File -> New Local Dataset. Enter the following parameters to set up the dataset:

· Dataset – HRPT
· Image Type – HRPT N18 area files
· Format – McIDAS AREA
· Directory – select the <local path>/Data/Polar/HRPT_areas directory.



c. Click Add Dataset.

d. In the ADDE Data Manager, select File -> New Local Dataset. Enter the following parameters to set up the dataset:

· Dataset – GAC
· Image Type – GAC N18 area files
· Format – McIDAS AREA
· Directory – select the <local path>/Data/Polar/GAC_areas directory.



e. Click Add Dataset.

f. Close the ADDE Data Manager by clicking Ok or select File -> Close.

14. Remove all layers and data sources and display HRPT 10.8 um Temperature data.

a. In the Main Display window, select Edit -> Remove -> All Layers and Data Sources.

b. In the Main Display select File -> New Display Tab -> Map Display -> One Panel.


c. In the Satellite -> Imagery chooser of the Data Sources tab of the Data Explorer, select <LOCAL-DATA> for the Server, select HRPT for the Dataset, and click Connect.

d. Choose the HRPT N18 area files Image Type and select an Absolute time of 04:45:04 UTC.

e. Select Lat/Lon for the Navigation.

f. Click Add Source to show the Field Selector.

g. Select 10.8 um Surface/Cloud-top Temp -> Temperature.

h. Under Displays click on the Advanced tab.  Click on the green arrow icon next to Image Size to load the full image. Change the Magnification to 1 X 1 with the sliders, and click Create Display.  (The Magnification of 1 X 1 downloads the full resolution of the data.  Negative magnification values will reduce the amount of data downloaded.  For example, -5 X -5 will sample the data, and every fifth line and every fifth element is sent from the server.)

i. There are some bad data points in this image that cause the minimum and maximum values of the color table to be 0 and 6553.1.  Change the range of the color table by right clicking on the color table in the Legend, selecting Change Range..., and entering the values of From: 330 and To: 180.

15. Load an FY2E satellite image over the HRPT image.  This dataset was previously created in the Displaying Satellite Imagery tutorial.

a. In the Data Sources tab of the Data Explorer, using the Satellite -> Imagery chooser, select <LOCAL-DATA> for the Server, select ZQ_IR for the Dataset, and click Connect.

b. Choose the FY2E IR satellite data Image Type and select an Absolute time of 05:01 UTC.

c. Click Add Source to show the Field Selector.

d. Select 10.8 um Surface/Cloud-top Temp -> Temperature.

e. Under Displays click on the Advanced tab.  Click on the green arrow icon next to Image Size to load the full image. Change the Magnification to 1 X 1 with the sliders, and cClick Create Display.

Auto-set Projection is off from a previous exercise. To change to the FY2E image’s native projection, in the Main Display, select Projections -> From Displays -> Image (GMSX) Projection from: Image Display.
16. Center
Zoom the Main Display over the HRPT image and place the HRPT image over the FY2E image.  Compare the two displays.

a. Turn off the FY2E full disk image by unchecking the FY2E IR Satellite Data box in the Legend.

b. Use Shift+Left Click+Drag to create a box over the HRPT image to zoom into it.

c. Turn on the FY2E full disk image by rechecking the FY2E IR Satellite Data box in the Legend.

d. In the Legend, Right Click on the HRPT N18 area files and select View -> Bring to Front.

e. Use the middle mouse button to click and probe the data for a temperature comparison.  Note that the resolution of the HRPT data is better than the FY2E data.

f. If the map lines in the display are missing or dashed instead of solid lines, click on Default Background Maps in the Legend to go to the Layer Controls.  In the Maps tab, change the setting for Fast rendering for each of the displayed maps.
g. 
17. Make the data ranges the same for both images and compare them.

a. In the Legend, Right Click on the FY2E IR satellite data’s color table and select Change Range....  In the window enter From: 330 and To: 180.  Click OK.

b. Use the middle mouse button to click and probe the data for a temperature comparison.
c. 

Creating RGB images using formulas

18. Create Add MODIS data using the local MODIS server created earlier in this tutorial.a local dataset to access a MODIS hdf file on your local machine and add the data.

a. In the Main Display, select the Tools -> Manage ADDE Datasets menu item.

b. In the ADDE Data Manager, select File -> New Local Dataset.  To set up a dataset with a MODIS hdf files provided with this tutorial enter the following parameters: Dataset: MODIS, Image Type: MODIS half km file, Format: MODIS MOD 02 – Level 1B Calibrated Geo-located Radiances.  Under Directory:, select the <local path>/Data/Satellite/modis_files directory. Click Add Dataset.

c. Close the ADDE Data Manager by clicking Ok or select File -> Close.

d. Remove All all Layers layers and Data data Sourcessources.

e. In the Data Sources tab of the Data Explorer, using the Satellite -> Imagery chooser, select <LOCAL-DATA> for the Server, select MODIS for the Dataset, and click Connect.

f. Choose the HDF MOD02 1km  MODIS half km files Image Type and select the Absolute time of 0221:50 00 UTC.

g. Click Add Source to show the Field Selector.

19. Define the Red, Green, and Blue channels of your image display.

a. Click on Formulas under the Data Sources listed in the Field Selector.

b. Select Imagery -> Three Color (RGB) Image, and click Create Display.

c. In the Field Selector, select MHDF MOD02ODIS half 1km files -> 0.6465 um -> Brightness as red, MODIS... -> 0.5537 um -> Brightness as green, and MODIS... -> 0.4656 um -> Brightness as blue and click OK.

d. Change the projection to over the United States via Projections -> Predefined -> US -> CONUS in the Main Display. Use Shift+Left Click+Drag to zoom in on the data.

Problem Sets

The previous examples were intended to give you a general knowledge of how to load and display polar satellite data.  The problem sets below are intended to introduce you to new topics related to the data, as well as challenge your knowledge of McIDAS-V.  We recommend that you attempt to complete each problem set before looking at the solutions, which is provided below the problem set.

1. Load a loop of GAC (Global Area Coverage) NOAA-18 images on a Globe Display.  Load visible and low-level water vapor images.  Animate the loop on a rotating globe with a solid blue background image.  Use the GAC N18 dataset created earlier in this tutorial.

2. Load a HRPT NOAA-18 image.  Display the polar orbit track for the image using a two-line element text file with the Polar Orbit Track chooser.  Add the swath width and antenna circles for the Wallops ground station.

Problem Set #1 – Solution

Load a loop of GAC (Global Area Coverage) NOAA-18 images on a Globe Display.  Load visible and low-level water vapor images.  Animate the loop on a rotating globe with a solid blue background image. Use the GAC N18 dataset created earlier in this tutorial.

1. Remove All all Layers layers and Data data Sourcessources, create a globe display, and load the data.

a. Remove All all Layers layers and Data data Sourcessources.

b. In the Main Display select File -> New Display Tab -> Globe Display -> One Panel.

c. In the Data Sources tab of the Data Explorer, using the Satellite -> Imagery chooser, select <LOCAL-DATA> for the Server, select GAC for the Dataset, and click Connect.

d. Choose the GAC N18 area files Image Type.  In  and select the Relative tab, enter a value of 8 times of 8 most recent.for Number of times.

e. Select Lat/Lon for the Navigation.

f. Click Add Source to show the Field Selector.

2. Select the 0.63 μm and 12.0 μm bands and display them.

a. Select 0.63 um VIS Cloud and Surface Features -> Brightness.

b. Under Displays click on the Advanced tab.  For Coordinate Type: choose Image Coordinates. Change the Magnification to 1 X 1 with the sliders.  Click on the green arrow icon  next to Image Size to load the full-size image.  For Location: choose Upper Left, and click Create Display.

c. Repeat this process with the 12.0 um IR SFC/Cloud Temp, Low-level WV -> Brightness.





3. Animate the globe and add the background image.  Then analyze and animate the globe display.

a. From the Main Display, select Display -> Add Background Image.  In the Layer Controls for Layer the background image, choose Solid Blue.

b. Start the loop by using the Time Animation buttons at the top of the Main Display.

c. Turn on the Auto-Rotate view option (View -> Viewpoint from the Main Display window, or the Auto-Rotate button  in the Viewpoint Toolbar to the left of the image).

d. Change the orientation of the globe in the Main Display with the mouse controls.  Restart the Auto rotate view.

Problem Set #2 – Solution

Load a HRPT NOAA-18 image.  Display the polar orbit tracks for the image using a two-line element text file with the Polar Orbit Track chooser.  Add an the swath width and antenna circles for the Wallops ground station.

1. Remove All all lLayers and Data data Sourcessources, and display the 19:46:04 UTC NOAA-18 image in a new tab.

a. Remove All all Layers layers and Ddata Ssources.

b. Click the  button in the Main Display to create a new tab.

c. In the Data Sources tab of the Data Explorer, using the Satellite -> Imagery chooser, select <LOCAL-DATA> for the Server, select HRPT for the Dataset, and click Connect.

d. Choose the HRPT N18 area files Image Type

e. Select an Absolute time of 19:46:04 UTC.  

f. Select Lat/Lon for the Navigation.

g. Click Add Source to show the Field Selector.

2. Display the 19:46:00 UTC NOAA-18 image

a. Select 0.63 um VIS Cloud and Surface Features -> Brightness.











b. Under Displays select the Advanced tab.  

· For Coordinate Type: choose Image Coordinates. 

· Change the Magnification to 1 X 1 with the sliders.  

· Click on the green arrow icon  to load the full-size image.  

· For Location: choose Upper Left.

c. Click Create Display. 

d. Reproject the display to the continental United States domain.  In the Main Display, select Projections ‑> Predefined -> US ‑> CONUS.  Zoom into the image to fill the display.

3. Display the polar orbit tracks from a two-line element file.

a. In the Data Sources tab of the Data Explorer, select the Under Development -> Imagery – Polar Satellite Orbit Track chooser.

b. In the Local panel, Uunder Look In, navigate to the <local path>/Data/Polar/ directory and select the noaa18.txt file.

c. Click Add Source to show the Field Selector.

d. Under Displays, select Polar Satellite Orbit Track.

e. Select what data to display in the Time Range tab of the Field Selector.

· Enter Use the calendar button to select Apr 26, 2012 in both Date: fields. 
· Enter 19:40:00 for Begin Time, and enter 20:00:00 for End Time.  Click Create Display.
[bookmark: _GoBack]
f. Navigate to the Layer Controls of the TLE data to modify the display.

· In the Ground Station Controls panel, expand the dropdown menu for Ground Stations Available, select Wallops Island 14 (near the bottom of the list) and click Add Selected.
g. Enter 3000 in Swath Width.
h. Enter 5 in Font Size
i. In Ground Station: click the arrow to show the list of stations.  Choose Wallops14 (near the bottom of the list).


Zooming, Panning, and Rotating Controls

	Zooming
	Panning
	Rotating

		
	Mouse
	

	Shift-Left Drag: Select a region by pressing the Shift key and dragging the left mouse button.
Shift-Right Drag: Hold Shift key and drag the right mouse button. Moving up zooms in, moving down zooms out.
	Control-Right Mouse Drag: Hold Control key and drag right mouse to pan.
	Right Mouse Drag: Drag right mouse to rotate.

	
	Scroll Wheel
	

	Scroll Wheel-Up: Zoom Out.
Scroll Wheel-Down: Zoom In.
	
	Control-Scroll Wheel-Up/Down: Rotate clockwise/counter clockwise.
Shift-Scroll Wheel-Up/Down: Rotate forward/backward clockwise.

	
	Arrow Keys
	

	Shift-Up: Zoom In.
Shift-Down: Zoom Out.
	Control-Up arrow: Pan Down.
Control-Down arrow: Pan Up.
Control-Right arrow: Pan Left.
Control-Left arrow: Pan Right.
	Left/Right arrow: Rotate around vertical axis.
Up/Down arrow: Rotate around horizontal axis.
Shift-Left/Right arrow: Rotate Clockwise/Counterclockwise.
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