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McIDAS-V Tutorial
Displaying Suomi NPPJPSS Data
updatedcreated September 2013August 2018 (software version 1.84)
McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in SSEC's 40-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data.
More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/ .  
If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share information with other users.
This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the document entitled McIDAS-V Tutorial – Installation and Introduction.  
Terminology
There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer).
The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field Selector, displayed in the Main Display, and output is formatted in the Layer Controls.
Menu trees will be listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources).

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).  









Introduction
McIDAS-V has the ability of displaying JPSS (Suomi NPP and NOAA-20) data through the Under Development -> Imagery – JPSS chooser.  Among the JPSS products that McIDAS-V can display are data from the VIIRS (all bands of SVM and SVI, EDRs, Day/Night band), CrIS, and ATMS instruments.  In order for the data to be recognized by McIDAS-V, the geolocation files must be contained within the same directory as the data.  Some sources of data, including NOAA’s CLASS, package the data and geolocation files together by default.  Other sources of JPSS data may store the geolocation in a separate file from the data.  Note that this chooser is still under development and improvements in functionality as well as the ability to utilize different JPSS products will be added in the future.McIDAS-V has the ability of displaying Suomi NPP data through the Under Development -> Imagery -> Suomi NPP chooser.  Among the Suomi NPP products that McIDAS-V can display are different bands of SVM and SVI data, various cloud filter products, and the day/night band.  In order for this data to be recognized by McIDAS-V, the data and geolocation files must be contained within the same directory.  Some sources of data, including NOAA’s CLASS, package the data and geolocation files together, while other sources, including SSEC’s PEATE server, do not package the files together.  Note that this chooser is still under development and improvements in functionality as well as the ability to utilize different NPP products will be added in the future.
This tutorial utilizes PEATE data with separate data and geolocation files, single-banded data from NOAA CLASS, as well as multi-banded visible data from NOAA CLASS.

Installing the VIIRS Formulas Plugin
1. [image: ]This tutorial uses two formulas specifically designed to work with Suomi NPP VIIRS data.  These formulas are not packaged as part of the core group of formulas in McIDAS-V, and must be added via a plugin.  Add this plugin.

a. In the Main Display window, navigate to the Tools -> Plugins -> Manage menu item to open the Plugin Manager. 

b. The top of the Plugin Manager lists plugins currently installed, and the bottom panel lists out various plugins available for installation.  Expand the Miscellaneous tree and click the green Install Plugin button next to VIIRS Formulas. 

c. This pops up a message informing that McIDAS-V must be restarted to complete the installation of the plugin.  Click OK through this message and restart McIDAS-V.

Aggregating Multiple Bands of SVM05 Visible DataDisplay a Single Granule of NOAA-20 Data
In the Main Display Remove All Layers and Data Sources via the Edit -> Remove -> All Layers and Data Sources menu item.

2. Create a new tab with the File -> New Display Tab -> Map Display -> One Tab menu itemLoad a single granule of NOAA-20 SVM03 VIIRS data.

a. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS.

b. Under Files, select the following file:

<local path>/Data/JPSS/NOAA20/VIIRS/SVM03_j01_d20180513_t1814201*

Note that the <local path>/Data/JPSS/NOAA20/VIIRS directory contains nine SVM data granules (three timesteps of three different bands).  There are also three GMTCO* geolocation files (one for each timestep) that are in this directory, but are either not visible or grayed out through this Imagery – JPSS chooser.

c. Click Add Source.

Note that the first time a JPSS granule is added through this chooser, a Plugin Compatibility Notice window may appear letting users of the older version of the VIIRS Formulas plugin know that a new one is available.  In step 1 above the most recent version of this plugin was installed.  Click the Do not show this message again checkbox and click OK.

3. Display Radiance data at low resolution.

a. In the Field Selector tab of the Data Explorer, select the VIIRS-M3-SDR_All/Radiance field, and the Imagery -> Image Display display type.

b. Note that the Region tab in the Field Selector shows a preview image of the selected field.

c. Click Create Display.

d. Investigate the display and note that the resolution of the display is course, not the native 750 meter resolution of the data.  This is because no subsetting of the data was done in the Region tab of the Field Selector.

4. Display Radiance data at the full resolution of the data.

a. From the Region tab of the Field Selector, use Shift+Left-Click+Drag to draw a green box in the data.  Any data contained within this box will be displayed at full resolution.  Note that the entire box must be contained within the granule’s data.

b. Click Create Display.

c. Investigate the display and note that the resolution of the data has improved.  However, note that the bowtie deletion lines still exist on the east and west edges of the granule.

5. Use the swathToGrid formula to display the Radiance data at full resolution with the bowtie deletion lines removed.

a. In the Field Selector tab of the Data Explorer select Formulas.

b. Choose the swathToGrid formula, the Imagery -> Imagery Display display type, and click Create Display.  Note that this formula was added as part of the plugin installed in step 1 above.

c. In the Select input window, enter a value of 750 for resolution in meters and click OK.

d. In the Field Selector window, select the VIIRS* -> Image -> VIIRS-M3-SDR_All/Radiance field.

e. Wait for the Region tab to appear at the bottom of the Field Selector window showing a preview image of the granule and click OK.

f. Investigate the display and notice that the data is now displayed at full resolution with the bowtie deletion lines removed.

g. When you are done investigating the display, remove all layers and data sources.

Create a RGB Display with Aggregated Granules

McIDAS-V has the ability to aggregate several small granules into one large one by selecting multiple time-consecutive granules in the Data Sources tab of the Data Explorer before clicking Add Source.  Multiple bands can also be included in the same data source if the times match up between the bands.
6. Create a data source of three time-consecutive granules of three visible SVM bands.

1. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS.

1. Use Shift+Left-Click to select all of the SVM* data files.

1. Click Add Source.

1. From the Field Selector tab of the Data Explorer, notice that all three bands (SVM03, SVM04, and SVM05) are included in the list in the Fields panel.

7. Use the VIIRS_M_RGB(M5, M4, M3) formula to create a RGB display from the data source.

1. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel menu item.  Close any previously-existing tabs.

1. In the Field Selector tab of the Data Explorer, select Formulas.

1. Choose the VIIRS_M_RGB(M5, M4, M3) formula, the RGB Composite display type, and click Create Display.

1. In the Field Selector window, select the following:

0. Field M5: VIIRS 2018-05-13 18:11:28 GMT -> Image -> VIIRS-M5-SDR_All/Radiance.

Once the Region tab appears, use Shift+Left-Click+Drag to draw a bounding box within the bounds of the data.  This subsetting step only has to be done for this field (the Red component of the formula) since this domain will be carried over to the Green and Blue fields.  Make sure that the subsetted area includes land, water, and data near the east and/or west edges of the granule to include the bowtie deletion regions.

0. Field M4: VIIRS 2018-05-13 18:11:28 GMT -> Image -> VIIRS-M4_SDR_All/Radiance.

0. Field M3: VIIRS 2018-05-13 18:11:28 GMT -> Image -> VIIRS-M3_SDR_All/Radiance.

1. Once all three Region subset tabs are visible, click OK at the bottom of the Field Selector window.

8. Investigate and brighten the display to make it easier to interpret.

1. From the Main Display window, notice that the display looks mainly black and white, though the bowtie deletion lines have been removed and the data is at full (750 meter) resolution.

1. Click on the blue RGB Composite text in the Legend of the Main Display to get to the Layer Controls tab of the Data Explorer.

1. The intensities of the red, green, and blue colors are controlled by their Gamma values.  Adjust all three colors to have a Gamma value of 0.4 by typing 0.4 into the Common Gamma field of the Layer Controls and click Apply to All Gamma Fields.

1. Go back to the Main Display and notice how the red, green, and blue colors are now more intense and you can see green and brown over the land and blue over areas of water.

1. By default, a wireframe box is drawn in the Main Display.  This is the white box going around and partially through the data.  Disable the wireframe box by unselecting View -> Show -> Wireframe Box from the panel in the Main Display window.

1. When you are done investigating the display, remove all layers and data sources.

Note that this formula suggests the user selects SVM05 for Red, SVM04 for Green, and SVM03 for Blue to create a true color RGB display.  However, any bands can be used to create different types of RGB displays.
Using CrIS Data in McIDAS-V
This section utilizes CrIS data from NOAA-20.  The <local path>/Data/JPSS/NOAA20/CrIS directory contains SCRIS data files and GCRSO geolocation files.  Only the SCRIS data files will be listed in the Imagery – JPSS chooser.
9. Create a data source of nine time-consecutive granules of SCRIS data.

1. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS.

1. In the Files panel, navigate to the <local path>/Data/JPSS/NOAA20/CrIS directory.

1. Use Shift+Left-Click to select all of the SCRIS* data files.

1. Click Add Source.

10. Display the data and investigate the display.

1. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel menu item.  Close any previously-existing tabs.

1. In the Fields panel of the Field Selector, verify that the CrIS-SDR_All/ES_RealLW field is selected.

1. In the Displays panel of the Field Selector, select the Imagery -> MultiSpectral Display display type.

1. Click Create Display.

1. This display type creates a grayscale display in the Main Display window along with two data probes (originally stacked on top of each other), as well as a spectra in the Layer Controls.  Move the probes around in the Main Display window by using Left-Click+Drag to place one probe over a cloud and one over cloud-free land.  Compare the spectras in the Layer Controls.

1. From the Layer Controls tab of the Data Explorer, use Left-Click+Drag to move the green selector line to a new wavenumber value.  Notice that the grayscale display in the Main Display window updates itself to reflect the new wavenumber.

1. When you are done investigating the display, remove all layers and data sources.

Using ATMS Data in McIDAS-V
This section utilizes ATMS data from NOAA-20.  The <local path>/Data/JPSS/NOAA20/ATMS directory contains SATMS data files and GATMO geolocation files.  Only the SATMS data files will be listed in the Imagery – JPSS chooser.
11. Create a data source of eight time-consecutive granules of SATMS data.

a. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS.

b. In the Files panel, navigate to the <local path>/Data/JPSS/NOAA20/ATMS directory.

c. Use Shift+Left-Click to select all of the SATMS* data files.

d. Click Add Source.

12. Display the data and investigate the display.

a. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel menu item.  Close any previously-existing tabs.

b. In the Fields panel of the Field Selector, select MultiSpectral -> ATMS-SDR_All/BrightnessTemperature.

c. In the Displays panel of the Field Selector, select the Imagery -> MultiSpectral Display display type.

d. Click Create Display.

e. Investigate the display as done in steps 10e and 10f above.  One difference is this ATMS data uses channel numbers instead of wavenumbers.  Notice how the longer wavelengths make areas with more precipitation stand out over Iowa and the Atlantic Ocean.

Using Day/Night Band Data in McIDAS-V
This section utilizes VIIRS Day/Night band data from Suomi NPP.  This data, ordered from NOAA CLASS, packages the data (SVDNB) and geolocation (GDNBO) into the same file.  Each file includes several small granules aggregated together to cover a relatively large geographical area.
13. Remove all layers and data sources from any previous displays via the Edit -> Remove -> All Layers and Data Sources menu item from the Main Display.

14. Add a new one-paneled map display by selecting File -> New Display Tab -> Map Display -> One Panel menu item.  Close any previously-existing tabs.

15. Create a data source of the two time-consecutive files of GDNBO-SVDNB* files.

a. In the Data Sources tab of the Data Explorer, select Under Development -> Imagery – JPSS.

b. In the Files panel, navigate to the <local path>/Data/JPSS/SuomiNPP directory.

c. Use Shift+Left-Click to select both of the GDNBO-SVDNB* files.

d. Click Add Source.

16. [image: ]Display the data and investigate the display.

a. In the Fields panel of the Field Selector, select IMAGE -> VIIRS-DNB-SDR_All/Radiance.

b. In the Displays panel of the Field Selector, select the Imagery -> Image Display display type.

c. In the Region tab of the Field Selector, use Shift+Left-Click+Drag to draw a green bounding contained entirely within the data over the eastern United States extending into the Atlantic (similar to this image).  Any data in this bounding box will be displayed at the full resolution of the data.

d. Click Create Display.

17. Investigate the display.

a. In the Main Display window, you will likely notice that no data is visible.  This is due to the enhancement range values being set based on the minimum and maximum values contained in the data.  Adjust the enhancement by Right-Clicking on the enhancement in the Legend and choosing Change Range….

b. In the Change Range window, enter From and To values that better match up with the radiance values contained in the display.  For example, you can use values of:

From: 8.8E-10
To: 1.9E-8

c. This is near full-moon scene, which allows for a display similar to a daytime visible image to be viewed.  Other features, such as city lights and ships can be viewed in this scene.  The range set in step 17b can be expanded or contracted on either end to make different features easier to see. 


Problem Sets
The previous examples were intended to give you a general knowledge of how to load and display JPSS data.  The problem sets below are intended to introduce you to new topics related to the data, as well as challenge your knowledge of McIDAS-V.  We recommend that you attempt to complete each problem set before looking at the solutions, which are provided below the problem set.

Note that this example utilizes Suomi NPP data from NOAA CLASS.  The files contain both the data and geolocation in the same file.  Also, several small granules are aggregated together into one file, so a relatively large geographic domain is covered by a single file.

1. Using the <local path>/Data/JPSS/SuomiNPP/GMODO-SVM03-SVM04-SVM05* file, create an RGB image using the Reflectance field of all three bands.  Create the display by using the VIIRS_M_RGB(M5,M4,M3) formula.  Display the data at full-resolution and make sure to include a large portion of the granule in your subsetted region.  Adjust the Common Gamma field in the Layer Controls to make the individual colors stand out more in the display.

1. Looking at the display over the Great Lakes, it is difficult to discern between clouds and snow over the land. Using the file loaded from question 1, display SVM14 brightness temperature data with the swathToGrid formula over the Great Lakes region.  Adjust the enhancement to make the clouds display as white instead of black.  Overlay this display on the RGB image created in problem 1. This longwave infrared band is useful to distinguish between clouds and snow. 

1. Looking at the RGB display over Louisiana, smoke can be observed.  Using the file loaded from question 1, display SVM13 brightness temperature data with the swathToGrid formula over Louisiana.  Overlay this display on the RGB image created in problem 1.  This medium-wave infrared band is useful to detect fire activity.

1. Determine the smoke concentration from the Louisiana fire using the <local path>/Data/JPSS/SuomiNPP /GMTCO-VSUMO* VIIRS suspended matter EDR data.  Overlay this display on the RGB image created in problem 1.


Problem Set #1 – Solution
Using the <local path>/Data/JPSS/SuomiNPP/GMODO-SVM03-SVM04-SVM05* file, create an RGB image using the Reflectance field of all three bands.  Create the display by using the VIIRS_M_RGB(M5,M4,M3) formula.  Display the data at full-resolution and make sure to include a large portion of the granule in your subsetted region.  Adjust the Common Gamma field in the Layer Controls to make the individual colors stand out more in the display.
1. Remove all layers and data sources from the previous displays.

1. Select File -> New Display Tab -> Map Display -> One Panel to create a new one-panel map display tab.

1. Load in a granule containing three bands of VIIRS SVM visible data (SVM03, SVM04 and SVM05).

2. In the Data Sources tab of the Data Explorer, select Under Development > Imagery – Suomi NPP

2. Select <local path>/Data/JPSS/SuomiNPP/GMODO-SVM03-SVM04-SVM05_npp*	
(Note: this file packages the geolocation (GMODO) and the data (SVM*) together into the same file.)

2. Click the Add Source button.

1. Use the VIIRS formula to create a true-color RGB image with the bowtie effect removed.

3. In the Field Selector tab, under Data Sources select Formulas.

3. Under Fields, select the VIIRS_M_RGB(M5,M4,M3) formula.  Click Create Display.

3.  In the new Field Selector window, select: 

1. [image: ]For Field: M5, select VIIRS -> IMAGE -> VIIRS-M5-SDR_All/Reflectance 
1. For Field: M4, select VIIRS -> IMAGE -> VIIRS-M4-SDR_All/Reflectance
1. For Field: M3, select VIIRS -> IMAGE -> VIIRS-M3-SDR_All/Reflectance

3. In the Region tab of Field: M5, use Shift+Left-Click+Drag to select a region to display at full-resolution.  Select a region that contains most of the granule, as shown in the image above.  It is not necessary to subset a region in for M4 and M3, as the region selected for M5 will be used for all fields.

3. Click OK to display the results of the VIIRS_M_RGB(M5,M4,M3) formula.

1. Adjust the display to enhance the Red, Green, and Blue components of the display.

4. Navigate to the Layer Controls tab of the Data Explorer.  By default, all Gamma values for all colors are set to 1.0.  Change this value to 0.4 by entering in 0.4 in the Common Gamma field and clicking the Apply to All Gamma Fields button.

4. Return to the Main Display window to observe the RGB display and also notice that the bowtie effect has been removed by the formula.
Problem Set #2 – Solution
[image: ]Looking at the display over the Great Lakes, it is difficult to discern between clouds and snow over the land. Using the file loaded from question 1, display SVM14 brightness temperature data with the swathToGrid formula over the Great Lakes region.  Adjust the enhancement to make the clouds display as white instead of black.  Overlay this display on the RGB image created in problem 1. This longwave infrared band is useful to distinguish between clouds and snow.
1. Use the swathToGrid formula to create a full-resolution display of the data without the bowtie effect.

0. In the Field Selector tab, under Data Sources select Formulas.

0. Under Fields, select the swathToGrid formula.  Under Displays, select Imagery > Image Display.  Click Create Display. 

0. In the new Select input window, enter 750 for res and 1.0 for mode.  Click OK.

0. In the Field Selector, select VIIRS* -> IMAGE -> VIIRS-M14-SDR_All/BrightnessTemperature.

0. In the Region tab, use Shift+Left-Click+Drag to select a region over the Great Lakes (as seen in the image on the right) to display at full-resolution.

0. Click OK to display the result of the swathToGrid formula.

1. Adjust the display to make the clouds over the Great Lakes appear as white instead of black and investigate the display.

1. Change the colorbar to Inverse Gray Scale.  To do this, Right-Click on the colorbar in the Legend and select System -> Inverse Gray Scale.  This is done to make the lower data values (colder temperatures, such as clouds) display as white, while warmer temperatures are darker.

1. Use the visibility checkbox in the Legend to toggle the SVM14 layer on and off to compare with the RGB display underneath.  The temperature difference between clouds and snow in this infrared band allows the clouds to stand out more than they do in the visible bands used in the RGB display.
Problem Set #3 – Solution
[image: ]Looking at the RGB display over Louisiana, smoke can be observed.  Using the file loaded from question 1, display SVM13 brightness temperature data with the swathToGrid formula over Louisiana.  Overlay this display on the RGB image created in problem 1.  This medium-wave infrared band is useful to detect fire activity.
1. Use the swathToGrid formula to create a full-resolution display of the data without the bowtie deletion.

0. In the Field Selector tab, select Formulas under Data Sources. 

0. Under Fields, select the swathToGrid formula.  Under Displays, select Imagery -> Image Display.  Click Create Display.

0. In the new Select input window, enter 750 for res and 1.0 for mode.  Click OK.

0. In the Field Selector window, select VIIRS* -> IMAGE -> VIIRS-M13-SDR_All/BrightnessTemperature.

In the Region tab, use Shift+Left-Click+Drag to select a region over Louisiana to display at full-resolution.  Click OK to display the result of the swathToGrid formula.

1. Use the visibility checkbox in the Legend to toggle the SVM13 layer on and off to compare with the RGB display underneath.

Problem Set #4 – Solution
Determine the smoke concentration from the Louisiana fire using the <local path>/Data/JPSS/SuomiNPP /GMTCO-VSUMO* VIIRS suspended matter EDR data.  Overlay this display on the RGB image created in problem 1.

1. In the Data Sources tab of the Data Explorer, navigate to the Under Development -> Imagery -> Suomi NPP chooser.

0. Under Files, select the following file:
<local path>/Data/JPSS/SuomiNPP/GMTCO-VSUMO*

0. Click the Add Source button.

1. Display the smoke concentration from the EDR data.

1. In the Fields panel of the Field Selector, select:
Image -> VIIRS-SusMat-EDR_/All/SmokeConcentration field.

1. Select Imagery -> Image Display in the Displays panel of the Field Selector.

1. In the Region tab of the Field Selector, use Shift+Left-Click+Drag to subset a region over Louisiana.  Anything within this subsetted region will display at the full resolution of the data.

1. Click Create Display.

1. Investigate the smoke concentration from the Louisiana fire.

2. In the Legend of the Main Display, toggle off the visibilities of the SVM13 and SVM14 data so only the RGB and the VIIRS EDR data is displayed.

2. Navigate over the fire in Louisiana and toggle the VIIRS EDR layer on and off with the visibility checkbox in the Legend.




11. 
12. Load in the three time-consecutive granules of SVM05 data.

a. In the Data Sources tab of the Data Explorer, navigate to the Under Development -> Imagery - Suomi NPP chooser.

b. Under Files, use Shift+Click to select the following three files:

<local path>/Data/NPP/SVM05/SVM05_npp_d20130820_t1841270_e1842511_b*
<local path>/Data/NPP/SVM05/SVM05_npp_d20130820_t1842524_e1844165_b*
<local path>/Data/NPP/SVM05/SVM05_npp_d20130820_t1844178_e1845419_b*

Note that the <local path>/ Data/NPP/SVM05 directory includes three GMTCO* files (one for each SVM05* file).  These GMTCO* files contain the geolocation data necessary for McIDAS-V to plot the SVM05 data.  These GMTCO* files cannot be selected in the Data Sources tab of the Data Explorer, only the SVM05 files can be chosen.

c. Click Add Source.  Adding these three files at once will aggregate the data together, combining the three individual granules into a single image.




13. Select the field to display, the display type, and display the data at full-resolution.

a. In the Fields panel of the Field Selector, expand the IMAGE dropdown to view the fields included with the data.  Select the VIIRS-M5-SDR_All/Reflectance field.

b. [image: ]In the Displays panel, select Imagery -> Image Display.

c. The Region panel gives a preview image of the display.  By default, McIDAS-V will display the data at a reduced resolution to save on memory usage.  To display the data at full-resolution, an area within the data must be subsetted by using Shift+Left-Click+Drag.  Anything contained with the green bounding box will be displayed at full-resolution.  Subset out a large area of the data.  Note that the entire region must be contained within the granule’s data. 

d. Click Create Display.

14. Inspect the display of the SVM05 reflectance data.

15. Zoom in on the region of interest in the Main Display by using Shift+Left-Click+Drag to choose an area containing the data (the southeastern United States).  The display region can be further customized by zooming in/out with the scroll wheel on the mouse and the display can be translated using Control+Right-Click+Drag.

16. Probe the data by holding down the middle mouse button over the display.  Probe output will be shown below the Main Display window.  Compare the output between the convective cloud tops over the Florida panhandle with cloud-free regions.

17. Observe the bowtie deletion effect on the eastern and western edges of the granule.  This is shown by black stripes of missing data going through the image. In Problem Set #1 below, a plugin will be installed that will introduce two formulas to remove these stripes of missing data.
18. 
19. Displaying Day/Night Band Data
20. Remove All Layers and Data Sources from the previous displays via the Edit -> Remove ->All Layers and Data Sources menu item in the Main Display. 

21. Create a new tab via the File -> New Display Tab -> Map Display -> One Panel menu item.



22. Load in the Suomi NPP Day/Night band granule.

a. In the Data Sources tab of the Data Explorer, navigate to the Under Development -> Imagery - Suomi NPP chooser.

b. 
Under Files, select the following file:

<local path>/ Data/NPP/DayNightBand/GNDBO-SVDNB_npp_d20121013*

Note that this file packages the geolocation (GNDBO) and the data (SVDNB) together into the same file.  Therefore, only this one file is included in <local path>/ Data/NPP/DayNightBand/.

c. Click the Add Source button.

23. Select the field to display, the display type, and display the data at full-resolution.

a. In the Fields panel of the Field Selector, expand the IMAGE dropdown to view the fields included with the data.  Select the VIIRS-DNB-SDR_ALL/Radiance field.

b. In the Displays panel, select Imagery -> Image Display.

c. In the Region panel, subset out a region in the bottom half of the data granule by using Shift+Left Click+Drag.  Anything contained with the green bounding box will be displayed at full-resolution.  Note that the entire region must be contained within the granule’s data.

d. Click Create Display.


24. Adjust the display to make the aurora borealis visible.

a. Zoom in on the region of interest in the Main Display by using Shift+Left-Click+Drag to choose an area containing the data (Alaska extending into Canada).  The display region can be further customized by zooming in/out with the scroll wheel on the mouse and the display can be translated using Control+Right-Click+Drag.

25. Adjust the colorbar range to make the data visible by Right-Clicking on the colorbar in the Legend of the Main Display and selecting Change Range.  In the Change Range window, set From to 1E-9 and set To to 3E-8.  Click OK.

26. 

Problem Sets
The previous examples were intended to give you a general knowledge of how to load and display Suomi NPP data.  The problem sets below are intended to introduce you to new topics related to the data, as well as challenge your knowledge of McIDAS-V.  We recommend that you attempt to complete each problem set before looking at the solutions, which are provided below the problem set.
4. Using the <local path>/ Data/NPP/SandyRGB/GMODO* file, create an RGB image using the Reflectance field of all three bands.  Create the display by using the VIIRS_M_RGB(M5,M4,M3) formula that will be available once you install the VIIRS Formulas plugin.  Display the data at full-resolution and make sure to include clouds as well as cloud-free land and water areas in your subsetted region.  Adjust the Common Gamma field in the Layer Controls to make the individual colors stand out more in the display.

5. Aggregate the SVM12* files contained in <local path>/ Data/NPP/Fire/SVM12* together to create a display of Brightness Temperature to investigate fire activity over Idaho.  Use the swathToGrid formula to remove the bowtie.  Display the data over Idaho at full-resolution.  Once the display is created, change the colorbar to Inverse Gray Scale, and use the Color Table Editor to make the hot spots stand out better.  Add a breakpoint at 300, color it yellow, and color the high-end breakpoint red.  Interpolate the colors between these two breakpoints.  Save the colorbar so it can be used in the future.  

6. Overlay the results of Problem Set #2 with the VIIRS-CM-IP_All/QF2_Fire_Detected field contained in the <local path>/ Data/NPP/Fire/GMODO* cloud mask file to verify that the cloud mask field’s display matches the SVM12 brightness temperature display.

7. 

Problem Set #1 – Solution
[image: ]Using the <local path>/ Data/NPP/SandyRGB/GMODO* file, create an RGB image using the Reflectance field of all three bands.  Create the display by using the VIIRS_M_RGB(M5,M4,M3) formula that will be available once you install the VIIRS Formulas plugin.  Display the data at full-resolution and make sure to include clouds as well as cloud-free land and water areas in your subsetted region.  Adjust the Common Gamma field in the Layer Controls to make the individual colors stand out more in the display. 

In the Main Display window, navigate to the Tools 
-> Plugins -> Manage menu item to open the Plugin Manager.

The top of the Plugin Manager lists plugins currently installed, and the bottom panel lists out various plugins packaged with McIDAS-V.  Expand the Miscellaneous tree and click the green Install Plugin button next to VIIRS Formulas. 

This pops up a message informing that McIDAS-V must be restarted to complete the installation of the plugin.  Click OK through this message and restart McIDAS-V.

Once McIDAS-V has restarted, navigate to the Field Selector tab of the Data Explorer and two new formulas will be listed: VIIRS_M_RGB(M5,M4,M3) and swathToGrid.  These formulas were added from the VIIRS Formulas plugin.

5. Load in a multi-banded VIIRS SVM granule.  This data file contains three bands of SVM visible data (SVM03, SVM04 and SVM05).

a. In the Data Sources tab of the Data Explorer, navigate to the Under Development > Imagery – Suomi NPP chooser.

b. Under Files, select the following file:
c. 
<local path>/ Data/NPP/SandyRGB/GMODO-SVM03-SVM04-SVM-5_npp*
d. 

Note that this file packages the geolocation (GMODO) and the data (SVM*) together into the same file.  Therefore, only this one file is included in <local path>/ Data/NPP/SandyRGB/.

e. Click the Add Source button.

6. Use the VIIRS_M_RGB(M5,M4,M3) formula to create a true-colored RGB display of this data and remove the bowtie deletion.

a. In the Field Selector tab, under Data Sources select Formulas.

b. Under Fields, select the VIIRS_M_RGB(M5,M4,M3) formula.  Click Create Display.

c.  In the new Field Selector window, select:

· For Field: M5, select VIIRS -> IMAGE -> VIIRS-M5-SDR_All/Reflectance 
· For Field: M4, select VIIRS -> IMAGE -> VIIRS-M4-SDR_All/Reflectance
[image: ]For Field: M3, select VIIRS -> IMAGE -> VIIRS-M3-SDR_All/Reflectance

d. In the Region tab of Field: M5, use Shift+Left-Click+Drag to select a region to display at full-resolution.  Select a region that contains clouds, as well as cloud-free areas.  It is not necessary to subset a region in for M4 and M3, as the region selected for M5 will be used for all fields.

e. Click OK to display the results of the VIIRS_M_RGB(M5,M4,M3) formula.

7. Adjust the display to make the Red, Green, and Blue components of the display stand out.

a. Navigate to the Layer Controls tab of the Data Explorer.  By default, all Gamma values for all colors are set to 1.0.  Change this value to 0.4 by entering in 0.4 in the Common Gamma field and clicking the Apply to All Gamma Fields button.

b. Return to the Main Display window to observe the RGB display of Hurricane Sandy and also notice that the bowtie effect has been removed by the formula.

Problem Set #2 – Solution
Aggregate the SVM12* files contained in <local path>/ Data/NPP/Fire/SVM12* together to create a display of Brightness Temperature to investigate fire activity over Idaho.  Use the swathToGrid formula to remove the bowtie.  Display the data over Idaho at full-resolution.  Once the display is created, change the colorbar to Inverse Gray Scale, and use the Color Table Editor to make the hot spots stand out better.  Add a breakpoint at 300, color it yellow, and color the high-end breakpoint red.  Interpolate the colors between these two breakpoints.  Save the colorbar so it can be used in the future.  Load in the three VIIRS SVM12 granules.
Remove All Layers and Data Sources from the previous displays.

2. In the Data Sources tab of the Data Explorer, navigate to the Under Development -> Imagery -> Suomi NPP chooser.

a. Under Files, use Shift+Click to select the following three files:

<local path>/ Data/NPP/Fire/SVM12_npp_d20130811_t1011478_e1013120_b*
<local path>/ Data/NPP/Fire/SVM12_npp_d20130811_t1013132_e1014374_b*
<local path>/ Data/NPP/Fire/SVM12_npp_d20130811_t1014386_e1016028_b*

Note that the <local path>/ Data/NPP/Fire directory includes three GMTCO* files (one for each SVM12* file).  These GMTCO* files contain the geolocation data necessary for McIDAS-V to plot the SVM12 data.  These GMTCO* files cannot be selected in the Data Sources tab of the Data Explorer, only the SVM12 files can be chosen.

b. Click the Add Source button.  Adding these three files at once will aggregate the data together, combining the three individual granules into a single image.

3. Use the swathToGrid formula to create a full-resolution display of the data without the bowtie deletion.

a. In the Field Selector tab, under Data Sources select Formulas.

b. Under Fields, select the swathToGrid formula.

c. Under Displays, select Imagery > Image Display.  Click Create Display.

d. In the new Select input window, enter 750 for res and 1.0 for mode.  Click OK.

e. In the Field Selector, select VIIRS* -> IMAGE -> VIIRS-M12-SDR_All/BrightnessTemperature.

f. In the Region tab, use Shift+Left Click+Drag to select a region over Idaho to display at full-resolution.

g. Click OK to display the result of the swathToGrid formula.

4. Adjust the display to make the fires over Idaho easier to see.

a. Change the colorbar to Inverse Gray Scale.  To do this, Right-Click on the colorbar in the Legend and select System -> Inverse Gray Scale.  This is done to make the lower data values (colder temperatures, such as clouds) display as white, while warmer temperatures are black.

Add a color enhancement to the upper end of the colorbar to make the highest temperatures stand out.  To do this, Right-Click on the colorbar in the Legend and select Edit Color Table.

In the Color Table Editor window, Right-Click on the colorbar and select Add Breakpoint -> At Data Point.  In the Breakpoint Value window, enter in a value of 300 and click OK.

[image: ]Change the color of the 300 breakpoint to yellow.  To do this, using the HSB tab, move the slider to yellow.  In the color panel within the HSB tab, Left-Click+Drag to select a bright yellow color.  This will change the 300 breakpoint to yellow.

Change the color for the upper end of the colorbar to red.  To do this, select the breakpoint on the right side of the colorbar to make this breakpoint active.  This breakpoint is denoted by an upside-down triangle.  Once this breakpoint is active, a yellow outline will be drawn around the breakpoint’s triangle.  Use the method in step d above to select a red color.

Interpolate between the breakpoints by Right-Clicking on the upper breakpoint and selecting Edit Colors -> Interpolate -> Left.

Save the colorbar to be used in the future by selecting File -> Save As.  Enter in a name of Fire and click OK.  This colorbar will now be available to use in the future by Right-Clicking on a colorbar in the Legend of the Main Display and selecting System -> Fire.  Note that this System comes from the Category dropdown menu in the Color Table Editor.  This value can be changed by the user.

Return to the display in the Main Display window to view the fires over Idaho.  Notice that the hotspots are now colored yellow, orange and red.  Probe the data to investigate the difference in brightness temperature between the fires and cloud-free land.

b. 

Problem Set #3 – Solution
Overlay the results of Problem Set #2 with the VIIRS-CM-IP_All/QF2_Fire_Detected field contained in the <local path>/ Data/NPP/Fire/GMODO* cloud mask file to verify that the cloud mask field’s display matches the SVM12 brightness temperature display.
2. In the Data Sources tab of the Data Explorer, navigate to the Under Development -> Imagery -> Suomi NPP chooser.

a. Under Files, use Shift+Click to select the following file:

<local path>/ Data/NPP/Fire/GMODO-IICMO_npp_d20130811_t1008587_ e*

Note that the <local path>/ Data/NPP/Fire directory includes one GMODO-IICMO file.  Note that this file packages the geolocation (GMODO) and the data (IICMO*) together into the same file.  

b. Click the Add Source button.

3. Use the swathToGrid formula to create a full-resolution display of the data without the bowtie deletion.

a. In the Field Selector tab, select Formulas under Data Sources.

b. Under Fields, select the swathToGrid formula.

c. Under Displays, select Imagery -> Image Display.

d. Click Create Display.

e. In the new Select input window, enter 750 for res and 1.0 for mode.  Click OK.

f. In the Field Selector window, select VIIRS* -> IMAGE -> VIIRS-CM-IP_All/QF2_Fire_Detected.

g. In the Region tab, use Shift+Left Click+Drag to select a region over Idaho to display at full-resolution.



In the Main Display, toggle the visibility of the cloud mask field on and off by clicking the visible checkbox in the Legend.  There should be white pixels from the cloud mask field that overlap with the higher SVM12 brightness temperatures.





The following table lists out band, wavelength and resolution information for VIIRS SVM, DNB (Day/Night Band) and SVI data.  Source: http://rammb.cira.colostate.edu/projects/npp/

[image: ]



Zooming, Panning, and Rotating Controls

	Zooming
	Panning
	Rotating

	
	Mouse
	

	Shift-Left Drag: Select a region by pressing the Shift key and dragging the left mouse button.
Shift-Right Drag: Hold Shift key and drag the right mouse button. Moving up zooms in, moving down zooms out.
	Control-Right Mouse Drag: Hold Control key and drag right mouse to pan.
	Right Mouse Drag: Drag right mouse to rotate.

	
	Scroll Wheel
	

	Scroll Wheel-Up: Zoom Out.
Scroll Wheel-Down: Zoom In.
	
	Control-Scroll Wheel-Up/Down: Rotate clockwise/counter clockwise.
Shift-Scroll Wheel-Up/Down: Rotate forward/backward clockwise.

	
	Arrow Keys
	

	Shift-Up: Zoom In.
Shift-Down: Zoom Out.
	Control-Up arrow: Pan Down.
Control-Down arrow: Pan Up.
Control-Right arrow: Pan Left.
Control-Left arrow: Pan Right.
	Left/Right arrow: Rotate around vertical axis.
Up/Down arrow: Rotate around horizontal axis.
Shift-Left/Right arrow: Rotate Clockwise/Counterclockwise.
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