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McIDAS-V Tutorial

Using and Creating Formulas
updated October 2010 (software version 1.0)

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in SSEC's 35-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data.

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/ .  If you encounter any errors, please send them to the McIDAS Help Desk at mug@ssec.wisc.edu .
This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the document entitled McIDAS-V Tutorial – Installation and Introduction.  
There are 3 methods of using formulas in McIDAS-V

System Formulas

User defined formulas

User defined formulas with jython code

System Formulas – Simple Subtraction
1. Load the forecast data for Super Typhoon Megi.

a. In the Data Sources tab in the Data Explorer window for McIDAS-V, open the Gridded Data tree and select Local

b. Under Look in, individually add data sources for the following files:
/advanced-training/forecast_data/gfs_4_20101017_0000_000.grb2
/advanced-training/forecast_data/gfs_4_20101017_0000_024.grb2

c. Select the Field Selector tab and then under the Data Sources select Formulas

d. Under Fields, open the Miscellaneous tree and select Simple Difference (a-b)

e. Under Displays, open the Imagery tree and select Image Display

f. Click Create Display
2. Using the new Field Selector window 

a. For field a, open the gfs_4_20101017_0000_024.grb2 -> 2D -> Mass and select Pressure_reduced_to_MSL @ msl

b. For field b, open the gfs_4_20101017_0000_000.grb2 -> 2D -> Mass and select Pressure_reduced_to_MSL @ msl

c. Click Ok

d. Zoom into the Phillipeans area. The darker region southeast of the whiter region shows areas where pressure drops are forecasted.  Drawing a line between the whiter and darker regions gives an indication of the predicted storm motion.

System Formulas – Combining Multiple Formulas

3. Remove All Layers


4. Add the rest of the forecast hours for 20101017_0000 and the corresponding verification files:


a. In the Data Sources tab in the Data Explorer window for McIDAS-V, open the Gridded Data tree and select Local

b. Under Look in, individually add a data source for the following files:
/advanced-training/forecast_data/gfs_4_20101017_0000_006.grb2
/advanced-training/forecast_data/gfs_4_20101017_0000_012.grb2


/advanced-training/forecast_data/gfs_4_20101017_0000_018.grb2

/advanced-training/forecast_data/gfs_4_20101017_0000_024.grb2

/advanced-training/forecast_data/gfs_4_20101017_0000_030.grb2


/advanced-training/forecast_data/gfs_4_20101017_0000_036.grb2


/advanced-training/forecast_data/gfs_4_20101017_0600_000.grb2


/advanced-training/forecast_data/gfs_4_20101017_1200_000.grb2


/advanced-training/forecast_data/gfs_4_20101017_1800_000.grb2


/advanced-training/forecast_data/gfs_4_20101018_0000_000.grb2


/advanced-training/forecast_data/gfs_4_20101018_0600_000.grb2


/advanced-training/forecast_data/gfs_4_20101018_1200_000.grb2

5. Select the Field Selector tab and then under the Data Sources select Formulas


a. Under Fields, open the Miscellaneous tree and select Any Field

b. Under Displays, open the 3D Surface tree and select Topography

c. Click Create Display

d. Using the new Field Selector window, open Formulas ->Miscellaneous -> Simple Difference

e. Click Ok
f. For field a, open the gfs_4_20101017_0000_006.grb2 -> 3D -> Mass and select Geopotential_height @ pressure
g. Click the Level tab and select 10000 Pa


h. For field b, open the gfs_4_20101017_0600_000.grb2 -> 3D -> Mass and select Geopotential_height @ pressure


i. Click the Level tab and select 10000 Pa


j. Click Ok

k. Repeat steps a-i for the following pairs of datasets
/advanced-training/forecast_data/gfs_4_20101017_0000_012.grb2 /advanced-training/forecast_data/gfs_4_20101017_1200_000.grb2

/advanced-training/forecast_data/gfs_4_20101017_0000_018.grb2 /advanced-training/forecast_data/gfs_4_20101017_1800_000.grb2

/advanced-training/forecast_data/gfs_4_20101017_0000_024.grb2 /advanced-training/forecast_data/gfs_4_20101018_0000_000.grb2

/advanced-training/forecast_data/gfs_4_20101017_0000_030.grb2 /advanced-training/forecast_data/gfs_4_20101018_0600_000.grb2

/advanced-training/forecast_data/gfs_4_20101017_0000_036.grb2 /advanced-training/forecast_data/gfs_4_20101018_1200_000.grb2

6. Import color enhancement for model verification.
a. In the Main Menu Bar in the Main Display window of McIDAS-V, select Tools -> Color Tables
b. Select File -> Import.

c. Select File Types -> McIDAS-X color table (*.et)

d. Select the following file /advanced-training/enhancement/MODEL_VERIFICATION.ET
e. Click Open
f. In the Category text box enter Training <Enter>
g. Select File -> Save As
h. In the Color table name text box enter Model Verification
i. Click Ok 

j. Click Close
7. Apply color enhancement and change range for layers.

a. From the Legend in the Main Menu Bar in the Main Display window of McIDAS-V, right click on the color bar of one of the layers and select Change Range

b. In the From: text box enter -200, in the To: text box enter 200
c. Click Ok 
d. Again right click on color bar, this time select Training -> Model Verification
e. Repeat steps a-d for each layer
8. Change the vertical range  
a. From the tool icons on the left side of the Main Display window click the vertical range icon:
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b. Change the Min Value to -100, Max Value to 100 and Units to m

c. Click Okay
9. Move the Map layers up so they are visible on the 3D animation.


a. From the Legend in the Data Explorer window of McIDAS-V, select the Layer Controls 

b. Click Default Background Maps

c. Select the Settings Tab

d. Slide the Map Position value to .3.
10. Animate the layers.
a. From the Legend in the Main Menu Bar in the Main Display window of McIDAS-V, click View -> Displays -> Visibility Animation -> check box On

11. Display Water Vapor Sea Surface Temperature data, similar to that created by the McIDAS-X IMGRGB command.


12. Remove All Layers and Datasets

13. Create three local datasets for global SST, land/sea mask and water vapor images

a. From the Main Menu Bar in the Main Display window of McIDAS-V, click Tools -> Manage ADDE Datasets

b. Select File -> New Local Dataset


c. In the Dataset text box enter GLOBAL


d. In the Image Type text box enter SST


e. Click the Browse button and choose:
/advanced-training/sea-surface-temperature

f. Click Open

g. Click Add New Dataset

h. Select File -> New Local Dataset


i. In the Dataset text box enter GLOBAL


j. In the Image Type text box enter WV


k. Click the Browse button and choose:
/advanced-training/global-wv

l. Click Open

m. Click Add New Dataset

14. Load a Big Blue Marble basemap using the flat file chooser

a. From the Data Source tab of the Data Explorer window, open the General tree and select Flat Files.

b. Select /advanced-training/basemap/blue-marble.jpg for the file to load.


c. For Navigation, select Bounds


d.  Enter 90 for upper lat, -180 for upper lon, -90 for lower lat and 180 for lower lon


e. Click Add Source


15. Create a display of the Big Blue Marble basemap


a. From the Field Selector, click Create Display

16. Create a Sea Surface Temperature data source


a. From the Data Source tab of the Data Explorer window open the Satellite tree and select Imagery

b. Set the value for the Server drop down box to Local-Data 

c. Set the value for the Dataset drop down box to Global


d. Click Connect

e. Set the value for the Image Type drop down box to SST

f. Select the Absolute tab

g. High light the 2010-10-20 00:00:00Z image 


h. Click Add Source
17. Create a Land/Sea Mask data source


a. From the Data Source tab of the Data Explorer window open the Satellite tree and select Imagery

b. Set the value for the Server drop down box to Local-Data 

c. Set the value for the Dataset drop down box to Global


d. Click Connect

e. Set the value for the Image Type drop down box to Land-Sea-Mask

f. Select the Absolute tab

g. High light the 2009-07-30 18:00:00Z image 


h. Click Add Source

18. Create a display of Sea Surface Temperatures over just water areas


a. From Data Sources under the Field Selector tab, select Formulas
b. Open the Image Filters (Beta) tree and select Discriminate Image Filter
c. Click Create Display


d. From the Select Input window, enter the following:
brkpoint1: 0
brkpoint2: 255
brkpoint3: 8
brkpoint4: 8
replace: 0

Break points 1 and 2 specifies the range from the first datast to be used and break points 3 and 4 are for the second dataset.  In this example values of 8 are used from the land/sea mask and represent water regions.

e. Click OK


f. Using image1 from the new Field Selector window, open the SST tree -> open the Band 1 tree -> select Brightness


g. Select the Advanced Tab -> click the full size icon:
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Also make sure the other fields are filled in as seen above.

h. Using image2 from the new Field Selector window, open the Land-Sea-Mask tree -> open the Band 1 tree -> select Brightness


i. Repeat step g for image2

j. Click OK

19. Import color enhancement for Sea Surface Temperatures
a. In the Main Menu Bar in the Main Display window of McIDAS-V, select Tools -> Color Tables
b. Select File -> Import.

c. Select File Types -> McIDAS-X color table (*.et)

d. Select the following file /advanced-training/enhancement/SST-WVSST.ET
e. Click Open
f. In the Category text box enter Training <Enter>
g. Select File -> Save As

h. In the Color table name text box enter Sea Surface Temperature - WV
i. Click Ok 

j. Click Close

20. Add transparencey to the Sea Surface Temperature – WV color enhancement

a. From the Legend in the Main Menu Bar in the Main Display window of McIDAS-V, right click on the color bar of the SST Image Display select Edit Color Table

b. Right click above the color bar, select Add Breakpoint -> At Data Point
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c. Enter a value of 2 and click OK

d. From the Transparency drop down box, select a value of 100%

e. Right click on the breakpoint you just created, select Edit Colors -> Transparency -> Left
This sets the transparency to 100% for all brightness values less than 2.
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f. Click OK

21. Create a Water Vapor data source


a. From the Data Source tab of the Data Explorer window open the Satellite tree and select Imagery

b. Set the value for the Server drop down box to Local-Data 

c. Set the value for the Dataset drop down box to Global


d. Click Connect

e. Set the value for the Image Type drop down box to WV

f. Select the Absolute tab

g. High light the 2009-10-18 00:00:00Z image 


h. Click Add Source

22. Create a Water Vapor display


a. From the Field Selector tab of the Data Explorer window open the 6.8 um tree and select Brightness

b. Click Create Display

23. Add Transparency to the Water Vapor Imagery.  Use the same techniques as found in step 20.


a. Create a breakpoint for at 135, set the transparency to 100% and fill to the left

b. Create another breakpoint at 220 and set the transparency to 0%. Now interpolate the transparency to the left:
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Creating your own Formulas – Simple Example
24. Create two local datasets for global infrared and water vapor images

a. From the Main Menu Bar in the Main Display window of McIDAS-V, click Tools -> Manage ADDE Datasets

b. Select File -> New Local Dataset

c. In the Dataset text box enter GLOBAL


d. In the Image Type text box enter IR


e. Click the Browse button and choose:
/advanced-training/global-ir

f. Click Open

g. Click Add New Dataset

25. From the Legend in the Main Menu Bar in the Main Display window of McIDAS-V, click Tools -> Formulas -> Create Formulas
a. In the Name text box enter:
Global Convective Diagonstic - Using Water Vapor and Long Wave Infrared Brightness temperatures
This value will be shown when you mouse over the formula

b. In the Formula text box enter:
WaterVaporTemperature – InfraredTemperature
Give your variables meaningful names, these will show up in the Field Selector.


c. In the Description text box enter:
GCD
This value will be seen in the list of formulas

d. In the Group text box enter:
Training <Enter>
You can create a tree structure of multiple groups – each of which can contain multiple formulas.

26. Add Water Vapor and Infrared datasets to use with formula

a. Remove all Layers and Datasets

b. From the Data Source tab of the Data Explorer window open the Satellite tree and select Imagery

c. Set the value for the Server drop down box to Local-Data 

d. Set the value for the Dataset drop down box to Global


e. Click Connect

f. Set the value for the Image Type drop down box to WV

g. Select the Absolute tab

h. High light the 2009-10-18 00:00:00Z image 

i. Click Add Source

j. From the Data Source tab of the Data Explorer window open the Satellite tree and select Imagery

k. Set the value for the Server drop down box to Local-Data 

l. Set the value for the Dataset drop down box to Global


m. Click Connect

n. Set the value for the Image Type drop down box to IR

o. Select the Absolute tab

p. High light the 2009-10-18 00:00:00Z image 


q. Click Add Source
27. Apply the formula to images

a. Select the Field Selector tab and then under the Data Sources select Formulas

b. Under Fields, open the Training tree and select GCD

28. Using the new Field Selector window 

a. For WaterVaporTemperature field, open the WV tree -> 6.8 um tree and select Temperature 


b. Select the Advanced Tab -> click the full size icon:
[image: image6.jpg][—
Line Mg | ) gttt

Ble wagli | D) Reset.0





Also make sure the other fields are filled in as seen above.

c. From the region tab, select a small region around southern Africa.

d. For InfraredTemperature field, open the IR tree -> 10.7 um tree and select Temperature 

e. Click OK


Creating your own Formulas – Advanced Example

29. Load the Wind Chill bundle.

30. From the Legend in the Main Menu Bar in the Main Display window of McIDAS-V, click File -> Open File 

a. Make sure the File Types is set to All McIDAS-V Bundles (*.mcv, *.mcvz) 


b. Select the following file: /advanced-training/bundles/wind-chill.mcv

c. Click Open

In the 1940’s the National Weather Service in the United States created a wind chill index.  The index identified when exposed skin would be susceptible to frost bite after 15 minutes. A combination of wind speed and temperature is used to create the index.  In 2001, the index was updated and now uses the following chart.
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d. The mathematical equation as seen above can be converted to a formula in McIDAS-V.  The equation has specific units (Farenheit for temperature and miles/hour for wind speed), so the formula must convert the units before the evaluating the index.  To see the McIDAS-V formula, select the Field Selector tab from the Data Explorer Window

e. From fields, select Point Data

f. Open up Layout Model and select Wind Chill

g. Reopen Layout Model and select Edit

h. Right-click on the parameter below the wind barb and select Properties.  In the Parameter field you’ll find the following equation:

=format(35.74 + .6125*(TEMP).getValue(makeUnit("degF")) - 35.75*((SPD).getValue(makeUnit("mi/h"))**(.16)) + .4275*(TEMP).getValue(makeUnit( "degF"))*((SPD).getValue(makeUnit("mi/h"))**(.16)))

Right now you must specify the formula for point data using the Layout Model Editor.  In the future, we hope that you can select from a global list of formulas.
Jython User Library
def myAlgorithm(source1, source2):


"""


   myAlgorithm - Create an algorithm to apply to 2 source datasets


   Input Parameters




source1 - first dataset specified in GUI




source2 - second dataset specified in GUI


"""


"""


   Create an object for the output array by copying from the first source


"""


destinationDataset = source1.clone()




"""


   This loop steps through times in the dataset - again times are defined through the GUI


   The variable Time is not actual value of time (i.e., 14:45) rather and index into the list


   of times.


"""


for time in range(source1.getDomainSet().getLength()):

  



"""



   Get the domain size (lines and elements) of source1, these values will be used when looping



   through the data



"""



source1Sample = source1.getSample(time)



domain = GridUtil.getSpatialDomain(source1Sample)



[elementSize,lineSize] = domain.getLengths()



"""



   Define Output Array



"""



destinationSample = destinationDataset.getSample(time)



destinationArray = destinationSample.getFloats(0)
   



"""



   This is the loop for reading/writing and displaying the data



"""



for line in range(lineSize):




for element in range(elementSize):





"""





   Set a variable to point to the location in the array to start reading data





"""





arrayOffset = line*elementSize+element





"""





   source1Object is a one dimensional array containing a list of all lines of data





"""





source1Value = readData(source1,time,arrayOffset)





source2Value = readData(source2,time,arrayOffset)





"""





   Call your ALGORITHM here





"""





if (source1Value <= 230.0):






outputValue = (source1Value - source2Value)





else:






outputValue = 330.0





"""






Write the value to the Output Object





"""





destinationArray[0][arrayOffset] = outputValue
  




destinationSample.setSamples(destinationArray)





return destinationDataset

def readData(source, time, offset):


"""


   readData




This is very basic function for reading in 1 dataset for a specified




location within the dataset and returns the value at that location


   Input Paramters




source - Source Dataset




time - Time of Dataset




offset - Offset into array


   Output Parameters




sourceValue - Value returned at specified location


"""


"""


   Get a sample of the data for the specified time


"""


sourceSample = source.getSample(time)


"""


   Get an array of floats from the sample


"""


sourceArray = sourceSample.getFloats(0)


"""



Grab the source value from the location at the offset specified


"""


sourceValue = sourceArray[0][offset]


return sourceValue

Background Jython Scripting


The following is a list of jython functions written to make it easier for users to write background scripts.  They are higher level functions that combine the efforts of lower level idv and visad function:

import ucar.unidata.util.Range

from java.lang import System

from ucar.unidata.ui.colortable import ColorTableDefaults

class _JavaProxy(object):

    """One sentence description goes here.

    This is where a more complete description of the class would go.

    Attributes:

        attr_one: Blurb about attr_one goes here.

        foo: Blurb about foo.

    """

    def __init__(self, javaObject):

        """Stores a given java instance and flags the proxy as being initialized."""

        self.__javaObject = javaObject

        self.__initialized = True

    def getJavaInstance(self):

        """Returns the actual VisAD/IDV/McIDAS-V object being proxied."""

        return self.__javaObject

    def __getattr__(self, attr):

        """Forwards object attribute lookups to the internal VisAD/IDV/McIDAS-V object."""

        if not self.__dict__.has_key('_JavaProxy__initialized'):

                raise AttributeError(attr)

        else:

            if hasattr(self.__javaObject, attr):

                return getattr(self.__javaObject, attr)

            else:

                raise AttributeError(attr)

    def __setattr__(self, attr, val):

        """Forwards object attribute changes to the internal VisAD/IDV/McIDAS-V object."""

        if not self.__dict__.has_key('_JavaProxy__initialized'):

            self.__dict__[attr] = val

            return

        if hasattr(self.__javaObject, attr):

            setattr(self.__javaObject, attr, val)

        else:

            self.__dict__[attr] = val

class _ColorTable(_JavaProxy):

    def __init__(self, javaObject):

        """Creates a proxy for ucar.unidata.util.ColorTable objects."""

        _JavaProxy.__init__(self, javaObject)

class _Display(_JavaProxy):

    def __init__(self, javaObject):

        """ """

        _JavaProxy.__init__(self, javaObject)

    def center(self, latitude, longitude, scale=1.0):

        """ """

        earthLocation = Util.makeEarthLocation(latitude, longitude)

        mapDisplay = self.__javaObj.getMapDisplay()

        # no idea what the problem is here...

        mapDisplay.centerAndZoom(earthLocation, False, scale)

        mapDisplay.centerAndZoom(earthLocation, False, scale)

        mapDisplay.centerAndZoom(earthLocation, False, scale)

    def getLayer(self, index):

        """Returns the layer at the given index (zero-based!) for this Display"""

        return _Layer(self.__javaObj.getControls()[index])

    def getLayers(self):

        """Returns a list of all layers used by this Display."""

        return [_Layer(displayControl) for displayControl in self.__javaObj.getControls()]

class _Layer(_JavaProxy):

    def __init__(self, javaObj):

        """Creates a proxy for ucar.unidata.idv.DisplayControl objects."""

        _JavaProxy.__init__(self, javaObject)

class _Projection(_JavaProxy):

    def __init__(self, javaObject):

        """Creates a proxy for ucar.unidata.geoloc.Projection objects."""

        _JavaProxy.__init__(self, javaObject)

def setViewSize(width, height):

    """Set the view size to a given width and height.

    Longer description goes here.

    Args:

        width:

        height:

    """

    idv.getStateManager().setViewSize(java.awt.Dimension(width, height))

def getColorTable(name=ColorTableDefaults.NAME_DEFAULT):

    """Return the ColorTable associated with the given name.

    Longer description goes here.

    Args:

        name: The name of the desired ColorTable. If no name was given, the

              name of the IDV's default ColorTable will be used.

    Returns:

        The first ColorTable with a matching name.

    Raises:

        LookupError: If there was no ColorTable with the given name.

    """

    colorTable = idv.getColorTableManager().getColorTable(name)

    if colorTable:

        return _ColorTable(colorTable)

    else:

        raise LookupError("Couldn't find a ColorTable named ", name, "; try calling 'colorTableNames()' to get the available ColorTa

bles.")

def colorTableNames():

    """Returns a list of the valid color table names."""

    return [colorTable.getName() for colorTable in idv.getColorTableManager().getColorTables()]

def allColorTables():

    """Returns a list of the available color tables."""

    return [_ColorTable(colorTable) for colorTable in idv.getColorTableManager().getColorTables()]

def firstDisplay():

    """Returns the first display

    Longer description goes here.

    Returns:

        The first Display (aka ViewManager).

    Raises:

        IndexError: If there are no Displays.

    """

    return _Display(idv.getVMManager().getViewManagers().get(0))

def allDisplays():

    """Returns a list of all McIDAS-V displays (aka ViewManagers)"""

    return [_Display(viewManager) for viewManager in idv.getVMManager().getViewManagers()]

def createLayer(layerType, data, dataParameter='Data'):

    """Creates a new Layer in the active Display.

    Args:

        layerType: ID string that represents a type of layer. The valid names

                   can be determined with the "allLayerTypes()" function.

        data: Data object to associate with the resulting layer.

        dataParameter: Optional...

    Returns:

        The Layer that was created in the active display.

    """

    # TODO(jon): this should behave better if createDisplay fails for some reason.

    return _Layer(createDisplay(layerType, data, dataParameter))

def allLayerTypes():

    """Returns a list of the available layer type names"""

    return idv.getAllControlDescriptors()

def allProjections():

    """Returns a list of the available projections."""

    return [_Projection(projection) for projection in idv.getIdvProjectionManager().getProjections()]

def projectionNames():

    """Returns a list of the available projection names"""

    return [projection.getName() for projection in idv.getIdvProjectionManager().getProjections()]

def getProjection(name=''):

    """Returns the projection associated with the given name.

    Longer description here.

    Args:

        name: Name of the desired projection.

    Returns:

        The first projection whose name matches the given name. If the given

        name is empty (or None), McIDAS-V's default projection is returned.

        (does that make sense!?)

    Raises:

        LookupError: If there was no Project with the given name.

    """

    if not name:

        return _Projection(idv.getIdvProjectionManager().getDefaultProjection())

    for projection in idv.getIdvProjectionManager().getProjections():

        if name == projection.getName():

            return _Projection(projection)

    else:

        raise LookupError("Couldn't find a projection named ", name, "; try calling 'projectionNames()' to get the available project

ion names.")

def load_enhancement(name=''):

    """Coming Soon - Under Development."""

    pass

def load_map(name=''):

    """Coming Soon - Under Development."""

    pass

def annotate(text=''):

    """Coming Soon - Under Development."""

    pass

def apply_colorbar(name=''):

    """Coming Soon - Under Development."""

    pass

def write_image(path=''):

    """Coming Soon - Under Development."""

    pass

def collect_garbage():

    """Signals to Java that it should free any memory that isn't in use."""

    System.gc()
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