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McIDAS-V Tutorial

Using HYDRA to Interrogate Hyperspectral Data

updated May 2012 (software version 1.2)
McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in SSEC's 35-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data.
More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. You will be notified at the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/ .  

If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/

 HYPERLINK "http://dcdbs.ssec.wisc.edu/mcidasv/forums/" . The forums also provide the opportunity to share information with other users.

This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start McIDAS-V.  If you can not start McIDAS-V on your machine, you should follow the instructions in the document entitled McIDAS-V Tutorial – Installation and Introduction.  

Terminology
There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer).
The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field Selector, displayed in the Main Display, and output is formatted in the Layer Controls.
Menu trees will be listed as a series (e.g. Edit ->Remove ->All Layers and Data Sources).

Mouse clicks will be listed as combinations (e.g. Shift+Left Click+Drag).  
Create a Multispectral Display (AIRS Hyperspectral Data)
1. In the Main Display remove all layers and data sources:  Select Edit ->Remove ->All Layers and Data Sources.
2. Display the data from the <local path>/Hydra/AIRS.2010.03.20.045.L1B.AIRS_RAD.v5.0.0.0.G10081101210.hdf file (59 MB).  This AIRS file is dated March 20, 2010 at 4:29 UTC.   

a. In left panel of Data Explorer, open the Satellite->HYDRA chooser.

b. Navigate to the <local path>/Hydra/AIRS.2010.03.20.045.L1B.AIRS_RAD.v5.0.0.0.G10081101210.hdf file.  Click Add Source.

c. The file loads into the Field Selector with the name of Hydra.  To make the name more descriptive, edit the properties of the data source.  
· Under Data Sources, right click on Hydra.  

· Select Properties.  

· Change Name from Hydra to AIRS 2010/03/20 4:29 UTC.
· Click OK.

d. Under Displays, select MultiSpectral Display.  Click Create Display.

3. The MultiSpectral image displays in the Main Display (Figure 1).  There are four aspects to the MultiSpectral display: 
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1) The image in the Main Display.  

2) The main spectrum probe in the Main Display is the magenta square (Figure 1).

3) The reference spectrum probe in the Main Display is the light blue square.  
(NOTE:  The two spectrum probes may overlap, with only the magenta square visible.  
Left click+drag either box to view spectra measured in various pixels of image.)
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The spectra of the MultiSpectral layer in the Layer Controls.  The default wavenumber is 919.50 cm-1 (10.8 µm).   From the Main Display, click Multi Spectral in the Legend to view spectra for the AIRS file.  

4. Add an image description to the Main Display.
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a. In the Layer Controls, select Edit->Properties.
b. In Layer Label (Figure 2):  Remove %displayname%.  Type %datasourcename%.  The macro %datasourcename% is linked to description entered in step 3c.

c. If  “Show in Layer List” box is not checked, click to activate this option.

d. [image: image11.png]8006 MCIDAS-V - Data Explorer

Data Sources Field Selector Layer Controls

e@untitied>panel 1| File Edit View Help

Default Background Maps. Display-| Settings _Histogram
MultSpectral »

&OTT



Click OK.  The customized label appears in the Main Display.
5. Compare clear vs. cloudy spectra by moving the spectrum probes (Figure 3). 
  
a. In the Main Display, Shift+Left Click+Drag to zoom the satellite image.

b. Place one probe over a thunderstorm cloud top and one over a dark cloud-free pixel.  

c. View spectra in the Layer Controls (Figure 4).  (When in the Main Display, click on MultiSpectral in the Legend to bring Layer Controls to the front.)

d. Zoom into interesting spectral regions Shift+Left Click+Drag.  Control+Left Click returns the full spectra.

e. Choose different wave numbers by dragging the green selector bar or by entering a Wavenumber below the spectra.
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Create a MultiSpectral Display (MODIS data)
1. Remove all layers and data sources from the previous displays.
2. Display the data from the <local path>/Hydra/MOD021KM.A2010079.0250.2010265200125.hdf file (154 MB). 
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In the left panel of the Data Explorer, choose Satellite 
->HYDRA, navigate to the MODIS file and click Add Source.
b. Change data source name to MODIS 2010/03/20 at 250 UTC.  (Use method outlined above in step 2c on page 2.)
c. Under Fields expand the MultiSpectral drop down list and select Emissive_Bands.  
d. Under Displays select MultiSpectral Display.
e. [image: image17.png]B HydraCombo,

[r—

Compute New Fi




Click Create Display.

An 11.0 µm image over Eastern China from 250 UTC on March 20, 2010 is displayed (Figure 5).


3. Change the band displayed in the Main Display.  


a. Left click MultiSpectral in Legend to bring Layer Controls to front.  


b. Change band with either Left Click+Drag option to move the green selector bar or select the Band from the drop-down list at the bottom of the Display tab of the Layer Controls (Figure 6).



Create a Scatter Analysis of two bands
1. Make a scatter analysis (plot) of two bands (Figures 7 and 8).

a. In Data Explorer, click Field Selector.  
(If the Data Explorer is not visible:  Select Window -> Show Data Explorer from the Main Display.)


b. Select Emissive_Bands field.  This will be the x-axis in this scatter analysis.  Under Displays, select Scatter Analysis. 


c. Select Channels tab in lower right panel.  Select Band 31 (11.0µm). (Macintosh: There are no tabs, use band drop down list at bottom of Display panel.  Figure 8.)  Click Create Display.


d. A second Field Selector will appear for selection of the y-axis data field.  In this new Field Selector, select Reflective_Bands, and then Band 1 (0.65 µm)  in the Channels tab.  Click OK.

	[image: image1.png]& Data Explorer,

0 Data Sources

| rotsoncr

Data Sources:
Formulas
» Hyira

Fields.

% MuliSpectral
Emissive_Bands
Reflective_Bands

7 Imagery
Image Display
Image Display Over Topography
MultiSpeciral Display
Linear Cambinations

catter Analysis|

Region || channals

Create Display





	[image: image2.png]Field: select ¥ Axis field
Formulas
Hydra
MultiSpectral
Emissive_Bands
Reflective_Bands

Region |/ channels

oK cancel







[image: image3.png]800

MCIDAS-V - Data Explorer

Data Sources
Formulas
» Hydra

Data Sources | _) Field Selector | ) Layer Controls |
Fields @ Displays
Multispectral Imagery
Image Display
Reflective_Bands Image Display Over Topography

JMutispectral Display

Linear Combinations

Image Contours
Scatter Analysis
4 Channel Combinations

Macintosh Slide Bar ——

Band: [ 31

(" Create Display )

[






2. The scatter analysis will display in the Layer Controls (Figure 9).

· The left image is the first selected field.

· The middle image is the second selected field. 
· The right plot is the two-field scatter analysis. The x-component (abscissa values) corresponds to the first field selected and the y-component (ordinate values) corresponds to the second field selected. (In this example, band 31 (11 µm) versus band 1 (0.65 µm)).
3. Analyze the scatter plot and images by highlighting a box or region in any of three panels. 
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a. To draw a box, click the Box  radio button and select one of the colors.  Use Shift+Left click+drag option to draw box over a region of the scatter plot.  The corresponding points are highlighted in the image. 
b. Conversely, select a region of interest in one of the images.   The corresponding points are highlighted in the scatter plot.  
c. To draw a shape, click the Curve radio button.  Use Left click+drag option to draw an enclosed shape. 
d. To remove a color from the scatter plot, double left click in that color’s selection box.

4. Click compute statistics.   A window with the scatter plot statistics will appear.  Also, there is an option to save the statistics as a CSV file.
Problem Sets
The previous examples provide general instructions for loading and displaying multi and hyperspectral data.  The problem sets below introduce new topics related to the data, and challenges to extend concepts covered in the lessons.  Attempt completion of each problem set before checking the solutions.  Solutions are provided below the problem set.
1. Create a Normalized Difference Vegetation Index (NDVI) where NDVI = [Band 2 (0.86µm) – Band 1 (0.65 µm)]/[ Band 2 (0.86 µm) + Band 1 (0.65 µm)] using the MODIS file. 

2. Scatter the Band 31 vs (Band 29 – Band 31).  Make channel 31 the x-axis.  Then, scatter 

     Band 31 vs. (Band 31 – Band 32).  Compare the two.

3. Make an online-offline difference of AIRS data.

Problem Set #1 - Solution
1. Remove all Layers.

2. Create the 4 Channel Combination.  In the Field Selector, 

· Under Fields, select Reflective Bands from the MultiSpectral list.
· Under Displays, select 4 Channel Combinations.
· Click Create Display.

3. Create NDVI equation (Figure 10).

a. Select Band 2 in red drop down menu (Note the red selector moves to 0.86µm).

b. To right of red drop down menu, select the minus (-) operator from drop-down list.

c. Select Band 1 in green drop down menu.


d. To right of green drop down menu, select the divide (/) operator from drop-down list.

e. Select Band 2 in blue drop down menu.

f. To right of blue drop down menu, select the plus (+) operator from drop-down list.

g. Select Band 1 in the magenta channel box.

h. Click Compute New Field to create a new NDVI.

4. Display the NDVI image and add an NDVI color enhancement.


a. In the Field Selector, the NDVI equation appears under the Fields MultiSpectral drop down as “(((1.0*a) – (1.0*b))/((1.0*c) + (1.0*d))).”  Click on the NDVI field equation and select Image Display from Displays.

b. Click Create Display.  

c. Add an NDVI color enhancement.  In the Main Display, Right click the grayscale Color Bar in the Legend.  Choose  Satellite -> GOES -> NDVI.
Problem Set #2 – Solution
1. Remove all layers.


2. Create the 4 Channel Combination.  In the Field Selector, 


a. Under Fields, select Emissive Bands from the MultiSpectral list.

b. Under Displays, select 4 Channel Combinations.


c. Click Create Display.

3. Create the “Band 29 – Band 31” difference image.

a. Select Band 29 in red channel box.


b. To the right of the red drop down menu, select the minus (-) operator from the drop-down list.

c. Select Band 31 in the green channel box.

d. Click Compute New Field.

4. Repeat step 3 to create the “Band 31 – Band 32” difference image.


5. Return to Field Selector to create the Scatter Analysis.

a. Under Fields, select Emissive Bands.

b. Under Displays, select Scatter Analysis. 

c. Click Create Display.  (The default emissive band is band 31.  This will be the x-axis).

d. A Second Field Selector  appears for the y-axis, data selection.   Select the “Band 29 – Band 31” difference image (This is the first “((1.0*a) – (1.0*b)) image in the MultiSpectral drop down list). 

e. Click OK.

f. The Scatter Display will display in the Layer Controls (Figure 11).
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Figure 11:  Band 31 vs. (Band 29 - Band 31) scatter analysis.
6. Repeat step 5 to create a scatter analysis display using band 31 as the x-axis and “Band 31 – Band 32” as the y-axis (Figure 12).  “Band 31 – Band 32” will be the second “((1.0*a) – (1.0*b)) image in the MultiSpectral drop down list.
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Figure 12:  Band 31 vs. (Band 31 – Band 32) scatter analysis.
7. Compare the scatter displays:  

a. Undock each display:  In Layer Controls for each Scatter Display, select View -> Undock from Data Explorer.  

b. Arrange the Scatter Displays vertically.  

c. Use the scatter analysis tools to draw boxes and curves on the images and scatter plot.
Problem Set #3 - Solution
1. Remove all layers and data sources, and load the AIRS data file.  
2. Return to the Field Selector and select 4 Channel Combinations under Displays and click Create Display.  
3. Enter in the equation 746.01 (red) – 746.97 (green) and hit Enter after each number (Figure 13).  The vertical red and green lines in the spectrum will move to 746.01 cm-1 and 746.97 cm-1, respectively.  The red band is the online value and the green band is the offline value.
4. Zoom in over the region by using the Shift+Left Click+Drag option. Reset the spectrum by Control +Left Click. 


5. Click Compute New Field to create a new field of this online - offline difference.  

6. The resulting field will be “((1.0*a) – (1.0*b))” in the Field Selector under the MultiSpectral field in the Fields list (Figure 14).  Click on this new field and select Image Display under Displays and click Create Display.

 


The resulting image from the online-offline calculation shows the vertical temperature gradient – in cloudy regions (darker), the difference is small because both the online and offline wave numbers detect clouds.  In clear regions (lighter), the difference between the two wave numbers is larger, because of the temperature gradient through the atmosphere (Figure 15).
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Short Summary of Hydra Controls in McIDAS-V
Spectra

Select spectra - write wavenumber in box, select channel from pulldown menu, or middle button click

Shift+Left click+Drag –  (Zoom) Select portion of spectra for magnification. 
Control+Left click – Return to full spectrum
Right Click + Drag – Move spectrum right or left 
Middle mouse button (or wheel) click –  Read Brightness Temperatures and Wavenumbers. Provides Brightness Temperature value and Wavenumber at cursor location. It will also move the green line and change the image to that wavenumber.

Image

Left Click on a probe and drag – Change probe location (The spectra will display for new location) 

Change band – use spectra window, write wavenumber in box, or middle button click

Move image up or down – use arrow icons in left utility bar
Zoom – Shift+Right Click+Roll over window –or- mouse scroll wheel forward or backward

Return to Original Image View – Click on house icon in left utility bar

Figure 1:  McIDAS-V Main Display





Figure 2:  MultiSpectral Properties used to change and apply layer label





Figure 4:  Spectra of clear versus cloudy pixels.





Figure 3:  Magnify image and move spectrum probes.





Figure 5:  MODIS 11 µm image





Figure 6:  Use Layer Controls to change band displayed in Main Display.





Figure 7:  Field Selector windows for Scatter Analysis ( UNIX/Windows).





Figure 8:  Field Selector windows for Scatter Analysis (Macintosh uses slide bar).





Figure 9:  Scatter analysis of two bands.





Figure 10:  Channel Combination Tool for NDVI.





Figure 13:  Channel Combination Tool for online – offline calculation.





Figure 14:  Field Selector for online – offline calculation.





Figure 15:  Main Display for online – offline calculation.
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