
McIDAS-V Tutorial 
Displaying Satellite Imagery 

updated August 2009 (software version 1.0beta4) 
 

 

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation 
in SSEC's 35-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 
(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 
manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and 
Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands 
and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being 
integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data. 
 
McIDAS-V is currently a beta version of the software, which means that the software may contain bugs and not 
always work as expected.  If you encounter any errors, please send them to the McIDAS Help Desk at 
mug@ssec.wisc.edu .  You will be notified at the startup of McIDAS-V when new versions are available on the 
McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/ .  More training materials are available 
on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-V User’s Guide, which is 
available from the Help menu within McIDAS-V.  
 
This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 
McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the 
document entitled McIDAS-V Tutorial – Installation and Introduction.   
 
In this McIDAS-V Tutorial, each exercise will be explained using two different methods of data access:  pre-
loaded data bundles and real-time access to default remote servers.  If you have access to your own real-time 
ADDE servers, you may also use those, but be aware that different server configurations may make the 
explanations in this document not quite applicable to all data that you may load.  
 
Note:  Users of data from the SSEC Data Center can use the "Import from URL" feature of the ADDE Server 
Manager and automatically include all of the SSEC Data Center servers in the McIDAS-V server lists.  From 
the main menu, select Edit -> Preferences -> ADDE Servers -> Import From URL and enter the URL 
(http://www.ssec.wisc.edu/mcidas/software/v/addeservers.xml), your User ID, and Project #.   
 
 

mailto:mug@ssec.wisc.edu
http://www.ssec.wisc.edu/mcidas/software/v/addeservers.xml
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Loading Geostationary Satellite Images and Loops 
 
1. Load the single times data bundle for the second tutorial into McIDAS-V. If you want to load real-time data, 

skip to step 2. 
 

a. In the Main Menu Bar in the Main Display window of McIDAS-V, select File -> Open File... 
 
b. In the file brower, “Look In” the location where you downloaded the data files for this tutorial, select  

Sat-Single-Times.mcvz and click Open. 
 

c. In the “Open Bundle” dialog box select the Replace session option and click OK. 
 

d. Under “Confirm Layer/Data Removal” uncheck the Always Ask box and click Remove all layers/data.  
 

e. Select Write to temporary directory, check Don’t show this again, and click OK. 
 
2. To load real-time data, follow these steps.  If you have already loaded the data in step one, proceed to step 

3. 

a. Click on the  button in the main toolbar to go to the Data Explorer.   
 
b. Select the Satellite -> Imagery chooser from the Data Sources tab.  

 
c. If you’re using the default servers in McIDAS-V, you can connect to the adde.ucar.edu server with the 

dataset RTIMAGES.   
 

d. Choose the GE-VIS - GOES-East 0.65 µm Visible  Image Type and select an absolute time of 17:45 
UTC from the previous day.  (This step may be slow, because when choosing absolute times, McIDAS-
V needs to query the ADDE server for all available times.)   

 
i. If your real-time server contains data with the original satellite resolution, you may need to change 

the Image size to 2000 X 2000 and the Magnification to -2 X -4.  
 

e. Click Add Source to show the Field Selector. 
 
f. Click Create Display.  The 17:45 UTC 0.65 μm image is displayed in the Map Display window. 

 
3. Use the zooming and panning controls in the left toolbar to inspect the image.   
 

a. Reset the display projection by clicking on the  icon below the zooming buttons on the left toolbar. 
 
b. Turn off the Auto-set Projection option under the Projections menu.  When this option is checked, the 

projection will automatically change to the native projection of the new layer.  When this option is 
unchecked, all new layers will be reprojected into the current projection.   

 
4. Edit the maps in the display by using the options in the Layer Controls tab.   
 

a. Click on Default Background Maps in the Legend to go to the Layer Controls tab.  The map controls 
will have two tabs.  The first Maps tab lists the available maps, and the second Settings tab allows the 
user to control latitude and longitude lines, as well as the Z level of the maps in the 3D display.   
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b. In the Maps tab, you can remove a map, change its visibility, line width, style and color.  Use these 

options to create your own map display.   
 

c. If you choose, also add latitude and longitude lines in the Settings tab.   
 

d. To save a map configuration as the default, in the Layer Controls tab select File -> Default Maps -> 
Save as the Default Map Set.  The next time you open a new tab, window, or start McIDAS-V, the 
defaults will reflect what you selected.   

 
5. Add the second image from the single times data bundle to the display.  To load real-time data skip to step 

6. 
 

a. Return to the Field Selector and click on the GE-IR – GOES-East 10.7 µm under the Data Sources list 
on the left hand side and click Create Display. 

 
6. If you are using real-time data, follow the steps below. 
 

a. Go to the Data Sources tab and select the GE-IR – GOES-East 10.7 µm IR Image Type and select an 
absolute time of 17:45 UTC from the previous day. 

 
i. If your real-time server contains data with the original satellite resolution, you may need to change 

the Image size to 2000 X 2000 and the Magnification to -2 X -4. 
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b. Change the Data Type to Temperature and click Add Source.  Click Create Display. 
 
7. The 10.7 temperature image is overlaid on top of the visible image.  To see the visible image, turn off the 

GE-IR – GOES-East 10.7 µm checkbox in the Legend.  Turn the image back on and click and drag the 
middle mouse button to activate the Cursor/Data Readout option.  This option brings up a latitude, 
longitude, and data value readout in the upper left part of the display on a mouse drag.  Since there are two 
layers in the main display, there are two different readouts with the appropriate values and units (if 
applicable). 

 
8. Remove the satellite image layers from the display and load the four panel bundle.  To load real-time data 

skip to step 9. 
 

a. Select Edit -> Remove -> All Layers and Data Sources. 
 
b. Load Sat-Four-Panel.mcvz to display the GOES-12 3.9 μm brightness loop. 

 
i. In the “Open Bundle” dialog box select the Add new tab(s) to current window option and click OK. 

 
9. If you are using real-time data, follow the steps below. 
 

a. Select Edit -> Remove -> All Layers and Data Sources. 
 
b. Open a new 4 panel tab by selecting File->New Display Tab->Map Display->Four Panels from the 

main menu. 
 

i. By default, the last panel created will be the active panel.  The lower right panel will be highlighted 
with a default color of blue.  Click on the top left panel to activate this panel for the next data load. 

 
ii. Double click on the “2 untitled” tab name and enter “GOES 4-panel” in the entry box and click OK 

to change the tab name. 
 
c. Go to the Data Sources tab and select the GOES-East 0.65 μm Image Type in the satellite image 

chooser.  In the Relative Times tab, select the 5 most recent images.  Change the Image size to 900 X 
1800 and the Magnification to 1 X 1, add the data source, and create the display. 

 
i. A warning message may pop up about the amount of data you will be loading; click OK.   

 
d. Click on the top right panel to make it the active tab.  Repeat step 9c using GOES-East 3.9 µm in the top 

right panel, GOES-East 6.5 µm in the bottom left panel, and GOES-East 10.7 µm in the bottom right 
panel. 

 
10.   Because the four tabs all have shared views, using the animation controls and zooming and panning in one 

panel will make the corresponding changes in the other panels. 
 

a. In one of the panels, animate the image loop and zoom in on an interesting weather feature.   The other 
panels should also begin looping and zoom in on the same geographical location.   
 

b. You may remove one of the panels from updating with the other panels by selecting Projections -> 
Share Views in that panels Projections menu. 
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11. Another feature for real-time data is data polling which allows the data and display to be updated when a 
new image exists.  To turn this on, go to the Field Selector tab and right click on the GOES-East 0.65 µm 
data source and select Properties.   
 
a. Under Polling click on the Automatically Reload:  Active checkbox.   

 
b. Click on the Reload Displays checkbox at the bottom of the window.   

 
c. Click Apply and OK.  Every 10 minutes (the default polling time) a check will be made for a new 

image and if one exists, the satellite loop will be automatically updated in your display. 
 

d. Repeat this step for the remaining three datasets. 
 
Loading Polar Orbiting Satellite Images and Loops 
 
1. Remove the GOES 4-panel tab in the McIDAS-V main display by clicking on the “x” in the right corner of 

the tab. 
 

2. When loading loops of polar orbiting satellite images, it is recommended that either the Auto-set 
Projection option be turned off and a global projection be used in the map display, or the images be 
displayed on the globe display to ensure all images are able to be viewed. 

 
a. Check the Projections menu to see that the Auto-set Projection option is not checked. 
 
b. Change your projection to Projections -> Predefined  -> North America. 

 
3. Remove all layers and data sources. 
 
4. Display a loop of 10 polar orbiting images by loading the polar orbiting loop bundle.  If you are using real-

time data, skip to step 5. 
 

a. Load Sat-Polar-Loop.mcvz and select Replace Session to display the loop of all 10 images.   
 
b. Use the zooming, rotating, and panning controls to zoom in on the images. 

 
5. If you are using real-time data, follow the steps below. 
 

a. Load the 10 most recent MODIS L1B 1 km 3.97 μm images by their Line/Element with an Image size of 
1000 X 1000 and Magnification of 1 X 1. 
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Problem Sets 
 
The previous examples were intended to give you a general knowledge of how to load and display satellite 
data.  The problem sets below are intended to introduce you to new topics related to the data, as well as 
challenge your knowledge of McIDAS-V.  We recommend that you attempt to complete each problem set 
before looking at the solutions, which are provided below the problem set. 
 

1. Load the 5 most recent GOES-West 10.7 µm IR Temperature images and change the enhancement to 
Basic -> Inverse Grayscale.  Change the range to enhance the colder clouds, create a color 
enhancement that has values from 190 to 273 interpolated between blue and green, and values greater 
than 273 transparent, and save the loop as an animated gif.  You may use bundle Sat-Problem-
Enhancement.mcvz or real-time data to load the images. 

 
2. Create a Parameter default for temperature images so all GOES Temperature images use the same 

enhancement and range as in Problem 1. Then, load several different bands of temperature (10.7 µm, 3.9 
µm, etc.) and loop through the different bands.  You may use bundles Sat-Problem-Default.mcvz and 
Sat-Problem-Default-Images.mcvz or real-time data to load the images. 

 
3. Display a GOES-East 10.7 µm brightness image and overlay a MODIS Level 1b 1km 11.0 µm 

brightness image.  Load a data transect for each image and sync them together.  You may use bundles 
Sat-Problem-GOES.mcvz and Sat-Problem-MODIS.mcvz or real-time data to load the images. 

 
 
Problem Set #1 – Solution 
 
Load the 5 most recent GOES-West 10.7 µm IR Temperature images and change the enhancement to Basic -> 
Inverse Gray shade.  Change the range to enhance the colder clouds, create a color enhancement that has 
values from 190 to 273 interpolated between blue and green, and save the loop as an animated gif.  You may 
use bundle Sat-Problem-Enhancement.mcvz or real-time data to load the images. 
 
1. The following instructions are the solution to Problem 1 from above.  If you are using real-time data, skip to 

step 2. 
 
a. Use the File -> Open File... to load bundle Sat-Problem-Enhancement.mcvz into McIDAS-V. 

 
i. In the “Open Bundle” dialog box select the Replace session option and click OK. 

 
b. Load the loop of 5 images by clicking Create Display. 

 
2. If you are using real-time data, follow the steps below. 

a. Return to the Data Explorer by clicking on the  button in the main toolbar. 
 
b. Connect to the server adde.ucar.edu with the dataset RTIMAGES. 

 
c. Choose the GW-IR – GOES-West 10.7 µm IR Image Type and select the 5 most recent times. 

 
d. Select a Channel of 10.7 µm IR Surface/Cloud-top Temp and a Data Type of Temperature. 

 



Page 7 of 13 

McIDAS-V Tutorial – Displaying Satellite Imagery                                                             August 2009 – McIDAS-V version 1.0beta4 

e. Click Add Source to show the Field Selector. 
 

f. Click Create Display. 
 
3. In the Legend, right-click on the GW-IR – GOES-West 10.7 µm IR color table and select Basic -> Inverse 

Gray shade. 
 
4. Right-click on the color table again and select Change Range...  Edit the values to focus on the colder 

clouds.  Change the range to 160 to 290 K and click OK.  
 
5. To create a color enhancement, right-click on the color table and select Edit Color Table.  The inverse gray 

shade color table will be loaded in with the 160 to 290 K range.   
 

The editor uses “breakpoints” which are used for a number of things: showing the data value at a point 
along the color table and changing the colors (fill, interpolation or transparency) directly below the 
breakpoint by dragging the breakpoint and changing colors through a popup menu.  Breakpoints are 
indicated along the top of the color legend bar with little triangles and a number. 

 
a. Create a new breakpoint at 273 K by right-clicking on or near the color table and selecting Add 

Breakpoint->At Data Point.  Enter in 273 and click OK.  By default, this breakpoint will be active. 
 
b. The Color Chooser in the lower half of the editor window allows you to select any possible color.  Use 

the slider bar to choose a green hue.  Once you have chosen a hue, click and drag the mouse on the 
square color display to choose a specific color, which should also update the color of the breakpoint. 

 
c. Click on the 160 breakpoint to make it active and use the same method to select a dark blue color. 

 
d. Interpolate the colors from 160 to 273 by right-clicking on the 160 breakpoint and selecting Edit Colors   

-> Interpolate->Right.  The enhancement on the images will automatically update. 
 

e. Click on the 290 breakpoint, select a yellow color, and interpolate left to interpolate between 273 and 
290. 

 
f. Another option is transparency.  Click on the Transparency paint mode radio button below the color 

table and change the pull down menu to 100%. 
 

i. Move the mouse over the color table to see the cursor change to a paintbrush.  A gray line 
representing the position of the cursor is also drawn. 

 
ii. Left click on 273 and drag the paint brush to the right to the 290 value.  All values between 273 and 

290 will now be transparent. 
 

g. Save the color table as IR Temps in the Satellite category. 
 

i. At the top right of the editor, select Satellite from the Category pull down list. 
 

ii. Select File->Save As..., enter in IR Temps and click OK.  This color table will now show up in the 
list of color tables as Satellite->IR Temps.  
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6. Select View -> Capture -> Movie to bring up the Movie Capture window. 
 

a. Make sure that the main display window is not obscured by any other window, including the Data 
Explorer and the Movie Capture window. 
 

b. Click the Time Animation button.  Each time in the loop will be automatically captured. 
 

c. When the capture is complete, a Save window will pop up.  Select “Animated GIF” from the Files of 
Type pull down menu, enter in a file name, and click Save. 

 
7. Click Close to close the Movie Capture window. 
 
Problem Set #2 – Solution 
 
Create a Parameter default for temperature images so all GOES Temperature images use the same enhancement 
and range as in Problem 1. Then, load several different bands of temperature (10.7 µm, 3.9 µm, etc.) and loop 
through the different bands.  You may use bundles Sat-Problem-Default.mcvz and Sat-Problem-Default-
Images.mcvz or real-time data to load the images. 
 
1. Select Tools -> Parameters -> Defaults from the main menu to bring up the Parameter Defaults Editor. 

 
a. Select File -> New Row from the editor menu. 
 
b. Click the double down arrows to the right of the Parameter entry box and select “Current Fields -> GW-

IR – GOES-West 10.7 um IR -> 76_Band4_TEMP”. 
 

c. Modify the Parameter name and replace “76” and “4” with an asterick followed by a period “*.”. 
 

i. The final result should be:  *._Band*._TEMP 
 

d. Check the Color Table option and select “Basic -> Inverse Gray shade” 
 

e. Check the Range option and enter in a range of 160 to 290. 
 

f. Click OK. 
 

g. Click Close in the Parameter Defaults editor. 
 
2. If you are using real-time data, skip to step 3. 
 

a. Use the File -> Open File... to load bundle Sat-Problem-Default.mcvz into McIDAS-V. 
 

i. In the “Open Bundle” dialog box select the Replace session option and click OK. 
 
b. Load the single image by clicking Create Display.  The GOES-East image should have the same range 

and enhancement as the GOES-West loop did in the previous problem. 
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3. If you are using real-time data, follow the steps below. 
 

a. Return to the Data Sources tab. 
 
b. Connect to the server adde.ucar.edu with the dataset RTIMAGES. 

 
c. Choose the GE-IR – GOES-East 10.7 µm IR Image Type and select the most recent time. 

 
d. Select a Data Type of Temperature. 

 
e. Click Add Source to show the Field Selector. 

 
f. Click Create Display.  The GOES-East image should have the same range and enhancement as the 

GOES-West loop did in the previous problem. 
 
4. Load bundle Sat-Problem-Default-Images.mcvz into McIDAS-V and repeat using other GOES-East 

Infrared bands with Temperature Data Types with the saved parameter default. 
 

a. In the “Open Bundle” dialog box select the Merge with active tab(s) option and click OK. 
 
b. In the list of Data Sources in the Field Selector, there should now be two additional data sources – 

GOES-East 3.9 µm and 13.3 µm temperature images.  Load both of these images. 
 
c. Use the View -> Bring to Front menu option in the layer controls for each band to bring the display to 

the front. 
 
5. To loop through the different bands, use the View -> Displays -> Visibility Animation -> On option. 
 
Problem Set #3 – Solution 
 
Display a GOES-East 10.7 µm brightness image and overlay a MODIS Level 1b 1km 11.0 µm brightness 
image.  Load a data transect for each image and sync them together.  You may use bundles Sat-Problem-
GOES.mcvz and Sat-Problem-MODIS.mcvz or real-time data to load the images 
 
1. Load bundle Sat-Problem-GOES.mcvz to load the GOES-East 10.7 µm image.  If you are using real-time 

data, skip to step 2. 
 

a. In the “Open Bundle” dialog box select the Replace Session option and click OK. 
 
2. If you are using real-time data, follow the instructions below.  
 

a. Remove all layers and data sources. 
 
b. From the Data Sources tab, connect to the server adde.ucar.edu with the dataset RTIMAGES. 

 
c. Choose the GE-IR – GOES-East 10.7 µm IR Image Type and select the 17:45 UTC image from the 

previous day. 
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d. Click Add Source to show the Field Selector. 
 

3. Click Create Display. 
 
4. Select Projections->Auto-set Projection from the Projection menu to turn this option off. 
 
5. Load bundle Sat-Problem-MODIS.mcvz to load the MODIS L1b 1km 10.7 µm image from 17:45 UTC the 

previous day.  If you are loading real-time data, skip to step 6. 
 

a. In the “Open Bundle” dialog box select the Merge with active tab(s) option and click OK. 
 
6. If you are using real-time data, follow the instructions below. 

 
a. From the Data Sources tab, connect to a server and dataset that has MODIS or other polar orbiting 

imagery. 
 
b. Select a ~10.7 µm channel and select an image as close to 17:45 UTC from the previous day, add the 

source, and create the display. 
 
7. Return to the Field Selector and click on the 1KM – MODIS L1b 1km data source and create the display.   
 
8. Go back to the Field Selector and select the “Data Transect” Display type and click Create Display. 
 
9. Repeat the data transect for the GE-IR – GOES-East dataset. 
 
10. In the Legend, right click on both transects (under “Cross sections”) and select Edit -> Sharing -> Sharing 

On. 
 
11. In the Layer Controls, click on each transect layer and select View -> Undock from Data Explorer to 

remove the transects from the Explorer. 
 

a. Turn off the GOES image by clicking off the checkbox in the Legend. 
 

b. Move the MODIS transect line, keeping it within the bounds of the MODIS image.  Once you move one 
of the transects in the main display window, both transects will align and move to the same points.   
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Creating RGB images using formulas 
 
1. Load Sat-RGB-MODIS.mcvz to load MODIS L1B ½ km data sources. If you are using real-time data, skip 

to step 2.   
 
a. In the “Open Bundle” dialog box select the Replace Session option and click OK. 

 
2. If you are using real-time data, follow the instructions below. 
 

a. Remove all layers and data sources. 
 
b. From the Data Sources tab, connect to the server nanuk.eosdis.nasa.gov with the dataset NANUK. 

 
c. Choose the AQUA_HKM Aqua 500 meter resolution Calibrated Radiances Image Type and select the 

most recent image.  
 

d. Select Channel: All Bands. 
 

e. Change the location to Line/Element. 
 

f. Make sure the chain links to the right of the Magnification are linked together and change the 
Magnification: to -5 X -2. 

 
g. Click Add Source. 

 
3. To define the Red, Green, and Blue channels of your image display, begin by clicking on Formulas under 

the Data Sources listed in the Field Selector. 
 

a. Select Imagery -> Three Color (RGB) Image, and click Create Display. 
 

b. In the pop up box, select Aqua_HKM... -> 0.6465 um -> Brightness as Red, Aqua_HKM... -> 0.5537 
um -> Brightness as Green, and Aqua_HKM... -> 0.4656 um -> Brightness as Blue and click OK. 

 
4. Load Sat-RGB-BBM.mcvz to load the Big Blue Marble channels.  If you are using real-time data, skip to 

step 5. 
 
5. If you are using real-time data, follow the instructions below. 
 

a. Remove all layers and data sources. 
 
b. From the Data Sources tab, connect to the server pepe.ssec.wisc.edu and the dataset BBM.   

 
c. Load the three image types: Big Blue Marble blue/green/red with a magnification of -10 X -20.   

 
6. Follow the same procedure as above to select the red, green, and blue images from left to right and click 

OK.   
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7. Save this as a favorite bundle in the toolbar.   
 

a. Select File -> Save Bundle…  
 

b. Under Category select Toolbar and under Name enter in BBM.   
 

c. Make sure the view, display, and data sources options are checked and click OK.   
 

d. To the right of the toolbar buttons, there should be a BBM button.   
 
8. Remove all layers and data sources and click on the BBM button to see the bundle load. 
 
 
Accessing Local Data Files from the Image Chooser 
 
1. Remove all layers and data sources. 
 
2. Open the Local Data Manager by selecting Tools -> Local ADDE Data.   
 

a. To add local data entries, select File->Add New Dataset from the menu.  Enter in the following 
parameters to set up a dataset with the AREA files provided with this tutorial: 

 

 
 
b. The data formats available for use with the local ADDE servers are listed under Format:.   
 
c. Under Directory:, select the directory where the AREA files provided with this tutorial are located.  

 
3. In the Data Sources tab in the Data Explorer, select Satellite -> Imagery.  The first server listed will be 

<LOCAL-DATA>, and if you only have one local dataset created, the dataset listed will be MY-AREAS.   
 

a. Click Connect. 
 
b. Select an Image Type: of GOES Satellite Data.   

 
c. Under Relative, select the number of images to view, and under Channel, select the band to view. 

 
d. Click Add Source to bring up the Field Selector, and then Create Display.  The image loop will load in 

the Main Display window.   
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Zooming, Panning, and Rotating Controls 
 

Zooming Panning Rotating 
 Mouse  
Shift-Left Drag: Select a region 
by pressing the Shift key and 
dragging the left mouse button. 
Shift-Right Drag: Hold Shift key 
and drag the right mouse button. 
Moving up zooms in, moving 
down zooms out. 

Control-Right Mouse Drag: 
Hold Control key and drag right 
mouse to pan. 

Right Mouse Drag: Drag right 
mouse to rotate. 

 Scroll Wheel  
Scroll Wheel-Up: Zoom Out. 
Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-
Up/Down: Rotate 
clockwise/counter clockwise. 
Shift-Scroll Wheel-Up/Down: 
Rotate forward/backward 
clockwise. 

 Arrow Keys  
Shift-Up: Zoom In. 
Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 
Control-Down arrow: Pan Up. 
Control-Right arrow: Pan Left. 
Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate 
around vertical axis. 
Up/Down arrow: Rotate 
around horizontal axis. 
Shift-Left/Right arrow: Rotate 
Clockwise/Counterclockwise. 
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