
McIDAS-V Tutorial 
Displaying Gridded Data 

updated August 2009 (software version 1.0beta4) 
 

 

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation 
in SSEC's 35-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite 
(including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and 
manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and 
Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands 
and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being 
integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data. 
 
McIDAS-V is currently a beta version of the software, which means that the software may contain bugs and not 
always work as expected.  If you encounter any errors, please send them to the McIDAS Help Desk at 
mug@ssec.wisc.edu .  You will be notified at the startup of McIDAS-V when new versions are available on the 
McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/ .    More training materials are available 
on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-V User’s Guide, which is 
available from the Help menu within McIDAS-V.   
 
This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start 
McIDAS-V.  If you can not start McIDAS-V on your machine, you should follow the instructions in the 
document entitled McIDAS-V Tutorial – Installation and Introduction.   

In this McIDAS-V Tutorial, each exercise will be explained using two different methods of data access:  pre-
loaded data bundles and real-time access to default remote servers.  If you have access to your own real-time 
ADDE servers, you may also use those, but be aware that different server configurations may make the 
explanations in this document not quite applicable to all data that you may load.   

 
Displaying Gridded data: 2D 
 
1. Load data bundle Grid-GFS-Intro.mcvz.  If you are using real-time data, skip to step 2. 
 

a. In the “Open Bundle” dialog box select the Replace session option and click OK. 
 
2. If using real-time data, follow the steps below. 
 

a. Remove all layers and data sources. 
 
b. Select the Gridded Data -> Remote chooser from the Data Sources tab.   

 
c. From the Catalog: pull down menu, select http://motherlode.ucar.edu:8080/thredds/idv/models.xml 

 
d. Add the NCEP Model Data -> Global Forecast System Model -> NCEP GFS CONUS 80 km  -> 

Latest source.   
 

 

mailto:mug@ssec.wisc.edu
http://motherlode.ucar.edu:8080/thredds/idv/models.xml
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3. In the Field Selector select the 2D grid -> Pressure reduced to MSL @ msl field. 
 

a. Select the Color-Shaded Plan View Display. 
 
b. In the Times tab, uncheck the “Use Default” box and select the first six times. 

 
c. Create the Display 

 
4. In the Layer Controls, turn on the option to Shade Colors.   
 
5. Go back to the Field Selector. 
 

a. Change the Display type to Contour Plan View and 
overlay the same parameter.   

 
b. Click on the Color Table name (PressureMSL) to 

change the color table of the contours to Solid ->Black.   
 

 
 
Displaying Gridded data: 3D 
 
1. Remove all layers.  In the Field Selector, select the Temperature @ isobaric field under the 3D grid listing. 
 

a. Select the Color-Filled Contour Plan View Display type. 
 
b. In the Times tab select the first 6 images. 

 
c. In the Levels tab, select 500 hPa. 

 
d. Click Create Display.   

 
2. Use the rotating and zooming controls to rotate the main 3D display.  You can clearly see the contours are 

displayed at 500 hPa in the main display. 
 
3. Keep the main display rotated so the difference in height between the map and the contours can be seen. 
 
4. In the Layer Controls, use the Levels pull down menu to change the level of the contours.  Note that when 

the level is changed, both the contours and the height of the contours change in the main display. 
 

a. Change the level to 850 hPa. 
 
b. Change the display units from Celsius to Fahrenheit by selecting Edit -> Change Display Unit from the 

Layer Controls menu. 
 

c. Change the contour interval to 5 Fahrenheit by clicking on the Change button in the Contour section of 
the Layer Controls.   
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5. Reset the projection and change the level to 250 hPa. You should notice that the map does not show up on 
the contours. 

 
6. Move the map above the 250 hPa contours and change the map colors to white. 
 

a. In the Layer Controls, select “Default Background Maps” from the list of layers on the left hand side. 
 
b. Change the map colors of “North & Central America”, “World Coastlines”, and “World Political 

Boundaries” to white. 
 

c. In the Settings tab, move the Map position slider to the right to move higher into the 3D display. 
 
Problem Set 
 
The previous examples were intended to give you a general knowledge of how to load and display gridded 
data.  The problem sets below are intended to introduce you to new topics related to the data, as well as 
challenge your knowledge of McIDAS-V.  We recommend that you attempt to complete each problem set 
before looking at the solutions, which are provided below the problem set. 
 
1. Create a display of 2D Pressure as a 3D Color Shaded Image over topography using the 5 most recent times.  

Overlay Absolute Vorticity as an isosurface.  Then, remove the Absolute Vorticiy layer and add a cross 
section of Relative Humidity.  Save this as a bundle, only saving the parameters used in the displays. 
 

2. Create a 3D globe display of jet stream winds and 2D surface pressure from grids.  You may use bundle 
Grid-Problem-Globe.mcvz or real-time data to load the grids.  Note:  This bundle is large, so it may take a 
minute to open the file. 

 
3. Create a display showing the difference between the 0Z and 6Z 2D Pressure Reduced to MSL @ msl for a 

specific time.  Save a JPG image of the difference.  You may use bundle Grid-Problem-Difference.mcvz 
or real-time data to load the grids. 

 
Problem Set #1 – Solution 
 
Create a display of 2D Pressure as a 3D Color Shaded Image over topography using the 5 most recent times.  
Overlay Absolute Vorticity as an isosurface.  Then, remove the Absolute Vorticiy layer and add a cross section 
of Relative Humidity.  Save this as a bundle, only saving the parameters used in the displays. 
 
1. Remove all layers.   
 
2. Reset the map position to the Bottom. 
 
3. Add the earliest 2D Pressure reduced to MSL @ msl and display it as a 3D Color-Shaded Image Over 

Topography.  The 2D field will be displayed as a topography. 
 

a. You will be prompted for the Topography field.  Select the Latest NCEP GFS CONUS 80km -> 2D 
grid -> 2D Geopotential height @ surface field from the selector, the earliest time, and press OK.   
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b. Shade the colors, and use the zooming and rotating controls to see the display in 3D.   
 

4. Reset the display projection. 
 
5. Display the earliest 3D Absolute Vorticity @ isobaric as a 3D isosurface.   
 
6. Zoom in over the US and rotate the display to see the absolute vorticity isosurface over the continental US.   
 
7. The Isosurface Value in the Layer Controls can be used to change the value of absolute vorticity displayed. 
 

 
 
8. Remove the absolute vorticity isosurface layer from the display. 
 
9. Add the earliest 3D Relative Humidity at isobaric as a Color-Filled Contour Cross Section.  The cross 

section will be displayed in 3D in the main window and in 2D in the Layer Controls tab.   
 
10. To reposition the cross section in the main window, left click on the plus or square to move the ends of the 

cross section, and the triangle to move the entire line.  
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11. Select File -> Save As... from the main menu. 
 

a. Under Files of Type select “Zipped McIDAS-V Bundles (*.mcvz)” 
 
b. Enter in a file name and click Save. 

 
c. In the “Save Data” dialog box, check Latest NCEP GFS CONUS 80 km and click OK.  By default, the 

fields used in the display are automatically checked.  Click OK. 
 

Problem Set #2 – Solution 
 
Create a 3D globe display of jet stream winds and 2D surface pressure from grids.  You may use bundle Grid-
Problem-Globe.mcvz or real-time data to load the grids.  Note:  This bundle is large, so it may take a minute to 
open the file. 
 
1. Add a new one panel globe display tab by selecting File -> New Display Tab -> Globe Display -> One 

Panel.   
 
2. Load bundle Grid-Problem-Globe.mcvz.  If you are using real-time data, skip to step 3. 
 

a. In the “Open Bundle” dialog box select the Replace session option and click OK.  This is a large 
dataset, so it may take a minute to open the file. 

 
3. If you are using real-time data, follow the steps below. 
 

a. Remove all layers and data sources. 
 
b. Load the latest GFS Global 1° grid (NCEP Model Data  ->Global Forecast System Model -> NCEP 

GFS Global 1 degree -> Latest).   
 

4. Display three 2D Temperature at Surface grids every 24 hours as a color-filled contour plan view.   
 
5. Overlay it again as contours.   
 
6. Next, display the 3D derived wind speed grid as a 3D isosurface for the same times. 

 
7. Use the Layer Control panel to change the following: 
 

a. Change the Contour intervals for temperature to 5 K for both sets of contours. 
 
b. Change the isosurface value to 60 m/s.   

 
c. Change the default World Coastlines map color to RGB 0-153-204 and the default World Political 

Boundaries map color to RGB 0-255-255.   
 
8. Start the loop and turn the Auto rotate view option (View -> Viewpoint from the main display window) on.   

 
a. Use the Zooming and Panning controls to observe the data from different views.   
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b. Depending on preference, it might help to turn the Auto rotate view option off. 
 

9. Turn the looping on and make sure the Auto rotate view option is on.   
 
10. Capture a movie of the rotating globe by selecting View -> Capture -> Movie…   
 

a. In the movie capture box, change the Rate: to 0.25 seconds.   
 
b. Move the main window and the movie capture box around so that they are not overlapping.  (During the 

movie capture, if the view in the main window is obscured, the obscurities will be shown in the capture.)   
c. Start the movie capture by clicking Automatically.   

 
d. Once the globe has rotated a complete 360°, click Stop. 

 
e. Click Save Movie to save it as a QuickTime movie. 
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Problem Set #3 – Solution 
 
Create a display showing the difference between the 0Z and 6Z 2D Pressure Reduced to MSL @ msl for a 
specific time.  Save a JPG image of the difference.  You may use bundle Grid-Problem-Difference.mcvz or 
real-time data to load the grids. 
 
1. Close the globe display tab. 
 
2. Load data bundle Grid-Problem-Difference.mcvz.  If you are using real-time data, skip to step 3. 
 

a. In the “Open Bundle” dialog box select the Replace session option and click OK. 
 

3. If you are using real-time data, follow the instructions below. 
 

a. Remove all layers and data sources. 
 
b. Return to the Data Sources tab. 
 
c. Load the 0Z and 6Z GFS Global 1° grids (NCEP Model Data -> Global Forecast System Model -> 

NCEP GFS Global 1 degree -> GFS_Global_onedeg_YYYYMMDD_0000.grib2 (0600.grib2) ) for 
today into the Field Selector. 

 
4. Choose Formulas in the Field Selector  
 
5. Select Miscellaneous -> Simple Difference a-b.   
 
6. In the Displays tab select Plan Views -> Color-Shaded Plan View and click Create Display.  A box will 

pop up prompting you for the two fields to subtract.   
 

a. On the left side, select the 0Z 2D Pressure Reduced to MSL @ msl in the field and 0Z for the next day in 
the times. 

 
b. On the right side, select the 6Z 2D Pressure Reduced to MSL @ msl in the field and 0Z for the next day 

in the times.   
 

7. The resulting plot will show the difference 
between the two grids in Pascals.   

 
a. To change to millibars, go to the Layer 

Controls tab and select Edit -> Change 
Display Unit…   

 
b. Select millibars from the dropdown list and 

click OK.  To change the range of data 
values with the new units, click on the default Color Table box, select Change Range, and click on Use 
Predefined -> From All Data.  Positive values indicate the 0Z forecast predicted a higher pressure than 
the 6Z, and negative values indicate the opposite.   
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8. To save the full main display window as an image, select View -> Capture -> Image… from the Display 
menu. 

 
a. Under “Capture What” change the radio button to Full Window. 
 
b. Enter in a name, followed by the “.jpg” extension. 

 
Challenge 
 
The bundle Grid-Problem-Challenge.mcvz contains 3D u and v data.  Use the available data and display 
options to look for a jet entrance or exit region. 
 
For a reminder of jet entrance and exit regions, see the graphic below from: 
http://www4.ncsu.edu/~nwsfo/storage/training/jets/JETS.gifs/JET.4Cell.A.gif 
 

http://www4.ncsu.edu/%7Enwsfo/storage/training/jets/JETS.gifs/JET.4Cell.A.gif
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Zooming, Panning, and Rotating Controls 
 

Zooming Panning Rotating 
 Mouse  
Shift-Left Drag: Select a region 
by pressing the Shift key and 
dragging the left mouse button. 
Shift-Right Drag: Hold Shift key 
and drag the right mouse button. 
Moving up zooms in, moving 
down zooms out. 

Control-Right Mouse Drag: 
Hold Control key and drag right 
mouse to pan. 

Right Mouse Drag: Drag right 
mouse to rotate. 

 Scroll Wheel  
Scroll Wheel-Up: Zoom Out. 
Scroll Wheel-Down: Zoom In. 

 Control-Scroll Wheel-
Up/Down: Rotate 
clockwise/counter clockwise. 
Shift-Scroll Wheel-Up/Down: 
Rotate forward/backward 
clockwise. 

 Arrow Keys  
Shift-Up: Zoom In. 
Shift-Down: Zoom Out. 

Control-Up arrow: Pan Down. 
Control-Down arrow: Pan Up. 
Control-Right arrow: Pan Left. 
Control-Left arrow: Pan Right. 

Left/Right arrow: Rotate 
around vertical axis. 
Up/Down arrow: Rotate 
around horizontal axis. 
Shift-Left/Right arrow: Rotate 
Clockwise/Counterclockwise. 
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