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McIDAS-V Tutorial
Displaying Polar Satellite Imagery
updated September December 2013 (software version 1.4)


McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in SSEC's 40-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data.

More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. Notifications at McIDAS-V startup alert users when there is a new version of McIDAS-V is available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/You will be notified at the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/ .
Please post error reports or feature requests to the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/http://dcdbs.ssec.wisc.edu/mcidasv/forums/. The forums also provide the opportunity to share information with other users.
If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share information with other users.

This tutorial assumes McIDAS-V is installed, and that you know how to start McIDAS-V.  For information about installing and starting McIDAS-V follow the instructions in the document entitled McIDAS-V Tutorial – Installation and Introduction.  
This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the document entitled McIDAS-V Tutorial – Installation and Introduction.


Terminology
There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer).
The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field Selector, displayed in the Main Display, and output is formatted in the Layer Controls.
Menu trees will beare listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources).
Mouse clicks will beare listed as combinations (e.g. Shift+Left Click+Drag).



Loading Polar Satellite Images and Loops

1. Create a local dataset to access the imagery files on your local machine.

a. In the Main Display window of McIDAS-V, select Tools -> Manage ADDE Datasets.

b. In the ADDE Data Manager, select File -> New Local Dataset.  Enter in the following parameters to define a dataset for the MODIS Level 1b HDF files provided with this tutorial:

· Dataset – MODIS
· Image Type – HDF MOD021km files
· Format – MODIS MOD 02 – Level-1B Calibrated Geolocated Radiances
· Directory – select the <local path>/Data/Polar/modis_files directory

[image: ]

c. Click Add Dataset.

d. Close the ADDE Data Manager by clicking Ok or File -> Close.

2. To load the data in this local dataset, follow these steps.
a. [image: ]Click on the [image: data-explorer-icon] button in the Main Toolbar to go to the Data Explorer.

b. Select the Satellite -> Imagery chooser from the Data Sources tab.

c. Select <LOCAL-DATA> for the Server, select MODIS for the Dataset, and click Connect.

d. Choose the 1km HDF MOD021KM files Image Type and select an Absolute time of 02:50 UTC.

e. Click Add Source to show the Field Selector.

f. Click on the dropdown arrow next to Select 0.6465 um Land/Cloud Boundaries

Select -> Brightness.

g. Click Create Display.  The 02:50 UTC 0.6465 μm image is displayed in the Main Display window.

3. Use the zooming and panning controls in the left toolbar to inspect the image.

a. Reset the display projection by clicking on the [image: house] icon below the zooming buttons on the left toolbar.

b. Reproject the image with a pre-defined domain.  Select Projections -> Predefined -> Asia.  Use the scroll wheel to zoom into the image or Shift+Left Click+Drag a box around the image.

c. Turn off the Auto-set Projection option under the Projections menu.  When this option is checked, the projection will automatically changes to the native projection of the new layer.  When this option is unchecked, all new layers will beare reprojected into the current projection.

4. Edit the maps in the display by using the options in the Layer Controls.

a. Click on Default Background Maps in the Legend to go toaccess the map Layer Controls.  The map controls will havehas two tabs:.  The first 
i. The Maps tab lists the available maps provides customization controls for map removal, visibility, line width, style and color., and the second 
ii. The Lat/Lon tab allows the user toprovides control latitude/ and longitude lines and label controlss. 

At the bottom of both tabs, there is a Position slider that allows you toprovides the vertical position control the vertical positioning of the maps in the Main Display.

In the Maps tab you can remove a map, change its visibility, line width, style and color.  Use these options to create your own map display.


b. If you choose, alsoOptional: add latitude/ and longitude lines and labels in using the Lat/Lon tab.

c. To save a default map configuration as the default, in from the map Layer Controls select File -> Default Maps -> Save as the Default Map Set.  This default becomes active tThe next time you open a new tab, or window is opened, or start McIDAS-V, the defaults will reflect what you selected.McIDAS-V is restarted.

5. Return to the Field Selector to load an infrared image.

a. Select 11.0186 um Surface/Cloud Temperature -> Temperature.

b. Click Create Display.

6. The 11.0186 µm temperature image is overlaid on topon of the visible image.  To see the To change the layer visible imageility (and view the visible image), turn off the topuncheck the 1km HDF MOD021KM (All Bands...) checkbox in the Legend.  Check the box again to Turn themake the 11 µm layer visible again image back on and .  click Click and drag the middle mouse button to activateand observe  the Cursor/Data Readout option.  This displays a readout at the bottom of the Main Display consisting of a latitude, longitude, and data value at the cursor locationThis option brings up a latitude, longitude, and data value readout in the upper left part of the display on a mouse drag.   Since there are two layers in the main displayMain Display, there are two lines are displayed in the different readouts with the appropriate corresponding values and units.
	Comment by gilbert kugi: Upper Left???
7. Change the font and color of the labels on the Main Display.

a. In the Main Display window, choose Edit -> Preferences.  Click on Display Window.

b. In the right column under Layer List Properties, change Font to Arial/Plain/14.  Change the Color to yellow.  Click OK.

c. Return to the Main Display to see the changes. Notice the labels are the same in the Legend and on the main display window label.  This can be customized.

d. Right Click on the top Legend label HDF MOD021KM (All Bands...).

e. Choose Edit -> Properties…. Enter the following for the Legend Label and Layer Label:
· Legend Label – 11.0186 um TERRA
· Layer Label – %datasourcename% - 11.0186 um -  %timestamp%

[image: ]


8. Return to the Data Sources tab of the Data Explorer to load another time.

a. Go to the Data Sources tab of the Data Explorer, and using the Satellite -> Imagery chooser with <LOCAL-DATA>/MODIS, select the HDF MOD021KM files Image Type, and an Absolute time of 02:55 UTC.

b. Click Add Source to show the Field Selector.

c. A new data source is created in the Field Selector.  Edit the label To to distinguish it from the first data source, the label is editable.  Right Click on the highlighted 1km HDF MOD021KM (All Bands...) and choose Properties.  In the Name field enter, 1km HDF 2:55 UTC MOD021KM.  Click OK.

d. Select 0.6465 um Land/Cloud Boundaries -> Brightness.

e. Click Create Display.  The 02:55 UTC 0.6465 μm image is displayed in the Main Display window with the other displays also visible (because the Auto-set Projection setting is unchecked).

f. In the Legend, click on the trash can next to 11.0816 µm TERRA to remove the infrared display (the middle one listed with the color table range of 0 to 295.7).

9. Create a local dataset to access the HRPT (High Resolution Picture Transmission) and GAC (Global Area Coverage) NOAA-18 Area polar orbiter imagery files on your local machine.

a. In the Main Menu Bar of the Main Display window , select Tools -> Manage ADDE Datasets. This will openopens the ADDE Data Manager.

b. Select File -> New Local Dataset. Enter the following parameters to set upto define the dataset:

· Dataset – HRPT
· Image Type – HRPT N18 area files
· Format – McIDAS AREA
· Directory – select the <local path>/Data/Polar/HRPT_areas directory.
[image: ]

c. Click Add Dataset.

d. In the ADDE Data Manager, select File -> New Local Dataset. Enter the following parameters to set updefine the dataset:

· Dataset – GAC
· Image Type – GAC N18 area files
· Format – McIDAS AREA
· Directory – select the <local path>/Data/Polar/GAC_areas directory.
[image: ]

e. Click Add Dataset.

f. Close the ADDE Data Manager by clicking Ok or select File -> Close.

10. Remove all layers and data sources and display HRPT 10.8 um Temperature data.

a. In the Main Display window, select Edit -> Remove -> All Layers and Data Sources.

b. Click on the [image: data-explorer-icon] button in the Main Toolbar to go to the Data Explorer  

c. Select the Data Sources tab use In the Satellite -> Imagery chooser of the Data Sources tab of the Data Explorer, select 

Server:  <LOCAL-DATA> for the Server, select 
Dataset:  HRPT for the
 Dataset, and clickClick Connect.

d. Choose 
the Image Type:  HRPT N18 area files Image Type and select 
Click the an Absolute tab.  Select the time of 04:45:04 UTC.

Navigation:  
Select Lat/Lon for the using the drop down listNavigation.

e. Click Add Source to show the Field Selector.

f. Select 10.8 um Surface/Cloud-top Temp -> Temperature.

g. Under Displays click on the Advanced tab.  Click on the green arrow icon next to Image Size to load the full image. Change the Magnification to 1 X 1 with the sliders, and click Create Display.  (The Magnification of 1 X 1 downloads the full resolution of the data.  Negative magnification values will reduce the amount of data downloaded.  For example, -5 X -5 will samplesamples the data, and every fifth line and every fifth element is sent from the server.)

h. There are some bad data points in this image that cause the extreme minimum and maximum range values of the color table to befor the data.  Observe the large range of the color table (0 and 6553.1).  Change the range of the color table range by right clicking on the color table in the Legend, selecting Change Range..., and entering the values of From: 330 and To: 180.

11. Load an FY2E satellite image over the HRPT image.  This dataset was previously created in the Displaying Satellite Imagery tutorial.

a. In the Data Sources tab of the Data Explorer, using the Satellite -> Imagery chooser, select <LOCAL-DATA> for the Server, select ZQ_IR for the Dataset, and click Connect.

b. Choose the FY2E IR satellite data Image Type and select an Absolute time of 05:01 UTC.

c. Click Add Source to show the Field Selector.

d. Select 10.8 um Surface/Cloud-top Temp -> Temperature.

e. Under Displays click on the Advanced tab.  Click on the green arrow icon next to Image Size to load the full image. Change the Magnification to 1 X 1 with the sliders, and click Create Display.

f. Auto-set Projection is off from a previous exercise. To cChange to the FY2E image’s native projection, in the Main Display, select Projections -> From Displays -> Image (GMSX) Projection from: Image Display.
12. 
Zoom the Main Display over the HRPT image and place the HRPT image over the FY2E image. 

a. Turn off the FY2E full disk image by unchecking the FY2E IR Satellite Data box in the Legend.

b. Use Shift+Left Click+Drag to create a box over the HRPT image to zoom into it.

c. Turn on the FY2E full disk image by rechecking the FY2E IR Satellite Data box in the Legend.

d. In the Legend, Right Click on the HRPT N18 area files and select View -> Bring to Front.

13. Make the data ranges the same for both images and compare them.

a. In the Legend, Right Click on the FY2E IR satellite data’s color table and select Change Range....  In the window enter From: 330 and To: 180.  Click OK.

b. Use the middle mouse button to click and probe the data for a temperature comparison.


Creating RGB images using formulas

14. Create a local dataset to access a MODIS hdf file on your local machine and add the data.

a. In the Main Display, select the Tools -> Manage ADDE Datasets menu item.

b. In the ADDE Data Manager, select File -> New Local Dataset.  To set updefine a dataset with for a the MODIS hdf files provided with this tutorial enter the following parameters: Dataset: MODIS, Image Type: MODIS half km file, Format: MODIS MOD 02 – Level 1B Calibrated Geo-located Radiances.  Under Directory:, select the <local path>/Data/Satellite/modis_files directory. Click Add Dataset.

c. Close the ADDE Data Manager by clicking Ok or select File -> Close.

d. Remove All Layers and Data Sources.

e. In the Data Sources tab of the Data Explorer, using the Satellite -> Imagery chooser, select <LOCAL-DATA> for the Server, select MODIS for the Dataset, and click Connect.

f. Choose the MODIS half km file Image Type and select the Absolute time of 02:50 UTC.

g. Click Add Source to show the Field Selector.

15. Define the Red, Green, and Blue channels for theof your image display.

a. Click on Formulas under the Data Sources listed in the Field Selector.

b. Select Imagery -> Three Color (RGB) Image, and click Create Display.

c. In the Field Selector, select MODIS half km file -> 0.6465 um -> Brightness as red, MODIS... -> 0.5537 um -> Brightness as green, and MODIS... -> 0.4656 um -> Brightness as blue and click OK.

Problem Sets

The previous examples were intended to give you aprovided general knowledge for loading and displaying of how to lpolar satellite data with the McIDAS-V software package.oad and display polar satellite data.  The problem sets below are intended to introduce you to new topics related to the data, as well as challenge expand your knowledge of McIDAS-V.  We It is recommended that you attempt to complete each problem set before looking at the solutions, which is provided below the problem set.

1. Load a loop of GAC (Global Area Coverage) NOAA-18 images on a Globe Display.  Load visible and low-level water vapor images.  Animate the loop on a rotating globe with a solid blue background image.  Use the GAC N18 dataset created earlier in this tutorial.

2. Load a HRPT NOAA-18 image.  Display the polar orbit track for the image using a two-line element text file with the Polar Orbit Track chooser.  Add the swath width and antenna circles for the Wallops ground station.

Problem Set #1 – Solution

Load a loop of GAC (Global Area Coverage) NOAA-18 images on a Globe Display.  Load visible and low-level water vapor images.  Animate the loop on a rotating globe with a solid blue background image. Use the GAC N18 dataset created earlier in this tutorial.

1. Remove All Layers and Data Sources, create a globe display, and load the data.

a. Remove All Layers and Data Sources.

b. In the Main Display select File -> New Display Tab -> Globe Display -> One Panel.

c. In the Data Sources tab of the Data Explorer, using the Satellite -> Imagery chooser, select <LOCAL-DATA> for the Server, select GAC for the Dataset, and click Connect.

d. Choose the GAC N18 area files Image Type and select the Relative times of 8 most recent.

e. Select Lat/Lon for the Navigation.

f. Click Add Source to show the Field Selector.

2. Select the 0.63 μm and 12.0 μm bands and display them.

a. Select 0.63 um VIS Cloud and Surface Features -> Brightness.

b. Under Displays click on the Advanced tab.  For Coordinate Type: choose Image Coordinates. Change the Magnification to 1 X 1 with the sliders.  Click on the green arrow icon [image: arrows] next to Image Size to load the full-size image.  For Location: choose Upper Left, and click Create Display.

c. Repeat this process with the 12.0 um IR SFC/Cloud Temp, Low-level WV -> Brightness.




3. Animate the globe and add the background image.  Then analyze and animate the globe display.

a. From the Main Display, select Display -> Add Background Image.  In the Layer Controls for Layer choose Solid Blue.

b. Start the loop by using the Time Animation buttons at the top of the Main Display.

c. Turn on the Auto-Rotate view option (View -> Viewpoint from the Main Display window, or the Auto-Rotate button [image: autorotate] in the Viewpoint Toolbar to the left of the image).

d. Change the orientation of the globe in the Main Display with the mouse controls.  Restart the Auto rotate view.

Problem Set #2 – Solution

Load a HRPT NOAA-18 image.  Display the polar orbit tracks for the image using a two-line element text file with the Polar Orbit Track chooser.  Add the swath width and antenna circles for the Wallops ground station.

1. Remove All Layers and Data Sources, and display the 19:46:04 UTC NOAA-18 image in a new tab.

a. Remove All Layers and Data Sources.

b. Click the [image: ] button in the Main Display to create a new tab.

c. In the Data Sources tab of the Data Explorer, using the Satellite -> Imagery chooser, select <LOCAL-DATA> for the Server, select HRPT for the Dataset, and click Connect.

d. Choose the HRPT N18 area files Image Type

e. Select an Absolute time of 19:46:04 UTC.  

f. Select Lat/Lon for the Navigation.

g. Click Add Source to show the Field Selector.

2. Display the 19:46:00 UTC NOAA-18 image

a. Select 0.63 um VIS Cloud and Surface Features -> Brightness.










b. Under Displays select the Advanced tab.  
[image: ]
· For Coordinate Type: choose Image Coordinates. 

· Change the Magnification to 1 X 1 with the sliders.  

· Click on the green arrow icon [image: arrows] to load the full-size image.  

· For Location: choose Upper Left.

c. Click Create Display. 

d. Reproject the display to the continental United States domain.  In the Main Display, select Projections ‑> Predefined -> US ‑> CONUS.  Zoom into the image to fill the display.

3. Display the polar orbit tracks from a two-line element file.

a. In the Data Sources tab of the Data Explorer, select the Under Development -> Imagery – Polar Orbit Track chooser.

b. Under Look In, navigate to the <local path>/Data/Polar/ directory and select the noaa18.txt file.

c. Click Add Source to show the Field Selector.

d. Under Displays, select Polar Orbit Track.

e. Select what the time range of data to for display in the Time Range tab of the Field Selector.

· Enter Apr 26, 2012 in both Date: fields. 
· Enter 19:40 for Begin Time, and enter 20:00 for End Time.  Click Create Display.

f. Navigate to the Layer Controls of the TLE data to modify the display.

· Enter 3000 in Swath Width.
· Enter 5 in Font Size
· In Ground Station: click the arrow to show the list of stations.  Choose Wallops14 (near the bottom of the list).

[bookmark: _GoBack]
Zooming, Panning, and Rotating Controls

	Zooming
	Panning
	Rotating

	
	Mouse
	

	Shift-Left Drag: Select a region by pressing the Shift key and dragging the left mouse button.
Shift-Right Drag: Hold Shift key and drag the right mouse button. Moving up zooms in, moving down zooms out.
	Control-Right Mouse Drag: Hold Control key and drag right mouse to pan.
	Right Mouse Drag: Drag right mouse to rotate.

	
	Scroll Wheel
	

	Scroll Wheel-Up: Zoom Out.
Scroll Wheel-Down: Zoom In.
	
	Control-Scroll Wheel-Up/Down: Rotate clockwise/counter clockwise.
Shift-Scroll Wheel-Up/Down: Rotate forward/backward clockwise.

	
	Arrow Keys
	

	Shift-Up: Zoom In.
Shift-Down: Zoom Out.
	Control-Up arrow: Pan Down.
Control-Down arrow: Pan Up.
Control-Right arrow: Pan Left.
Control-Left arrow: Pan Right.
	Left/Right arrow: Rotate around vertical axis.
Up/Down arrow: Rotate around horizontal axis.
Shift-Left/Right arrow: Rotate Clockwise/Counterclockwise.
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