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McIDAS-V Tutorial
Displaying Point Observations from netCDF Files
updated September 2013 (software version 1.4)

McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in SSEC's 40-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data.
More All training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. Notifications at McIDAS-V startup alert users when there is a new version of McIDAS-V is available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/.  Please post error reports the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/. 
You will be notified at the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/.
Please post error reports or feature requests to the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/http://dcdbs.ssec.wisc.edu/mcidasv/forums/. The forums also provide the opportunity to share information with other users.
This tutorial assumes McIDAS-V is installed, and can be run on your machine.  For information about installing and running McIDAS-V follow the instructions in the document entitled McIDAS-V Tutorial – Installation and Introduction.  If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share information with other users.
This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the document entitled McIDAS-V Tutorial – Installation and Introduction.

Terminology
There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer).
The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field Selector, displayed in the Main Display, and output is formatted in the Layer Controls.
Menu trees will beare listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources).

Mouse clicks will beare listed as combinations (e.g. Shift+Left Click+Drag).




Plotting and Contouring Surface Point Observations around the world

1. Remove All Layers and Data Sources from the previous displays. (From the main toolbar [image: ] or from the main menu EditRemoveAll Layers and Data Sources)

2. If you have createdthere are more than onemultiple tabs, close the extra tabs by clicking the “X” in the right corner of the tabs.

3. Display the data from the <local path>/Data/Point_netCDF/metar/20090903_0100-metar.nc file.

a. In the Data Sources tab of the Data Explorer, open the General -> Files/Directories chooser.

b. In the Data Type field, choose netCDF/GEMPAK Point Data files.

c. Navigate to the <local path>/Data/Point_netCDF/metar/20090903_0100-metar.nc file.  Click Add Source.

d. In the Field Selector, select Point Data in the Fields panel.

e. In the lower-right panel, click the Layout Model tab and click the down arrows to select the parameter to plot.  Select Observations -> Temperature to plot all available temperatures.

f. Click Create Display.  The default display is a world projection with temperatures plotted from around the worldglobally.  As you zoom in you will see moreMore stations appear in the plot as the display is zoomed.

4. One feature of this dataset feature is that the data is plotted every minute.  This can be convenient for some applications, but is hard to view in an animated loop.  Change the time step to every thirty minutes.
a. Select the [image: ] icon in the Main Display to edit the Time Animation Properties.

b. Go toClick the Define Animation Times tab.

c. Select Define your own list of times, change the Interval and Round To values to 15 minutes.

d. Click OK.  Note that the time interval in the Time Animation Widget has changed from 1 minute to 15 minutes, and more data points are displayed at each time step.

5. Contour the temperatures plotted on the screen.

a. In the Field Selector, choose the 20090903_0100-metar.nc Data Source. Under Fields, click the [image: Description: TreeTagClosed] icon next to Gridded Fields to open the tree and list the fields available for contouring.  Select temperature from the list of available fields.

b. Select Contour Plan View from the Displays panel.

c. Subset a region over land in the Region tab:
 If  “Use Default” is checked, uncheck
with Use Left Click+Drag to select a region over land..

d. Click Create Display.  The contour properties can beare changed in the Layer Controls tab of the Contour Plan View display.


6. Repeat step 5, but select IB in the Displays panel.  In the Layer Controls for the Color-Shaded Plan View display, check the Shade Colors box to shade the colors.  (Hint:  Color-Shaded Plan View plots much faster than Color-filled Contours.)


Creating Time Series of Point Observations

7. Remove All Layers and Data via the Edit -> Remove -> All Layers and Data Sources menu item in the Main Display.

8. In the General -> Files/Directories chooser in the Data Sources tab of the Data Explorer, navigate to the <local path>/Data/Point_netCDF/metar directory and select times in at once (*_0300-metar.nc through *_0500-metar.nc) using Shift+Click. Click Add Source.

9. In the Field Selector tab, select the Point Data field, the Point Data Plot display, and the
Observations -> Temperature layout model. Click Create Display.

10. In the Layer Controls of the temperature point data plot, click on the Plot tab to create a time series.

11. Zoom in over a station in the Main Display and Left Click on the center of it.  The station information should fill into the table below the plot in the Layer Controls.

12. Add temperature to the plot by Right Clicking on temperature in the table and selecting Add To Chart.


Displaying RAOB Sounding Data

13. Remove All Layers and Data via the Edit -> Remove -> All Layers and Data Sources menu item in the Main Display.

14. Select the Point Observations -> Soundings  -> Local chooser from the Data Sources tab of the Data Explorer.

15. Under File, click Select File. Change the Files of Type field to All Files, and select 
<local path>/Data/Point_netCDF/raob/20090903_1200-raob.nc.  Click Open.
	Comment by Joleen Feltz: Not working for me.
16. Pick the station for your a sounding display.

a. Use the zooming and panning buttons to find your the station(s).

b. Select an available time and click on your the station to see if a sounding is available.  Available soundings will show upappear in the Selected box on the( bottom right of the chooser).

c. Left click on Select multiple stations by Left Clicking on thento select more than one. Once you have athere are multiple few stations in your the Selected box, click Add Source.

d. Under the Displays panel of the Field Selector, choose which a type of thermodynamic diagram to display type (Skew-T, Stuve, or Emagram).
	Comment by Joleen Feltz: Was redundant
e. Select one of the thermodynamic diagrams and cClick Create Display.

17. The sounding will plotplots in as a 2D display in the Layer Controls tab along with a list of thermodynamic parameters.  As the cursor moves over the sounding, the thermodynamic parameters will update with the location of the cursor.

[image: Description: handout-upperair1]


18. Modify the temperature and dewpoint profiles.

a. Left Click on the first data-point to be modified and drag it horizontally along an isobar to the desired position, then move the pointer diagonally along an isotherm to keep the data-point at the desired position and to pick-up the next data-point.

b. Repeat until done and then release the mouse button.

c. To reset the sounding, use the Edit ->Reset sounding menu item in the main menu of the Layer Controls tab.

19. Use the checkboxes below the sounding to configure the sounding chart. When the Stations box is checked, you will seethere is a square box in the Main Display indicating the location of each sounding selected in the Data Sources tab.  Select a new station by Left Clicking another square box in the Main Display, or by choosing a station in the Soundings dropdown menu in the Layer Controls.

20. In the Layer Controls, in In addition to the Sounding Chart in In the Layer Controls, there are is also a tabs for a Hodograph tab, and a Table tab. The table table tab lists of all of the data in the sounding.



Problem Sets

The previous examples were intended to give you aprovide the general knowledge of howrequired to load and display surface and upper air point data.  The problem sets below are intended to introduce you to new topics related to the data, as well as challenge your knowledge of McIDAS-V.  We It is recommend that you attempt to completecompletion each problem set before looking at the solutions, which are provided below the problem set.

1. Create a time series of surface Temperature, Dewpoint Temperature and Wind Barbs for five hours over Beijing (ZBAA).  Change the Temperature and Dewpoint Temperature axes in the plot so they have the same range.  Use six netCDF files provided from 03 UTC to 07 UTC and display the data in 30-minute intervals.

2. Modify the chart from problem #1 so you have three separate charts:  Place Wind Barbs in the top left chart, Pressure in the top right chart, and Temperature and Dewpoint Temperature in the bottom chart  (Hint: Change the chart names to separate out parameters!)

3. Using the same times used in problems 1 and 2, create your own station model layout that display the Dewpoint Depression in green over the center of the station with the station ID below the Dewpoint Depression, the Temperature to the upper left, and Dewpoint Temperature to the upper right.  Display the observations using the new layout and use 15-minute time intervals to display the data.


Problem Set #1 – Solution

Create a time series of surface Temperature, Dewpoint Temperature and Wind Barbs for five hours over Beijing (ZBAA).  Change the Temperature and Dewpoint Temperature axes in the plot so they have the same range.  Use six netCDF files provided from 03 UTC to 07 UTC and display the data in 30-minute intervals.

1. Remove All Layers and Data Sources from the previous display.

2. Display the data from five files in the <local path>/Data/Point_netCDF/metar directory: 
20090903_0300-metar.nc, 20090903_0400-metar.nc, 20090903_0500-metar.nc, 
20090903_0600-metar.nc, and 20090903_0700-metar.nc files.

a. In the Data Explorer, open the General -> Files/Directories chooser.

b. Navigate to the listed files.  Highlight the five files by Control+Left Click on each file.  Click Add Source.

c. In the Field Selector, select Point Data under Fields.

d. In the lower-right panel, click the Layout Model tab and click the down arrows to select the parameter to plot.  Select Observations -> METAR w/ Altimeter to plot a metar station model.  Click Create Display.
e. Change the interval to 15 minutes by clicking the  [image: ] icon to the right of the Time Animation Controls. Go to the Define Animation Times tab, select Define your own list of times, and the change Interval and Round To fields to 15 minutes.

f. Use the Zooming and Panning controls to zoom in over Beijing, and Left Click on the ZBAA station.

3. Create a time series plot of temperature and dewpoint.

a. In the Layer Controls, click on the Plot tab, and at the bottom, scroll down through the list of fields until you find temperature.

b. Right Click on temperature and select Add to Chart, and repeat for dewpoint.

4. Change the minimum and maximum values for the y-axis.

a. Right Click on the table of fields and select temperature -> Chart Properties.

b. In the Range: field, enter in a Min and Max value appropriate for both Temperature and Dewpoint Temperature (ex. 20 – 30).  Click OK.

c. Right Click on the table of fields below the chart and select dewpoint -> Chart Properties.

d. To the right of the Range: field, there is a ... button.  Click on this button and select “Fixed Range from temperature...”, and click OK.

5. To add wind barbs, add speed (windSpeed) and direction (windDir) to the chart.  When both of these parameters are added, they are converted into wind barbs.


Problem Set #2 – Solution

Modify the chart from problem #1 so there are three separate charts:  Place Wind Barbs in the top left chart, Pressure in the top right chart, and Temperature and Dewpoint Temperature in the bottom chart  (Hint: Change the chart names to separate out parameters!)

1. Return to the Temperature chart properties by Right Clicking on the table of fields and selecting temperature ‑> Chart Properties.

a. Enter in “Temperature” in the Chart Name field.

b. Click OK.  The Temperature plot should appear in a new chart below the other plot.

2. Repeat this step for Dewpoint Temperature and place it in the “Temperature” plot.

3. Add pressure to the charts and place altimeter in a separate chart titled “Pressure”.

4. Select View -> Chart -> Layout -> Change Grid Layout from the Layer Controls menu.

a. Use the Columns and Rows buttons to add/remove new columns and rows.

b. Left Click+Drag on a chart to move it to a different location.

c. Use the black squares around the individual charts to control their width and length.



Problem Set #3 – Solution

Using the same times used in problems 1 and 2, create your own station model layout that display the Dewpoint Depression in green over the center of the station with the station ID below the Dewpoint Depression, the Temperature to the upper left, and Dewpoint Temperature to the upper right.  Display the observations using the new layout and use 15-minute time intervals to display the data.

1. Remove All Layers.  

2. In the Main Display select the Tools -> Station Model Template menu item.

3. In the editor, select File -> New and enter in “Dewpoint Depression” for the name of the layout.

4. Click on “123 Value” to add a numeric value and Left Click in the middle of the layout.  The Properties Dialog box will pop up.

5. In the Parameter field, enter:  =temperature-dewpoint

6. Change the Foreground Color to green, and click OK.

7. Add a Station ID (“IDN”, from the ‘Text’ field), Temperature (“temperature”, from the ‘123 Value’ field), and Dewpoint Temperature (“dewpoint”, from the ‘123 Value’ field) in the appropriate locations.

8. In the editor select File -> Save and then close the Layout Model Editor window.

9. Return to the Field Selector, and display the same times of data with your newly created layout model.  

a. Under Fields, select Point Data.

b. Under Displays, select the Point Data Plot display type.

c. In the Layout Model tab in the lower right corner, change the model to “Dewpoint Depression <local>”

d. Click Create Display.  
e. Change the interval to 15 minutes by clicking the  [image: ] icon to the right of the Time Animation Controls. Go to the Define Animation Times tab, select Define your own list of times, and the change Interval and Round To fields to 15 minutes.

f. Zoom in over the United States using the Projections -> Predefined -> US -> CONUS menu item in the Main Display window.

g. Loop through the times to see values for dewpoint depression change.  







Zooming, Panning, and Rotating Controls

	Zooming
	Panning
	Rotating

	
	Mouse
	

	Shift-Left Drag: Select a region by pressing the Shift key and dragging the left mouse button.
Shift-Right Drag: Hold Shift key and drag the right mouse button. Moving up zooms in, moving down zooms out.
	Control-Right Mouse Drag: Hold Control key and drag right mouse to pan.
	Right Mouse Drag: Drag right mouse to rotate.

	
	Scroll Wheel
	

	Scroll Wheel-Up: Zoom Out.
Scroll Wheel-Down: Zoom In.
	
	Control-Scroll Wheel-Up/Down: Rotate clockwise/counter clockwise.
Shift-Scroll Wheel-Up/Down: Rotate forward/backward clockwise.

	
	Arrow Keys
	

	Shift-Up: Zoom In.
Shift-Down: Zoom Out.
	Control-Up arrow: Pan Down.
Control-Down arrow: Pan Up.
Control-Right arrow: Pan Left.
Control-Left arrow: Pan Right.
	Left/Right arrow: Rotate around vertical axis.
Up/Down arrow: Rotate around horizontal axis.
Shift-Left/Right arrow: Rotate Clockwise/Counterclockwise.
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