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McIDAS-V Tutorial
Displaying Suomi NPP Data
created updated September December 2013 (software version 1.4)
McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in SSEC's 40-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data.
More training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. Notifications at McIDAS-V startup alert users when there is a new version of McIDAS-V is available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/.  Please post error reports the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/.You will be notified at the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/ .  
Please post error reports or feature requests to the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/http://dcdbs.ssec.wisc.edu/mcidasv/forums/. The forums also provide the opportunity to share information with other users.
If you encounter an error or would like to request an enhancement, please post it to the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share information with other users.
This tutorial assumes McIDAS-V is installed, and that you know how to start McIDAS-V.  For information about installing and starting McIDAS-V follow the instructions in the document entitled McIDAS-V Tutorial – Installation and Introduction.  
This tutorial assumes that you have McIDAS-V installed on your machine, and that you know how to start McIDAS-V.  If you cannot start McIDAS-V on your machine, you should follow the instructions in the document entitled McIDAS-V Tutorial – Installation and Introduction.  
Terminology
There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer).
The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field Selector, displayed in the Main Display, and output is formatted in the Layer Controls.
Menu trees will beare listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources).

Mouse clicks will beare listed as combinations (e.g. Shift+Left Click+Drag).  








Introduction
McIDAS-V has the ability of displayings Suomi NPP data through the Under Development -> Imagery -> Suomi NPP chooser.  Among the displayable Suomi NPP products that McIDAS-V can display are different bands of SVM and SVI data, various cloud filter products, and the day/night band.  In order for this data to be recognized by McIDAS-V, the data and geolocation files must be contained within the same directory.  Some sources of data, including NOAA’s CLASS, package the data and geolocation files together, while other sources, including SSEC’s PEATE server, do not package the files together.  Note that this chooser is still under development and improvements in functionality as well as the ability to utilize different NPP products will be added in the future.
This tutorial utilizes PEATE data with separate data and geolocation files, single-banded data from NOAA CLASS, as well as multi-banded visible data from NOAA CLASS.

Aggregating Multiple Bands of SVM05 Visible Data
1. In the Main Display Remove All Layers and Data Sources via the Edit -> Remove -> All Layers and Data Sources menu item.

2. Create a new tab with the File -> New Display Tab -> Map Display -> One Tab menu item.

3. Load in the three time-consecutive granules of SVM05 data.

a. In the Data Sources tab of the Data Explorer, navigate to the Under Development -> Imagery - Suomi NPP chooser.

b. Under Files, use Shift+Click to select the following three files:

<local path>/Data/NPP/SVM05/SVM05_npp_d20130820_t1841270_e1842511_b*
<local path>/Data/NPP/SVM05/SVM05_npp_d20130820_t1842524_e1844165_b*
<local path>/Data/NPP/SVM05/SVM05_npp_d20130820_t1844178_e1845419_b*

Note that the <local path>/ Data/NPP/SVM05 directory includes three GMTCO* files (one for each SVM05* file).  These GMTCO* files contain the geolocation data necessary for McIDAS-V to plot the SVM05 data.  These GMTCO* files cannot be selected in the Data Sources tab of the Data Explorer, only the SVM05 files can be chosen.

c. Click Add Source.  Adding these three files at once will aggregates the data together, combining the three individual granules into a single image.




4. Select the field to display, the display type, and display the data at full-resolution.

a. In the Fields panel of the Field Selector, expand the IMAGE dropdown to view the fields included with the data.  Select the VIIRS-M5-SDR_All/Reflectance field.

b. [image: ]In the Displays panel, select Imagery -> Image Display.

c. The Region panel gives shows a preview image of the display.  By default, McIDAS-V will displays the data at a reduced resolution to save onconserve memory usage.  To display the data at full-resolution, an area within the data must be subsetted by using Shift+Left-Click+Drag.  Anything contained with the green bounding box will be displayed at full-resolution.  Subset out a large area of the data.  Note that the entire region must be contained within the granule’s data. 

d. Click Create Display.

5. Inspect the display of the SVM05 reflectance data.

a. Zoom in on to the region of interest (the southeastern United States)  in the Main Display by using Shift+Left-Click+Drag to choose an area containing the data (the southeastern United States).  The display region can be further customizedThe mouse can control display zoom and translation.  Experiment with the by  zooming in/out with using the scroll wheel on the mouse.  and the display can be tTranslated using Control+Right-Click+Drag on the mouse.

b. Probe the data by holdingHold down the middle mouse button over the display to probe the data.  The pProbe output readout will is be shown below the Main Display window.  Compare the output between the convective cloud tops over the Florida panhandle with to the cloud-free regions.
	Comment by Joleen Feltz: wording change to keep consistent with satellite tutorials which use the word “readout"
c. Observe the bowtie deletion effect on the eastern and western edges of the granule.  This is shown by black stripes of missing data going through the image. In Problem Set #1 below, a plugin will be installed that will introduces two formulas to that remove these stripes of missing datathe bowtie effect.

Displaying Day/Night Band Data
6. Remove All Layers and Data Sources from the previous displays via the Edit -> Remove ->All Layers and Data Sources menu item in the Main Display. 

7. Create a new tab via the File -> New Display Tab -> Map Display -> One Panel menu item.



8. Load in the Suomi NPP Day/Night band granule.

a. In the Data Sources tab of the Data Explorer, navigate to the Under Development -> Imagery - Suomi NPP chooser.

b. Under Files, select the following file:

<local path>/ Data/NPP/DayNightBand/GNDBO-SVDNB_npp_d20121013*

Note that this file packages the geolocation (GNDBO) and the data (SVDNB) together into the same file.  Therefore, only this one file is included in <local path>/ Data/NPP/DayNightBand/.

c. Click the Add Source button.

9. Select the field to display, the display type, and display the data at full-resolution.

a. In the Fields panel of the Field Selector, expand the IMAGE dropdown to view the fields included with the data.  Select the VIIRS-DNB-SDR_ALL/Radiance field.

b. In the Displays panel, select Imagery -> Image Display.

c. In the Region panel, subset out a region in the bottom half of the data granule by using Shift+Left Click+Drag.  Anything contained with the green bounding box will be displayed at full-resolution.  Note that the entire region must be contained within the granule’s data.

d. Click Create Display.

10. Adjust the display to make the aurora borealis visible.

a. Zoom in onto the region of interest in the Main Display by using Shift+Left-Click+Drag to choose an area containing the data (Alaska extending into Canada).  As before, the mouse can control display zoom and translation.  Experiment with the zooming in/out using the scroll wheel on the mouse. Translate using Control+Right-Click+Drag on the mouse.
The display region can be further customized by zooming in/out with the scroll wheel on the mouse and the display can be translated using Control+Right-Click+Drag.

b. Adjust the colorbar range to make the data visible by Right-Clicking on the colorbar in the Legend of the Main Display and selecting Change Range.  In the Change Range window, set From to 1E-9 and set To to 3E-8.  Click OK.



Problem Sets
The previous examples were intended to give you aprovided general knowledge for loading and displaying Suomi NPP data with the McIDAS-V software package.of how to load and display Suomi NPP data.  The problem sets below are intended to introduce you to new topics related to the data, as well as challenge expand your knowledge of McIDAS-V.  We It is recommended that you attempt to complete each problem set before looking at the solutions, which are provided below the problem set.
1. Using the <local path>/ Data/NPP/SandyRGB/GMODO* file, create an RGB image using the Reflectance field of all three bands.  
a. Use the plugin manager (Tools->Plugins->Manage) to install the VIIRS formula plugin.
b. Create the display by using the VIIRS_M_RGB(M5,M4,M3) formula that will be available once after you install the VIIRS Formulas plugin is installed.  
c. Display the data at full-resolution and make sure to includinge clouds as well as cloud-free land and water areas in your the subsetted region.  Adjust the Common Gamma field in the Layer Controls to make the individual colors stand out more in the display.

2. Aggregate the SVM12* files contained in <local path>/ Data/NPP/Fire/SVM12* together to create a display of Brightness Temperature to investigate fire activity over Idaho.  
a. Use the swathToGrid formula to remove the bowtie.  Display the data over Idaho at full-resolution.
b.   Once the display is created, cChange the colorbar to Inverse Gray Scale, and use the Color Table Editor to make the hot spots stand out better.  
c. Add a breakpoint at 300, color it yellow, and color the high-end breakpoint red.  Interpolate the colors between these two breakpoints.  Save the colorbar so it can be used in the future.  

3. Overlay the results of Problem Set #2 with the VIIRS-CM-IP_All/QF2_Fire_Detected field contained in the <local path>/ Data/NPP/Fire/GMODO* cloud mask file to verify that the cloud mask field’s display matches the SVM12 brightness temperature display.



Problem Set #1 – Solution
[image: ]Using the <local path>/ Data/NPP/SandyRGB/GMODO* file, create an RGB image using the Reflectance field of all three bands.  Create the display by using the VIIRS_M_RGB(M5,M4,M3) formula that will be available once you install the VIIRS Formulas plugin.  Display the data at full-resolution and make sure to include clouds as well as cloud-free land and water areas in your subsetted region.  Adjust the Common Gamma field in the Layer Controls to make the individual colors stand out more in the display. 

1. In the Main Display window, navigate to the Tools 
-> Plugins -> Manage menu item to open the Plugin Manager.

a. The top of the Plugin Manager lists plugins currently installed, and the bottom panel lists out various plugins packaged with McIDAS-V.  Expand the Miscellaneous tree and click the green Install Plugin button next to VIIRS Formulas. 

b. This pops up aA message message appears informing you that McIDAS-V must be restarted to complete the installation of the plugin.  Click OK.   through this message andThen, restart McIDAS-V.

c. Once McIDAS-V has restarted, navigate to the Field Selector tab of the Data Explorer and where two new formulas will beare listed: VIIRS_M_RGB(M5,M4,M3) and swathToGrid.  These formulas were added from the VIIRS Formulas plugin.

2. Load in a multi-banded VIIRS SVM granule.  This data file contains three bands of SVM visible data (SVM03, SVM04 and SVM05).

a. In the Data Sources tab of the Data Explorer, navigate to the Under Development > Imagery – Suomi NPP chooser.

b. Under Files, select the following file:

<local path>/ Data/NPP/SandyRGB/GMODO-SVM03-SVM04-SVM-5_npp*

Note that this file packages the geolocation (GMODO) and the data (SVM*) together into the same file.  Therefore, only this one file is included in <local path>/ Data/NPP/SandyRGB/.

c. Click the Add Source button.

3. Use the VIIRS_M_RGB(M5,M4,M3) formula to create a true-colored RGB display of this data and remove the bowtie deletion.

a. In the Field Selector tab, under Data Sources select Formulas.

b. Under Fields, select the VIIRS_M_RGB(M5,M4,M3) formula.  Click Create Display.

c.  In the new Field Selector window, select:

· For Field: M5, select VIIRS -> IMAGE -> VIIRS-M5-SDR_All/Reflectance 
· For Field: M4, select VIIRS -> IMAGE -> VIIRS-M4-SDR_All/Reflectance
· [image: ]For Field: M3, select VIIRS -> IMAGE -> VIIRS-M3-SDR_All/Reflectance

d. In the Region tab of Field: M5, use Shift+Left-Click+Drag to select a region to display at full-resolution.  Select a region that contains clouds, as well as cloud-free areas.  It is not necessary to subset a region in for M4 and M3, as the region selected for M5 will be used for all fields.

e. Click OK to display the results of the VIIRS_M_RGB(M5,M4,M3) formula.

4. Adjust the display to make the Red, Green, and Blue components of the display stand out.

a. Navigate to the Layer Controls tab of the Data Explorer.  By default, all Gamma values for all colors are set to 1.0.  Change this value to 0.4 by entering in 0.4 in the Common Gamma field and clicking the Apply to All Gamma Fields button.

b. Return to the Main Display window to observe the RGB display of Hurricane Sandy and also notice that the bowtie effect has been removed by the formula.

Problem Set #2 – Solution
Aggregate the SVM12* files contained in <local path>/ Data/NPP/Fire/SVM12* together to create a display of Brightness Temperature to investigate fire activity over Idaho.  Use the swathToGrid formula to remove the bowtie.  Display the data over Idaho at full-resolution.  Once the display is created, change the colorbar to Inverse Gray Scale, and use the Color Table Editor to make the hot spots stand out better.  Add a breakpoint at 300, color it yellow, and color the high-end breakpoint red.  Interpolate the colors between these two breakpoints.  Save the colorbar so it can be used in the future.  Load in the three VIIRS SVM12 granules.
1. Remove All Layers and Data Sources from the previous displays.

2. In the Data Sources tab of the Data Explorer, navigate to the Under Development -> Imagery -> Suomi NPP chooser.

a. Under Files, use Shift+Click to select the following three files:

<local path>/ Data/NPP/Fire/SVM12_npp_d20130811_t1011478_e1013120_b*
<local path>/ Data/NPP/Fire/SVM12_npp_d20130811_t1013132_e1014374_b*
<local path>/ Data/NPP/Fire/SVM12_npp_d20130811_t1014386_e1016028_b*

Note that the <local path>/ Data/NPP/Fire directory includes three GMTCO* files (one for each SVM12* file).  These GMTCO* files contain the geolocation data necessary for McIDAS-V to plot the SVM12 data.  These GMTCO* files cannot be selected in the Data Sources tab of the Data Explorer, only the SVM12 files can be chosen.

b. Click the Add Source button.  Adding these three files at once will aggregate the data together, combining the three individual granules into a single image.

3. Use the swathToGrid formula to create a full-resolution display of the data without the bowtie deletion.

a. In the Field Selector tab, under Data Sources select Formulas.

b. Under Fields, select the swathToGrid formula.

c. Under Displays, select Imagery > Image Display.  Click Create Display.

d. In the new Select input window, enter 750 for res and 1.0 for mode.  Click OK.

e. [bookmark: _GoBack]In the Field Selector, select VIIRS* -> IMAGE -> VIIRS-M12-SDR_All/BrightnessTemperature.

f. In the Region tab, use Shift+Left Click+Drag to select a region over Idaho to display at full-resolution.

g. Click OK to display the result of the swathToGrid formula.

4. Adjust the display to make the fires over Idaho easier to see.

a. Change the colorbar to Inverse Gray Scale.  To do this, Right-Click on the colorbar in the Legend and select System -> Inverse Gray Scale.  This is done to make the lower data values (colder temperatures, such as clouds) display as white, while warmer temperatures are black.

b. Add a color enhancement to the upper end of the colorbar to make the highest temperatures stand out.  To do this, Right-Click on the colorbar in the Legend and select Edit Color Table.

c. In the Color Table Editor window, Right-Click on the colorbar and select Add Breakpoint -> At Data Point.  In the Breakpoint Value window, enter in a value of 300 and click OK.

d. [image: ]Change the color of the 300 breakpoint to yellow.  To do this, using the HSB tab, move the slider to yellow.  In the color panel within the HSB tab, Left-Click+Drag to select a bright yellow color.  This will change the 300 breakpoint to yellow.

e. Change the color for the upper end of the colorbar to red.  To do this, select the breakpoint on the right side of the colorbar to make this breakpoint active.  This breakpoint is denoted by an upside-down triangle.  Once this breakpoint is active, a yellow outline will be drawn around the breakpoint’s triangle.  Use the method in step d above to select a red color.

f. Interpolate between the breakpoints by Right-Clicking on the upper breakpoint and selecting Edit Colors -> Interpolate -> Left.

g. Save the colorbar to be used in the future by selecting File -> Save As.  Enter in a name of Fire and click OK.  This colorbar will now be available to use in the future by Right-Clicking on a colorbar in the Legend of the Main Display and selecting System -> Fire.  Note that this System comes from the Category dropdown menu in the Color Table Editor.  This value can be changed by the user.

h. Return to the display in the Main Display window to view the fires over Idaho.  Notice that the hotspots are now colored yellow, orange and red.  Probe the data to investigate the difference in brightness temperature between the fires and cloud-free land.



Problem Set #3 – Solution
Overlay the results of Problem Set #2 with the VIIRS-CM-IP_All/QF2_Fire_Detected field contained in the <local path>/ Data/NPP/Fire/GMODO* cloud mask file to verify that the cloud mask field’s display matches the SVM12 brightness temperature display.
1. In the Data Sources tab of the Data Explorer, navigate to the Under Development -> Imagery -> Suomi NPP chooser.

a. Under Files, use Shift+Click to select the following file:

<local path>/ Data/NPP/Fire/GMODO-IICMO_npp_d20130811_t1008587_ e*

Note that the <local path>/ Data/NPP/Fire directory includes one GMODO-IICMO file.  Note that this file packages the geolocation (GMODO) and the data (IICMO*) together into the same file.  

b. Click the Add Source button.

2. Use the swathToGrid formula to create a full-resolution display of the data without the bowtie deletion.

a. In the Field Selector tab, select Formulas under Data Sources.

b. Under Fields, select the swathToGrid formula.

c. Under Displays, select Imagery -> Image Display.

d. Click Create Display.

e. In the new Select input window, enter 750 for res and 1.0 for mode.  Click OK.

f. In the Field Selector window, select VIIRS* -> IMAGE -> VIIRS-CM-IP_All/QF2_Fire_Detected.

g. In the Region tab, use Shift+Left Click+Drag to select a region over Idaho to display at full-resolution.

3. Click OK to display the result of the swathToGrid formula.

4. In the Main Display, toggle the visibility of the cloud mask field on and off by clicking the visible checkbox in the Legend.  There should be white pixels from the cloud mask field that overlap with the higher SVM12 brightness temperatures.





The following table lists out band, wavelength and resolution information for VIIRS SVM, DNB (Day/Night Band) and SVI data.  Source: http://rammb.cira.colostate.edu/projects/npp/

[image: ]



Zooming, Panning, and Rotating Controls

	Zooming
	Panning
	Rotating

	
	Mouse
	

	Shift-Left Drag: Select a region by pressing the Shift key and dragging the left mouse button.
Shift-Right Drag: Hold Shift key and drag the right mouse button. Moving up zooms in, moving down zooms out.
	Control-Right Mouse Drag: Hold Control key and drag right mouse to pan.
	Right Mouse Drag: Drag right mouse to rotate.

	
	Scroll Wheel
	

	Scroll Wheel-Up: Zoom Out.
Scroll Wheel-Down: Zoom In.
	
	Control-Scroll Wheel-Up/Down: Rotate clockwise/counter clockwise.
Shift-Scroll Wheel-Up/Down: Rotate forward/backward clockwise.

	
	Arrow Keys
	

	Shift-Up: Zoom In.
Shift-Down: Zoom Out.
	Control-Up arrow: Pan Down.
Control-Down arrow: Pan Up.
Control-Right arrow: Pan Left.
Control-Left arrow: Pan Right.
	Left/Right arrow: Rotate around vertical axis.
Up/Down arrow: Rotate around horizontal axis.
Shift-Left/Right arrow: Rotate Clockwise/Counterclockwise.
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