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McIDAS-V Tutorial
Installation and Introduction
updated September December 2013 (software version 1.4)


McIDAS-V is a free, open source, visualization and data analysis software package that is the next generation in SSEC's 40-year history of sophisticated McIDAS software packages. McIDAS-V displays weather satellite (including hyperspectral) and other geophysical data in 2- and 3-dimensions. McIDAS-V can also analyze and manipulate the data with its powerful mathematical functions. McIDAS-V is built on SSEC's VisAD and Unidata's IDV libraries, and contains "Bridge" software that enables McIDAS-X users to run their commands and tasks in the McIDAS-V environment. The functionality of SSEC's HYDRA software package is also being integrated into McIDAS-V for viewing and analyzing hyperspectral satellite data.

More All training materials are available on the McIDAS-V webpage and in the Getting Started chapter of the McIDAS-V User’s Guide, which is available from the Help menu within McIDAS-V. Notifications at McIDAS-V startup alert users when there is a new version of McIDAS-V is available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/You will be notified at the startup of McIDAS-V when new versions are available on the McIDAS-V webpage - http://www.ssec.wisc.edu/mcidas/software/v/ .
Please post If you encounter an eerror reports or would like tofeature requests an enhancement, please post it  to the McIDAS-V Support Forums - http://www.ssec.wisc.edu/mcidas/forums/. The forums also provide the opportunity to share information with other users.

Terminology
There are two windows displayed when McIDAS-V first starts, the McIDAS-V Main Display (hereafter Main Display) and the McIDAS-V Data Explorer (hereafter Data Explorer).
The Data Explorer contains three tabs that appear in bold italics throughout this document:  Data Sources, Field Selector, and Layer Controls.  Data is selected in the Data Sources tab, loaded into the Field Selector, displayed in the Main Display, and output is formatted in the Layer Controls.
Menu trees will beare listed as a series (e.g. Edit -> Remove -> All Layers and Data Sources).
Mouse clicks will beare listed as combinations (e.g. Shift+Left Click+Drag).










Installation of McIDAS-V
The installation of McIDAS-V is a simple three step procedure (download, install, and run).

1.  Download the appropriate package for your operating system from the McIDAS-V webpage.  This file is only the installer and can be placed anywhere on your machine.  The McIDAS-V installation directory will be defined in the next step, When when you run the installer in the next step, you can then indicate where you want McIDAS-V to be installeds run.  The system requirements for McIDAS-V are also listed on the McIDAS-V webpage.

2.  Install McIDAS-V:   by sStarting the installer by following the instructions appropriate for your operating system:
		Mac OS X		mount the .dmg and double-click the installer
		Windows		double-click the downloaded .exe file
	All other platforms	open a terminal window and run sh ./<installer>.sh

[image: ] 

A GUI will walk you throughassists the installation steps process and allows you to creation ofe a program group and/or desktop icon.

3.  Run McIDAS-V:  by fFollowing the instructions appropriate for your operating system:
	
	Mac OS X		Double-click on the McIDAS-V shortcut icon that was created in /Applications.
	Windows	Double-click on the McIDAS-V shortcut icon that was created on the Desktop.
	All others	At the UNIX prompt from the directory where McIDAS-V was installed, 
			run the command: McIDAS-V-System/runMcV

Note:  By default, McIDAS-V uses 80% of the available machine memory on your machine. The maximum amount of memory is determined by the operating system. To manually change the amount of memory used by McIDAS-V, edit the Maximum Heap Size 
· Select Edit -> Preferences from the main menu
· in tSelect the Advanced tab of the Users Preferences by selecting 
Edit -> Preferences... from the main menu. 
· Enter the desired memory usage under Starup Options
· The new amount of memory will is be saved and used in subsequent sessions. For 32 bit operating systems, it is recommended to set this to no more than 1250 MB. The maximum value for 32 bit operating systems is 1536 MB. 
· To change the amount of memory used to a percentage, select the percentage option in the Advanced tab of the Preferences by selecting 
Edit -> Preferences... from the main menu. The new amount of memory that you enter will be saved and used in subsequent sessions.  Exit McIDAS-V and start a new session to use this new memory setting.

Welcome Window

Upon initial startup, the Welcome to McIDAS-V window will beis displayed.

[image: Welcome-Window]
Please be sure to read this the IMPORTANT NOTICE:  .  Because McIDAS-V utilizes the latest developments in Java 3D programming and video driver updates, it is often necessary to update video drivers to solve some seemingly unrelated performance problems.  Do not assume that because you have a new machine, you have the latest drivers.  We have found brand new machines with drivers that are more than five years old!


After reading the notice in the Welcome window, click Quit to close the window, or click Start McIDAS-V to close the window and start McIDAS-V.  Once McIDAS-V has been started, this window will not appear again.


Introduction to McIDAS-V windows
There are two main windows in the McIDAS-V application - the Data Explorer window and the Main Display window. Other windows may appear when needed.
	

	[image: ../images/MainWindow.gif]




Data Explorer (shown on the left)
The Data Explorer window is central to McIDAS-V. It is used to choose the data display options.  These options include the data source, s and parameters to display, the kinds of display types to make, and times of data to displayalong with data times and any region selection or data reduction.  The Tfirst time McIDAS-V starts up, the Data Explorer defaults to the Satellite -> Imagery Chooser for the first run of McIDAS-V.  This chooser, along with several others, uses ADDE (Abstract Data Distribution Environment) servers to access data.  McIDAS-V comes withhas a pre-configured list of several available free servers which contain real-time and archived atmospheric datasets.

Main Display (shown on the right)
The Main Display window includes the McIDAS-V display panels, legend, time animation controls, viewpoint controls for 3D displays, icons to zoom and pan, menus to control views and projections, and the main McIDAS-V menu. Navigating Navigate to Help -> User’s Guide in the Main Toolbar brings up theto access the McIDAS-V User’s Guide, which has both a table of contents and a search function.

Common Usage Scenario
To create displays of data with McIDAS-V, the common usage scenario is:workflow is
· Choosing Choose the data source of data (local files, remote servers, etc.)
· Selecting parameters and display type
· Creating Create the display
· Controlling the display
· Creating Create a bundle and/or save images and movies


Bundles
Bundles let you save a quick "snapshot" of McIDAS-V, including data sources, maps, and data displays. Bundles are small informationconfiguration files that specify the state of McIDAS-V. They are a kind of configuration file. They include information about what data sources are in use, which parameters from the data sources are displayed, and how they are displayed.  In a sense, they are a “snapshot” of a particular McIDAS-V session.
The purpose of bundles is for you to save a particular McIDAS-V setup and display. A bundleBundles can be used save work forfor your own future reference at a later time, or others using McIDAS-V can use bundles you made to see data the same way you didcan be used to share McIDAS-V data and displays with colleagues. There are two types of bundles, regular *.mcv bundles, and *.mcvz zipped bundles. These serve different purposes.
The *.mcv bundle, along with storing the setup and display options, stores a reference to the particular type of data you have loaded into McIDAS-V. For example, if you load in the most recent GFS, display pressure, and save your the display as a *.mcv bundle, the next  time the bundle is loaded, McIDAS-V will connect to the same server/catalog where you gotfrom which the data from was originally retrieved, and display the most recent GFS pressure data. This type of bundle can be very useful in an operational environment, where you often wanit is desirable t to look at the same products but displaying the most recent data.
The *.mcvz bundle is different from the *.mcv bundle in thatbecause it actually stores data along with the bundle. For example, if you load in radar data for a tornado case is loaded that you want to look at again, but thatthat may not be on the server at a later date, you can save yourthe display can be saved as a *.mcvz zipped bundle. The next time this bundle is loaded inloaded, the same exact data with the same display options will beis displayed. This can beis useful for case studies, where you always wantit is desirable to look at the same data.



Data Explorer - Data Sources tab
[image: dataexplorer2] 
The Data Sources tab is used to locate remote data servers or local files for display in McIDAS-V.  Once the type of data source is selected, a chooser with the appropriate selection criteria is displayed.  Satellite -> Imagery is chosen above, and the Satellite -> Imagery chooser is displayed.  Other data source types are the HYDRA multi-spectral display, Radar, Point Observations, Gridded Data, General files, and the McIDAS-X bridge.

Data Explorer - Field Selector tab
[image: ]
The Field Selector tab analyzes the data source to determine the displayable fields and parameters.  With this information, a list of available displays is presented.  In the Subset panel of the Field Selector there are tabs to select which times to display, which region to use, as well as a variety of advanced options. Note that the tabs in the Subset panel will differ dependent on which data source you is loaded.

Data Explorer - Layer Controls tab
[image: ]

Displayed fields and parameters are known as Layers. The Layer Controls tab contains the display options for the displayed fields and parameters which are referred to aseach layers.  Changes made to each any layer will be reflected in the Main Display.  Also, if a graphs, time series or and all  non-navigated special displays was selected, it will display are drawn in the Layer Controls.



Introduction to McIDAS-V controls

1. Load the <local path>/Data/Installation/Intro-Bundle.mcvz bundle to display NCEP GFS data in the Main Display window.

a. In Use the Main Menu Bar in of the Main Display window of McIDAS-V, Left Click to select File -> Open File….

b. In the file browser, “Look In” the location where you downloaded the data files for this tutorial, select Intro-Bundle.mcvz and Left Click Open.

c. When prompted, select Replace Session to replace the current window with the contents of the bundle and Left Click OK.

d. Select Remove all layers.

e. Select Remove all data.

f. Select Write to temporary directory, check Don’t show this again, and Left Click OK.

The Main Display will change to a view from the south, and two new 3D Surfaces will be listed in the right panel Legend in the right panel of the Main Display window.  One surface is a color-shaded image over topography.  The other surface is an 50 m/s wind speed isosurface of a constant wind speed of 50 m/s.  The yellow isosurface is shadowed for perspective,perspective; otherwise it would be one block of color.

2. Click and drag the right mouse button to rotate the display.  Use the navigation controls listed on the last page of this document or the navigation controls on the left side of the Main Display to zoom in and out, and “move through” the data.

3. Toggle the 3D surfaces on and off in the display by clicking the checkbox next to each item in the Legend on the right side of the Main Display window.

4. Click on the name of each item in the Legend to bring upaccess the Layer Control and s to change the color table or the isosurface values.  To change the display unit of the isosurface to something other than m/s, in  use the Layer Controls menu and select Edit -> Change Display Unit.

5. Use the Time Animation controls at the top of the Main Display to loop through the imagesanimate, or step through them one by onethe image sequence.


Apply Customized Display Settings to Multiple Layers

1. Navigate to the Layer Controls.  Under “Tab 1>Panel 1”, Select the top of the two layers listed “Latest NCEP GFS CONUS…” 

2. From the Layer Controls menu, select EditProperties

3. Locate the “Legend Label”  text input dialog box (see image below):  



a. Remove:  “%datasourcename% - %displayname%” 
b. Type:  “%displayname% - %longname%
c. The first layer should be labeled “Topography – Geopotential…”  when steps 3a-b are complete.

4. From the layer control, select EditDisplay Settings…
a. Note, the “Topography” layer is highlighted under the Source Displays dialog box.  The settings for this layer are active in the Properties dialog box, and can be applied to other layers.
b. Under the Properties dialog box, check “Legend Label”
c. Under Target Displays select “Latest NCEP GFS CONUS 80 km – Isosurface…” (See illustration below)
d. Click “Apply>>”.  The second layer should be labeled “Isosurface – Speed (from…” when steps 4a-c are complete.

This technique can be used to efficiently apply color tables, ranges, and many display settings to multiple layers.

Data Explorer - Layer Controls tab – Display Settings

[image: ]




Moving a layer to a new panel

1. Open a new tab using FileNew Display TabMap DisplayTwo Panels

2. Navigate to the Layer Controls.  Select the “Topography – Geopotential…” layer.
a. Place the mouse over “Drag and Drop” tool ([image: ]), 

b. Hold the left mouse button.  

c. Continue holding left mouse button while moving the “Drag and Drop” square over “untitled >Panel 1.”    

d. Release the left mouse button. 

e.  The displayed layer is now in panel 1 of the two-panel display.

3. Repeat steps 2a-d for the “Isosurface – Speed” layer.  Place the “Isosurface-Speed” layer in “untitled>Panel 2”



[image: ]







Below is a list of supported data types, formats, and the method to access them in McIDAS-V.

	Data Type
	Description
	Supported Formats
	Access Method

	Gridded
 
 
 
	Numerical weather prediction models, climate analysis, gridded
oceanographic datasets, NCEP/NCAR Reanalysis
	netCDF
	local files, HTTP, TDS Servers

	
	
	GRIB (versions 1&2)
	local files, TDS Servers

	
	
	Vis5D
	local files, HTTP

	
	
	GEMPAK
	local files, TDS Servers

	Satellite
Imagery
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
	Geostationary and polar orbiter satellite imagery, derived satellite products
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
	ADDE
	ADDE servers, local & remote

	
	
	McIDAS AREA
	local files, local & remote ADDE

	
	
	AIRS
	local files

	
	
	GINI
	local files, TDS servers

	
	
	AMSR-E Level 1b
	local ADDE

	
	
	AMSR-E Rain Product
	local ADDE

	
	
	EUMETCast LRIT
	local ADDE

	
	
	Meteosat OpenMTP
	local ADDE

	
	
	Meteosat Second Generation 
(MSG) Level 1b
	local ADDE

	
	
	Metop AVHRR Level 1b
	local ADDE

	
	
	MODIS L1b MOD02 
(MODIS Level 1b)
	local ADDE

	
	
	MODIS L2 MOD04 
(Level 2 Aerosol)
	local ADDE

	
	
	MODIS L2 MOD06 
(Level 2 Cloud Top Properties)
	local ADDE

	
	
	MODIS L2 MOD07 
(Level 2 Atmospheric Profile)
	local ADDE

	
	
	MODIS L2 MOD28 
(Level 2 Sea Surface Temperature Products)
	local ADDE

	
	
	
	 

	
	
	MODIS L2 MOD35 
(Level 2 Cloud Mask)
	local ADDE

	
	
	MODIS L2 MODR 
(Level 2 Corrected Reflectance)
	local ADDE

	
	
	MSG HRIT FD and HRV
	local ADDE

	
	
	MTSAT HRIT
	local ADDE

	
	
	NOAA AVHRR Level 1b
	local ADDE

	
	
	SSMI (TeraScan netCDF)
	local ADDE

	
	
	TRMM (TeraScan netCDF)
	local ADDE

	Radar
	Radar images
 
 
	Level II
	local files or TDS (bzip2 compressed or uncompressed)

	
	
	 
	

	
	
	Level III/TDWR
	ADDE Servers, local files or TDS

	
	
	Universal Format (UF)
	local files

	
	
	DORADE
	local files




	Data Type
	Description
	Supported Formats
	Access Method

	Point
Observational
 
 
 
 
 
	Surface observations (METAR and
SYNOP), earthquake observations
 
	ADDE
	ADDE servers

	
	
	netCDF (Unidata, AWIPS/MADIS formats)
	local files

	
	
	Text (ASCII, CSV), Excel spreadsheet
	local files

	
	Global balloon soundings (RAOB)
 
 
	ADDE
	ADDE servers

	
	
	netCDF (Unidata, AWIPS/MADIS formats)
	local files

	
	
	CMA text format
	local files

	
	NOAA Profiler Network winds
	ADDE
	ADDE servers

	Trajectory
 
	Aircraft observations
 
	netCDF (RAF convention)
	local files

	
	
	Text (ASCII, CSV)
	local files

	GIS
 
	Data typically used in Geographic Information Systems (GIS)
	ESRI Shapefile
	local files, HTTP

	
	
	USGS DEM
	local files

	QuickTime
 
	QuickTime movies (without extensions)
	QuickTime
	local files, HTTP

	
	
	 
	 




Zooming, Panning, and Rotating Controls

	Zooming
	Panning
	Rotating

	
	Mouse
	

	Shift-Left Drag: Select a region by pressing the Shift key and dragging the left mouse button.
Shift-Right Drag: Hold Shift key and drag the right mouse button. Moving up zooms in, moving down zooms out.
	Control-Right Mouse Drag: Hold Control key and drag right mouse to pan.
	Right Mouse Drag: Drag right mouse to rotate.

	
	Scroll Wheel
	

	Scroll Wheel-Up: Zoom Out.
Scroll Wheel-Down: Zoom In.
	
	Control-Scroll Wheel-Up/Down: Rotate clockwise/counter clockwise.
Shift-Scroll Wheel-Up/Down: Rotate forward/backward clockwise.

	
	Arrow Keys
	

	Shift-Up: Zoom In.
Shift-Down: Zoom Out.
	Control-Up arrow: Pan Down.
Control-Down arrow: Pan Up.
Control-Right arrow: Pan Left.
Control-Left arrow: Pan Right.
	Left/Right arrow: Rotate around vertical axis.
Up/Down arrow: Rotate around horizontal axis.
Shift-Left/Right arrow: Rotate Clockwise/Counterclockwise.
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